Intel® NUCs
Support for Intel® NUC products
Announcements
Do you have improvements you would like us to make on this community site? If so, we would love to hear your feedback! Click here for an 8 question survey. Thanks!

11282 Discussions

NUC10I7FNH with Razer Core / Nvidia Geforce 3060TI

Lagouach
Beginner
333 Views

Hello,

Impossible to connect my Razer Core (3060TI inside) on the Thunderbolt.

The screen display the desktop just 10 seconds and it crash with a windows 10 error message - SYSTEM_THREAD_EXCEPTION_NOT_HANDLED -

I tried to install the latest version of graphic card driver without result.

I tried to install the latest version of the intel Thunderbolt port without result.

Has someone already encountered the problem?

0 Kudos
1 Solution
Victor_G_Intel
Moderator
303 Views

Hello Lagouach,


Thank you for posting on the Intel® communities.


Based on the information provided we would like to recommend the following:


-Go to NVIDIA.com to get the latest NVIDIA GPU drivers.

·        Uninstall the current GPU drivers in your system and then perform a clean fresh driver install.

·        Install the latest driver for the NVIDIA GPU card.


-Set the power mode in the NVIDIA control panel to Maximum Performance.

·        To do this, go to 3D Setting > Global Setting > Power Management Setting > Maximum Performance.


-Try To test the unit with a different Thunderbolt cable.


-Set BIOS defaults on the Intel NUC:

·        Press F2 during boot to enter BIOS Setup.

·        Press F9 to load default settings.

·        Press F10 to save and exit BIOS.


-Confirm Windows® 10 is current by using the Windows Update feature.


-In Windows Power & Sleep Settings, turn off PCI Link Power Management:


Steps:


·        Go to Control Panel > Hardware and Sound > Power Options.

·        Select Change Plan Settings.

·        Select Change Advanced Power Settings.

·        Go to PCI Express > Link State Power Management.

·        Set On Battery and Plugged In to Off.

·        Click OK.


-In BIOS try the following steps:


·        Press F2 during boot to enter BIOS Setup.

·        Change Power Mode to High Performance.

·        Disable Intel Virtualization Technology for I/O (VT-d) under the Security menu.

·        Disable Advance State Power Management under Power-> Secondary Power Settings.

·        Set Thunderbolt Security Level to Legacy.

·        Press F10 to save and exit BIOS.


-Test the eGPU on a different system (other than an Intel NUC) to ensure it's in working condition.


I look forward to hearing from you.


Regards,


Victor G.

Intel Technical Support Technician 


View solution in original post

5 Replies
Victor_G_Intel
Moderator
315 Views

Hello Lagouach,


Thank you for posting on the Intel® communities.


To better assist you please provide the following report to continue with your support request.


Please run the following tool and attach the report generated.  

   

-Intel® System Support Utility (Intel® SSU)


Download link: https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-

 

•          Open the application and click on "Scan" to see the system and device information

•          By default, Intel® SSU will take you to the "Summary View".  

•          Click on the menu where it says "Summary" to change to "Detailed View".  

•          To save your scan, click on "Next", then "Save".  



I look forward to hearing from you.


Regards,


Victor G.

Intel Technical Support Technician  


Lagouach
Beginner
311 Views

Hello @Victor_G_Intel,

Thank you for your help.

There is the report in attachement.

Regards,

Victor_G_Intel
Moderator
304 Views

Hello Lagouach,


Thank you for posting on the Intel® communities.


Based on the information provided we would like to recommend the following:


-Go to NVIDIA.com to get the latest NVIDIA GPU drivers.

·        Uninstall the current GPU drivers in your system and then perform a clean fresh driver install.

·        Install the latest driver for the NVIDIA GPU card.


-Set the power mode in the NVIDIA control panel to Maximum Performance.

·        To do this, go to 3D Setting > Global Setting > Power Management Setting > Maximum Performance.


-Try To test the unit with a different Thunderbolt cable.


-Set BIOS defaults on the Intel NUC:

·        Press F2 during boot to enter BIOS Setup.

·        Press F9 to load default settings.

·        Press F10 to save and exit BIOS.


-Confirm Windows® 10 is current by using the Windows Update feature.


-In Windows Power & Sleep Settings, turn off PCI Link Power Management:


Steps:


·        Go to Control Panel > Hardware and Sound > Power Options.

·        Select Change Plan Settings.

·        Select Change Advanced Power Settings.

·        Go to PCI Express > Link State Power Management.

·        Set On Battery and Plugged In to Off.

·        Click OK.


-In BIOS try the following steps:


·        Press F2 during boot to enter BIOS Setup.

·        Change Power Mode to High Performance.

·        Disable Intel Virtualization Technology for I/O (VT-d) under the Security menu.

·        Disable Advance State Power Management under Power-> Secondary Power Settings.

·        Set Thunderbolt Security Level to Legacy.

·        Press F10 to save and exit BIOS.


-Test the eGPU on a different system (other than an Intel NUC) to ensure it's in working condition.


I look forward to hearing from you.


Regards,


Victor G.

Intel Technical Support Technician 


View solution in original post

Victor_G_Intel
Moderator
288 Views

Hello Lagouach,


Were you able to check the previous post?  


Please let me know if you need further assistance.  


Best regards,


Victor G. 

Intel Technical Support Technician


Victor_G_Intel
Moderator
275 Views

Hello Lagouach,


We have not heard back from you.


If you need any additional information, please submit a new question as this thread will no longer being monitored 


Victor G. 

Intel Technical Support Technician  


Reply