Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
421 Views

NUC10I7FNK + Thunderbolt eGPU (Radeon VII) not working

Hi,

 

My setup is as follows:

  • NUC10i7FNK (with latest BIOS update)
  • Samsung SSD 970 EVO PLUS 500GB
  • Corsair Vengeance 2666mhz 2x8gb
  • eGPU case: Asus XG Station Pro
  • GPU: Sapphire Radeon VII
  • OS: Windows 10 Pro version 1909

 

I bought this setup to be able to bring the NUC to work at daytime and sometimes game at home in nighttime. The perfect combination of hardware, at least on paper. In reality it turned out to be a very complicated affair which is still not working as it should.

 

I am really struggling to get the NUC and Windows to recognize my eGPU. I have been reinstalling Windows a dozen times and tried to install official drivers in many different orders but still no luck. Windows always ends up with a yellow triangle on the Radeon VII and the a “Error 12” error message. Are there any specific order that I need to install the drivers?

 

I also tried an older version of Windows 10 Pro (version 1803) which works somewhat better, but I don’t see that as a good solution.

 

I also do not get any output from BIOS during boot on screen (with eGPU), which this NUC is supposed to support. BIOS shows up fine with the onboard HDMI connection though. I have configured BIOS to prefer output to Thunderbolt, so that is not the problem.

 

Since Intel is the creator and driving force behind Thunderbolt I thought this was going to be plug-and play. I actually managed to get my eGPU working on my 2017 MacBook Pro with Bootcamp, but not the NUC.

 

If there are anything I have missed here or if there are known problems with the NUC10I7FNK/NUC10i7FNH I would like to know. Please let me know if you can help out in any way.

0 Kudos
5 Replies
Highlighted
Super User
267 Views

Download, run, and ATTACH (using the paperclip under the toolbar) the results of this utility:

https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility

 

Doc

0 Kudos
Highlighted
Beginner
267 Views

I actually am having the same problem!

 

I'm using the NUC10i7k as well, (64b ram and a 1tb NVMe drive)

I'm using the Razer Core X external enclosure and the Radeon RX 5700 XT Card.

I previously had a Sapphire Pulse RX 580 card in the same enclosure, and same computer. That worked normally.

When the new card arrived today, I got the "Code 12" error.

 

I've dealt with this error in the past in other contexts. Code 12 means the OS doesn't have enough address space in the PCI bus to address the RAM of the GPU. This problem occurs because we're attaching the card through TB3 and not a normal PCIe slot. Windows uses a 32-bit addressing scheme which makes the beefier graphics cards unable to address their RAM. This is vexing because:

 

1) eGPU nonsense is what the NUC is built for.

2) This problem is actually Microsoft. In build 1903 of Windows MS changed a file to take up a little more address space than before, and it broke the addressing capabilities of 1903 and 1909

 

(I'm running Windows 10 version 1909, and that's the first OS this computer had.)

 

I submitted my SSU Report for your convenience.

 

 My understanding of the solution is limited:

 

As above installing 1809 works. I'm going to download the Insider Preview of 2005 (or is it May 2020?) and see if that fixes the problem.

 

0 Kudos
Highlighted
Beginner
267 Views

Last night, after posting on this forum I did a little more sleuthing, and found out that a few people on Reddit had put their NUCs in the Windows insider program to get the latest preview builds of Windows. They shared that it worked for them. I was intending to refresh my OS with 1809 and just avoid it, but I thought I'd give it a try.

 

It worked. I went with the "Fast" ring, and it took a couple of hours, but I've got the latest possible Windows build, everything is updated, my new RX 5700 XT is working. I'm going to start benchmarking in a minute, and I might disable windows update.

 

I hope this means that in the May 2020 Windows build they've addresses this issue. (because it's all over both the Intel forums, Reddit, and the egpu forums.)

 

good luck!

 

-Jeff

0 Kudos
Highlighted
Moderator
267 Views

Hello DAden

Thank you for posting on the Intel® communities.

 

We are checking this thread and we would like to know if you need further assistance. If yes, could you please provide the following information?

 

1- By any chance did you tried the suggestions recommended by JMoor58: Going back to Windows® 1809, Windows® 2004 (20H1 May 2020 Update) or testing with the Windows® Insider Preview of 2005?

 

2- Did you check the NUC BIOS, Graphics, and Firmware, especially Thunderbolt firmware are updated to the latest version?

You can find the latest available drivers in the below link, at the left side, click on "Drivers and Software"

https://ark.intel.com/content/www/us/en/ark/products/188808/intel-nuc-10-performance-kit-nuc10i7fnk....

 

3- Do you have installed the latest drivers and firmware for the "Sapphire Radeon VII" video card and the eGPU case Asus XG Station Pro?

 

4- Have you tried the following:

  • Set the Power Mode in NUC BIOS to: High Performance
  • Switch off PCI Link Power Management in Windows Power Settings.

 

5- Please run the Intel® System Support Utility (Intel® SSU) and attach the report to this thread.

5.1- Download the Intel® SSU and save the application on your computer.

https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-

 

5.2- Open the application and click "Scan" to see the system and device information. The Intel® SSU defaults to the "Summary View" on the output screen following the scan. Click the menu where it says "Summary" to change to "Detailed View".

 

5.3- To save your scan, click Next and click Save.

 

5.4- To attach a file, you must click the “Attach” option on the bottom left-hand corner of the response box.

 

Best regards,

 

Andrew G.

Intel Customer Support Technician

0 Kudos
Highlighted
Moderator
267 Views

Hello DAden

 

We have not heard back from you so we will proceed to close this thread. If you need further assistance, please do not hesitate to contact us back.

 

Best regards,

 

Andrew G.

Intel Customer Support Technician

0 Kudos