Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor I
351 Views

NUC10i3FNH issues following Windows updates 2004

Jump to solution

Hi all

I recently updated Windows 10 to the latest "2004" updates and I have had major issues since.

The major symptom is that on startup the computer is extremely slow for 10 minutes and shows in Task Manager performance tab that the HDD is at 100% utilisation. CPU utilisation is also very high. Strangely the Processes tab does not show anything that is using significant HDD.

Following the startup, the computer can be used but over a fairly short amount of time becomes unstable and freezes. No errors are received.

Searches on the internet indicate that it could be an issue with Optane, but I think those should have been fixed now? Are there any other known issues?

Thanks in advance for the help

Gareth

0 Kudos

Accepted Solutions
Highlighted
Super User
261 Views

Hi @GProc3 ,

  1. To my regret I don't have NUC10FN to make test for you. However it must be a bug in BIOS. You can see that on the  Information Panel, there is an explanation for the missing SATA mode "Intel RST Premium...". I can also see that BIOS versions 0042 and 0041 where pulled out by Intel from the Download site. Please read also  @sbmi post date 13-07-2020 in this thread.
  2. In this case, I suggest that you should downgrade your BIOS to version 0039, using BIOS Recovery from Power Button Menu Method:
  3. Prepare USB stick fully formatted to FAT32 (disable quick format option during format). Format your USB on Windows machine (rather than Linux or MAC). Save the Bios file FN0039.CAP on this stick. Important : the USB device must contain a folder \EFI\Intel, which contains the IN0039.CAP file. Otherwise the recovery will fail. ExampleD:\EFI\INTEL\IN0039.CAP
  4. and insert it into front USB slot with amber color (NUC shall be OFF). You may use also one of the rear USB ports (do not use front blue USB port, since sometime the USB stick is not recognized during boot process).
  5. Press and hold Power Button for about 3 seconds. Count 1001, 1002, 1003,1004. Release the Power Button. NUC should reboot into Power Button Menu. You should release the Power Button before 4-sec shut down override or when the Power Button LED changes color from blue to amber.
  6. Press F4 and the recovery shall start (it can take up to 30 seconds for messages to appear on the screen).
  7. When the recovery finishes, press on Power Button and hold it, until NUC switches OFF. Pull out the power cord. Remove the USB stick.
  8. Replace the power cord and press Power Button to switch the computer to ON. Let the NUC fully reboot.

Leon

 

View solution in original post

15 Replies
Highlighted
Super User
345 Views

1. In order to get better information about your system, please download the Intel System Support Utility (SSU). Run the SSU scan and save the results. The .txt file with the results please attach to your post.

2. Open Windows Settings> Update & Security > Troubleshoot > Additional Troubleshooters  and run Windows Update troubleshooter.

Leon

Highlighted
New Contributor I
338 Views

Thanks Leon

 

Text file attached

0 Kudos
Highlighted
Super User Retired Employee
331 Views

You have Optane? I hope you disabled it during this upgrade. If you didn't, I suggest that you (a) disable it now, (b) verify the consistency of the file system on your HDD and then (c) Enable Optane again.

...S

 

Highlighted
Super User
314 Views

Hi @GProc3 ,

1. From the SSU report I can see that you have 16GB Optane Memory, that suppose  accelerate your 1TB HDD. However the acceleration is now disabled.  Therefore, your NUC performance is degraded now. This probably happened as result that during update the Windows to version 2004, the  unallocated space (required for Optane), was overwritten by Windows Recovery Partition. For some reason (I don't know what is the reason), Microsoft (in version 2004) decided to assigned the end of drive for the Recovery Partition. Doing so, the Optane Enablement was corrupted. You can check if I am right, by looking at Disk Management. Probably you will find at the end of your system drive (C:), Recovery Partition, instead of some small unallocated space (5 - 20 MB), used by Optane. Probably you will see a second drive 16GB Optane Drive. 

2. I suggest that you should delete this Recovery Partition (this is how) and this will free the unallocated space in end of drive, needed for Optane. The Recovery Partition is not a must. You will be able always to boot into recovery environment, using Windows Installation Media.  If you want keep this Recovery Partition, using a third party software tool you can move it to other location on drive.

3. Once you have free space in the en of drive, try to re enable Optane Acceleration.  You can not succeed to do this since the Optane Memory is "dirty" with the old enablement and should be cleaned first. 

Leon

 

Highlighted
New Contributor I
299 Views
Hi thanks for this... in response to your points:

Point 1: yes all that you have said appears to be correct.

Point 2: partition has been removed using the method you described.

Point 3: I have been unable to reenable Optane, the Optane memory and storage management application says that no supported controllers are found.

What is the best way of enabling Optane?

Thanks again

0 Kudos
Highlighted
New Contributor I
298 Views
Hi thanks for this... in response to your points:

Point 1: yes all that you have said appears to be correct.

Point 2: partition has been removed using the method you described.

Point 3: I have been unable to reenable Optane, the Optane memory and storage management application says that no supported controllers are found.

0 Kudos
Highlighted
Super User
286 Views
  1.   Are you aware that your drive see is bitlocker encrypted? Just saying. This should not affect Optane  Acceleration. In order to enable Optane please follow next paragraphs:
  2. You need to prepare 5-15MB of unallocated space in the end of your System Drive (drive C:). You may do this in Disk Management, shrinking the C: partition in the end.
  3.  Like always before starting such operation, I'm encouraging to have backup of your drive.
  4.  Enter BIOS and check in Advanced > Storage >  SATA Mode Selection is "Intel RST Premium with Intel Optane System". If yes, exit BIOS and continue to para. 10. If not, exit BIOS and continue in next paragraph.
  5.  In order to change SATA Mode without destroying Windows boot, Windows must be set to SAFE Boot Mode. While in Windows, press Windows key + r. Run msconfig .  Chose Boot tab and enable Safe boot. Reboot your system. 
  6. During system boot enter Bios again. Verify in Advanced > Boot that Fast Boot is disabled. If not disable it.
  7. Now you can change the SATA mode to "Intel RST Premium with Intel Optane System". Save the setting (click on F10 folowed by "Y") and boot into windows in SAFE mode. Disregard the warning you will see. 
  8. While in Windows, press Windows key + r. Run msconfig. Chose Boot tab and uncheck Safe boot
  9. Reboot your system. Now your system is bootable in "Intel RST Premium with..." mode (however not accelerated).
  10. Right click on Windows key and press on Windows PowerShell (Admin).
  11. From the command prompt, type diskpart and press Enter. The diskpart prompt will open.
  12. From the diskpart prompt, type list disk and press Enter. A list of disks will appear in a text format. You will return to the diskpart prompt.
  13. From the diskpart prompt you will need to select a disk disk number (for instance, if the Optane Memory 16GB drive is Disk 1, you would type select disk 1) and press EnterDiskpart Erase/Clean will permanently erase/destroy all data on the selected drive. Please be certain that you are erasing the correct disk. 
  14. From the diskpart prompt, type clean and press Enter. The Optane Memory is now erased and the old enablement is not active any more.
  15. Close out of the Command Prompt.
  16. Update Intel RST Driver as described in para. 3.1,  page 10 of Intel Optane Installation Guide
  17. Now open Intel Optane Memory and Storage Management Application and enable Optane.

 

Hope this will help

Leon

 

Highlighted
New Contributor I
279 Views
Hi Leon

Thanks again, you put in a huge effort here.

In response to you points below:

Bit locker - yes I’m aware, but honestly don’t know why it is activated, it’s a pain in the proverbial...

I have tried to follow your instructions but get stuck at the point where I need to select Intel RST Premium in the BIOS, the option isn’t there.

Photo attached, hopefully it helps you help me!
0 Kudos
Highlighted
Super User
262 Views

Hi @GProc3 ,

  1. To my regret I don't have NUC10FN to make test for you. However it must be a bug in BIOS. You can see that on the  Information Panel, there is an explanation for the missing SATA mode "Intel RST Premium...". I can also see that BIOS versions 0042 and 0041 where pulled out by Intel from the Download site. Please read also  @sbmi post date 13-07-2020 in this thread.
  2. In this case, I suggest that you should downgrade your BIOS to version 0039, using BIOS Recovery from Power Button Menu Method:
  3. Prepare USB stick fully formatted to FAT32 (disable quick format option during format). Format your USB on Windows machine (rather than Linux or MAC). Save the Bios file FN0039.CAP on this stick. Important : the USB device must contain a folder \EFI\Intel, which contains the IN0039.CAP file. Otherwise the recovery will fail. ExampleD:\EFI\INTEL\IN0039.CAP
  4. and insert it into front USB slot with amber color (NUC shall be OFF). You may use also one of the rear USB ports (do not use front blue USB port, since sometime the USB stick is not recognized during boot process).
  5. Press and hold Power Button for about 3 seconds. Count 1001, 1002, 1003,1004. Release the Power Button. NUC should reboot into Power Button Menu. You should release the Power Button before 4-sec shut down override or when the Power Button LED changes color from blue to amber.
  6. Press F4 and the recovery shall start (it can take up to 30 seconds for messages to appear on the screen).
  7. When the recovery finishes, press on Power Button and hold it, until NUC switches OFF. Pull out the power cord. Remove the USB stick.
  8. Replace the power cord and press Power Button to switch the computer to ON. Let the NUC fully reboot.

Leon

 

View solution in original post

Highlighted
New Contributor I
258 Views
This is all beginning to make a bit of sense now.

I had previously written a post about how I had updated to the new v41 BIOS and it had given me a BSOD (inaccessible boot drive). I eventually managed to get it to boot into Windows but the computer has not been right since. Sounds like the v41 bios knocked out Optane and Windows 2004 is probably not helping either. I will do as you say later and let you know the results...
Highlighted
Super User
254 Views

One more thing. The BitLocker was probably activated during Windows installation.  You may deactivate it (remove the encryption). In the search box write "Control Panel" and then open Control Panel. Click on "BitLocker Drive Encryption" and deactivate BitLocker. It takes some time and the encryption will be removed.

 

Leon

 

Highlighted
New Contributor I
238 Views
Hi Leon

We have success - Optane back up and running!

I attach an image showing that Optane was available again once I had downgraded the BIOS. We could have all been saved a lot of time if Intel had just mentioned the issue!

I have also attached an image of a BSOD that occurred the first time I activated Optane through the memory and storage tool. I managed to fix it in the end by adding an extra step into your instructions. Once I had cleaned the Optane drive I needed to go back into disk management and set the partition style to GPT. All worked after that as shown by the final photo.

Next step... I’m going to try and upgrade to Windows 10 2004 again. I might be able to solve the issues with that now we have figured out the BIOS.

I will keep you updated.

Thanks again.
0 Kudos
Highlighted
Super User
230 Views

Hi @GProc3 ,

I'm glad that Optane is working now. However, I suggest that before you are upgrading Windows to version 2004, disable Optane again.  As I wrote you, this is a major Windows update (practically the current installation is replaced and packed into Windows.old directory). This Windows version creates recovery partition in the end of the drive, therefore the Optane may be affected.  So, first, disable Optane, then update Windows. Next, delete/move the recovery partition from the drive end. Create 5-15MB unallocated space in the drive end and finally enable Optane.

Leon

 

0 Kudos
Highlighted
New Contributor I
215 Views
Hi Leon, I disabled Optane before the install of 2004 and all is well. Interestingly the update didn’t create the recovery partition, perhaps because I had previously uninstalled it when working through our fixes.

I’m still not completely out of the woods though as it appears that every time the computer wakes from standby and I open up an application like Edge or Chrome the computer hangs for a significant amount of time, so I end up having to restart.

Might end up just doing a clean install of windows.
0 Kudos
Highlighted
Super User
211 Views

Hi  @GProc3 ,  If you are going to do a clean install, disable Optane first, in order to remove the current enablement.  Otherwise you will not be able to enable Optane in the new installation.

 

Leon

 

0 Kudos