Intel® NUCs
Support for Intel® NUC products
12330 Discussions

NUC10i5FNB - monitor wont wake from sleep

Charlle
Novice
628 Views

Hi,

I'm having issues with my monitor (Gigabyte M32Q) going into sleep but never wakes up. the NUC is still working (not configured to go to sleep mode), and i can connect through remote desktop connection and work with it as usual, also the mouse & KB are working just the screen is sleeping.

the only solution is to power cycle the NUC to get the screen on again.

I'm attaching the SSU report & Intel Graphics report, also 2 pictures of the display settings when the issue occurs (via RDC, the display shows as "wired display"), and in normal state (display show "Gigabyte M32Q").

all drivers & bios are up to date of course.

 

help will be much appreciated!

0 Kudos
6 Replies
David_G_Intel
Moderator
607 Views

Hello Charlle


Thank you for posting on the Intel️® communities. Please share with us the following information to have a better understanding:

  • Did you test other drivers? What version?
  • Did you try using the latest graphics driver for the NUC?
  • Did it work properly at any point before?
  • When did this start happening?
  • What connections do you use? (Ports, cables, adapters and others)
  • Does this also happen with other monitors?
  • Does this happen if you lower the refresh rate and resolution? 
  • Did you check with the monitor manufacturer to confirm if this is expected behavior or for firmware updates?


Regards, 

David G 

Intel Customer Support Technician 


Charlle
Novice
576 Views

Hi @David_G_Intel,

Thanks for the reply, here are the details:

  • Did you test other drivers? What version? - using the latest. no other drivers tested, nor updates related to graphics card were available in the past 6 months.
  • Did you try using the latest graphics driver for the NUC? - sure, latest are installed and no updates in the past few months.
  • Did it work properly at any point before? - yes, worked perfect till mid Nov
  • When did this start happening? - Mid Nov.
  • What connections do you use? (Ports, cables, adapters and others) - HDMI (for the screen), USB (for screen hub), 3.5mm for speakers
  • Does this also happen with other monitors? - replaced the monitor end of Oct, didn't happen with the old one though it was never connected again after i replaced it.
  • Does this happen if you lower the refresh rate and resolution? - yes, tried using 60Hz instead of 140Hz. still the same
  • Did you check with the monitor manufacturer to confirm if this is expected behavior or for firmware updates? - yes, they do not recognize this issue, FW update it to the latest.

i can add that after searching this forum i found there is a HDMI FW update, so i updated it and testing. hopefully this will resolve the issue.

 

Thanks again for your support

LeonWaksman
Super User
598 Views

Hi @Charlle 

1. Instead of restarting the NUC, restart the Graphics Driver: press Win+Ctrl+Shift+B on your keyboard.

2. In System Power settings ensure that the line "When plugged in, turn off my screen" is set to "Never"

3. Enable the "Allow wake timers" in Advanced Power Options:

 

powerOptions.png

Leon

 

 

Charlle
Novice
576 Views

Hi @LeonWaksman

 

  1. Thanks for the tip, when this will happen again I'll try the Win+Ctrl+Shift+B shortcut to see if it revive the screen.
  2. If I'll put the "turn off my screen" to "never" it will never sleep and the issue will be gone (no need to wake it up...)
  3. I can see only a few options in the power options screen, not as you have shown. "Allow wake timers" is not available in my NUC

 

Thanks for the help!

 

LeonWaksman
Super User
569 Views

Hi @Charlle 

"...Allow wake timers" is not available in my NUC...." The reason for this is the Sleep Mode setting in BIOS. It is probably set to default "Modern Standby". Could be that this is causing the monitor wake problem. You may try to test your system after changing the Sleep Mode to Legacy S3 Standby.

The sleep mode can be changed without corrupting Windows boot, only after setting Windows to SAFE boot mode. Before starting this procedure, I advise to create full backup image of your drive, just in case that something goes wrong. The same procedure should be used in case that you decide to return to the default setting (i.e. Modern Standby):

While in Windows, press Windows key + r. Run msconfig
Chose Boot tab and enable Safe boot. Reboot your system. 
During system boot enter Bios again. Now you can change the sleep mode. Click on Power tab. Secondary Power settings > Sleep Type set to Legacy S3 Standby. Save the settings and exit from BIOS (disregard any warning you see).
While in Windows, press Windows key + r. Run msconfig
Chose Boot tab and uncheck Safe boot. Reboot your system. 


Leon



Charlle
Novice
473 Views

Just wanted to update that since I've updated the HDMI FW, (here https://www.intel.com/content/www/us/en/download/19639/hdmi-firmware-update-tool-for-nuc10i3fn-nuc10...almost 2 weeks ago) the issue seems to be resolved.

Thanks for the tips. will keep you posted if something changes

Reply