Intel® NUCs
Assistance in Intel® NUC products
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
12976 Discussions

NUC10i7FNB Wont POST from power switch but works perfectly from Windows 11 restart


Hi all, my NUC10i7FNB BIOS POST stops and times out when it is first turned on (pressing the power button).  Waiting for the BIOS to time out and the error message to be displayed I can enter the BIOS.

Pressing F9 to load Optimal defaults <save> then F10 to save and exit works every time to start Windows.  Nothing is changed in the BIOS after pressing F9.

Restarting the NUC from the Windows Restart command works every time without issue.

I have updated the BIOS to FNCML357.0056 to no avail.  The only peripherals installed are the Corsair keyboard and mouse, both wired type.

Any help much appreciated.

RAM:   32Gb Kingston Hyper X (2 x 16Gb sticks)
SSDS: 1TB Samsung 970 Evo Plus
            1TB Samsung 860 Evo

0 Kudos
3 Replies
Super User

1. How the NUC is booting without any device connected to USB (i.e. no keyboard and mouse, empty USB ports).

2. What event/change in your NUC caused this problem to appear?





Hello Leon, thank you for your reply.

Unplugging the keyboard, mouse and USB audio interface allowed the NUC to boot as it should.

I plugged in the mouse and shut the NUC down through windows.  I then plugged the keyboard in and turned the power on.  The NUC booted normally but the keyboard was dead.  Changed the mouse and keyboard USB plugs over and had the same result.

Plugged the USB audio interface in and mouse and keyboard worked and booted normally.  When in windows I unplugged the audio device and the keyboard went dead, plugged it back in and the keyboard worked.  Turn off, start again with the audio device plugged into the front port and no problems.  I unplugged the audio device USB at the device and the keyboard still worked, unplug the same cable from the front USB port and the keyboard went dead.

I rebooted and went into the BIOS, pressed F9 the F10 and exit and now everything seems to work as intended.


It seems the problem is solved, thank you for your guidance.

Super User

I was glad to help. If any time your NUC will hang during post, enter BIOS, and change the relevant USB port settings from Enabled to Not Detect.  The Post will skip over the problematic device, but the device will be functional.