Intel® NUCs
Support for Intel® NUC products
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
12539 Discussions

NUC10i7FNH Front USB-A Port Not Working

Adam_Risch
Beginner
115 Views

My front USB-A port has stopped working.  I've plugged multiple devices in (they work on back ports).  I've tried slim profile devices (to test whether it's a seating problem - it's not).  I've tried going into device manager and uninstalling/reinstalling the various USB hosts.  I've tried unclicking the "allow system to turn off device to save power"  in the host controller properties window.  I've gone into the setpup menu to see if there is anything disabled there (not).

 

I've run out of things to try - nothing has worked.

 

Note: the USB-C port right next to it is working fine.

 

Any suggestions out there?

0 Kudos
3 Replies
n_scott_pearson
Super User Retired Employee
105 Views

I vaguely remember at least one case previously where the hardware failed this way, but lets look at possibilities.

  • Have you installed the latest available BIOS? If not, do so.
  • Have you tried doing a total reset of the BIOS configuration? If not, use F9 key while in BIOS Setup to reset configuration and then F10 key to exit saving this change.

Hope this helps,

...S

Adam_Risch
Beginner
77 Views

Hi Scott - thanks for the input.  I do have the latest BIOS and I tried your suggestion about resetting the BIOS config..no change. 

 

Only odd thing I noticed in device manager - sharing this in case it means anything to you - there are two host controller entries.  When I right click on the top one I get three options: Update Driver, Disable Device, Uninstall Device (then scan for changes, etc.).  When I right click on the other one I only get two options: Update Driver, Uninstall Device.  The Disable Device option isn't present (note: when I looked in Device Manager on my laptop, both Host Controllers offer all 3 options).  My first reaction was, "well, the one that isn't offering me the Disable option must be the problem - it must not be being enabled at startup somehow."  However, when I uninstall that host controller, my mouse/keyboard (plugged into rear USB ports) stop working.  So the one I can't disable is the one that is actually working.  At this point, the only way I can restart the NUC is by yanking the cord or holding the power button down - I don't have any way to plug a mouse or keyboard into the system because none of them use a Type C connector (though I did just order a converter).  I don't know if that matters at all (not being able to "restart" vs. just going hard down in terms of how the system reacts).

 

Seems odd to me that this would be a hardware problem (seems too rudimentary of an issue to be hardware).  If you have any other suggestions let me know. 

 

Thanks - note: I'll also be an Intel retiree (in 5 days)..hows the club?

 

 

n_scott_pearson
Super User Retired Employee
64 Views

Well, hard powering off (yanking the cord or holding the power button) is a good way to end up with a corrupted system drive. Just a soft press on the power button should cause Windows to perform a clean shutdown.

As for the oddity in the supported capabilities, I don't believe that this is abnormal. Yea, wishy-washy answer, but I see it too in my Intel NUC 9 Extreme laptop and it isn't causing any issues. In my FN NUC, however, both host controllers show all three options.

Something to try: check if the front USB ports are actually working in BIOS Setup. Put the latest .CAP file (FN0059.CAP) in the root folder of a flash drive, plug this drive into a front port, use F7 during POST and see if you can access the drive and select this .CAP file for installation (using F7 method).

Hope this helps, 

...S

P.S. Check your private messages.

Reply