Intel® NUCs
Support for Intel® NUC products
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
11855 Discussions

NUC10i7FNH fails to identify Linux boot drive

Ethann
Beginner
623 Views

I have recently been attempting to install several Debian based Linux distributions (Proxmox, Debian Buster) onto a NUC10i7FNH with a 256gb NVME, however have faced issues getting the BIOS to recognise the boot drive. Installation completes successfully, and rebooting succeeds, however upon a complete shutdown and restarting, the NVMe drive does not appear in the storage tab of the BIOS, and so I encounter the "A bootable device has not been detected" error.

Launching the UEFI shell, no mapping is initially found, however if I reload the drivers:

reconnect -r

map -r

fs0:

fs0:\EFI\proxmox\grubx64.efi [Or equivalent EFI\BOOT\ file, both are present on Proxmox install]

I am able to launch into the OS successfully. This however is obviously not ideal for a headless startup. I have tried updating the BIOS to the latest version through various methods, as well as setting a hard disk predelay of up to 30s to no avail. Could this possibly be a BIOS bug?

 

Thanks

0 Kudos
9 Replies
AndrewG_Intel
Moderator
591 Views

Hello @Ethann

Thank you for posting on the Intel® communities.

 

It is worth mentioning that for the Intel® NUC 10 Performance kit - NUC10i7FNH, Linux Operating systems have not been validated yet and only Windows® 10 is officially supported as you can confirm in the following links:

 

Nevertheless, we would like you to provide us with more details so we can check this further:

1- The exact version number of the different Linux distros that you have tried:

2- NVMe Drive brand and model:

3- When this behavior happens, have you made sure the drive is fully inserted into the M.2 slot and the screw is secured to the stand-off?

4- Have you tested with different drives? Have you tested the NVMe Drive in question on other systems? Please provide details:

5- When experiencing this behavior, please check Boot Order in BIOS:

  1. Press F2 during boot to enter BIOS Setup.
  2. Go to Advanced > Boot > Boot Priority (or Boot > Boot Priority).
  3. Set the drive with the operating system to be the first device in the Boot Order. 
  4. Press F10 to save and exit BIOS.

6- We understand that "installation completes successfully" and you are able to boot to the operating system (OS), could you please provide the following logs?

 

Best regards,

Andrew G.

Intel Customer Support Technician

 

Ethann
Beginner
573 Views

Hello Andrew,

 

Apologies for the delayed response;

 

1- I have attempted to install Debian Buster 10.10.0, Proxmox VE 6.4 and Proxmox VE 7.0, encountering the same issue with all.

2- From nvme-cli:

Node /dev/nvme0n1

Model SKHynix_HFS256GD9TNI-L2B0B

FW Rev 11710C10

3- As a trouble shooting step, I removed and reinstalled the M.2 drive and believe it is making good contact. The same M.2 drive successfully booted a previous Windows installation with no issues.

4- I unfortunately do not currently have access to another system in which to test the M.2 nor an alternate drive, however as previously mentioned the same drive functioned without any apparent issues when booting Windows 10.

5- When the boot drive is not detected, the drive shows as 'Not Installed' under the Advanced > Storage menu, and thus does not appear in the boot priority menu. It does not appear in the F10 boot screen either. It will occasionally appear after modifying BIOS settings then restarting, consistent with the discovery upon running 'reconnect -r' in the EFI Shell.

6- After a fresh install of Proxmox 7.0:

  • /var/log/dmesg not present, saved with "dmesg > dmesg-manual.log"
  • I have redacted any serial numbers I found, let me know if you need them and I can provide them privately

Thanks

n_scott_pearson
Super User Retired Employee
551 Views

Just checking: You are booting and installing Linux in UEFI mode, right? You aren't attempting to boot in Legacy Mode (which isn't supported for NVMe SSDs), right?

...S

Ethann
Beginner
546 Views

Definitely using UEFI, Legacy is disabled in the NUC 10 BIOS unless the sleep type is modified. Cheers for the suggestion though.

AndrewG_Intel
Moderator
515 Views

Hello Ethann

Thank you for your response and for the reports. Please allow us to check this further and we will be posting back in the thread as soon as more details are available or in case additional information is required.


Best regards,

Andrew G.

Intel Customer Support Technician


Ethann
Beginner
494 Views

Something of an update for you @AndrewG_Intel; I managed to free up an spare SATA SSD, performed an identical installation of identical software with identical BIOS settings, and it boots and works flawlessly. The NVMe works fine as a secondary drive, and fine as a boot drive when booting Windows 10, however some combination of the specific NVMe, BIOS and Linux seems to break it. Hopefully my logs will be of some use to figure out why this is happening.

Ronny_G_Intel
Community Manager
470 Views

Hi @Ethann 

 

I checked the logs and did some internal digging but unfortunately, I was not able to find any reason why the system is behaving as described.

I have Ubuntu 20.04.2.0 LTS running on an equivalent system and I have no issues, we offer limited Linux* support, keep in mind that the NUC10i7FNH has been validated only with Windows 10, see our Operating System Compatibility List 

Have you tested Ubuntu*? I would recommend that you check with Proxmox* or with Debian* community support.

 

Thanks,

Ronny G

 

 

AndrewG_Intel
Moderator
427 Views

Hello Ethann

We have not heard back from you so we will proceed to close this thread now. If you need any additional information, please submit a new question as this thread will no longer be monitored.


Best regards,

Andrew G.

Intel Customer Support Technician


Ethann
Beginner
419 Views

My apologies, I had attempted to send a reply but it seems that it didn't go through. As the system is now in use, I am unfortunately unable to keep troubleshooting this, although if I have a spare NVMe / some spare time at some point in the future I shall endeavour to reinvestigate this, and shall report anything I find to this forum. Thank you for all your help, this thread can be closed

Reply