Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cosmo23
Beginner
136 Views

NUC10i7FNH no 3D display support?

Hi, I've just bought  NUC10i7FNHJA to have a better experience from 4K and 3D content.  4K works fine. But I'm not able to enable 3D at all.

I've got my NUC connected to Onkyo receiver, then to my LG 3D & 4K TV. Both cables are PremiumCord HDMI 2.1 High Speed 8K @ 60Hz capable. HDMI port on TV is HDCP 2.2 compatible.

I'm trying to play some reference 3D videos from https://kodi.wiki/view/Samples#3D_Test_Clips

I don't even need to load the video, I just go to Cyberlink PowerDVD 18 setup menu, and when trying to select any of "HDMI 1.4 enabled 3D TV" resolutions, I end up with:

Annotation 2020-09-05 155104.png

 

 

 

 

 

 

 

 

 

Cyberlink BD advisor gives me this:

Annotation 2020-09-05 160612.png

 

 

 

 

 

 

 

 

 

 

Prior to that I was using very old Zotac HTPC with Intel HD graphics. With the same setup (Onkyo receiver, LG 3D TV, the same cables) - there it worked flawlessly. I'm desperate to find the cause why this is not working..

Also, I  tried to skip the receiver and connect NUC directly to TV.. The same result. I have the latest video drivers installed. Latest BIOS, latest HDMI firmware. Intel SGX activated. I don't know what else can I do. I'm attaching SSU report, as I've noticed, that despite my video is connected via HDMI, it says DisplayPort in the report. Are the connectors using the same chip or what is the cause of this ?

I would be thankful for any suggestion or advice as I bought this unit solely for watching 3D and 4K content.. Thank you in advance.

Attaching also SSU report

 

 

0 Kudos
0 Replies