Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
161 Views

NUC10i7FNH no video output on boot with a monitor connected directly to the eGPU

About three days ago I purchased a NUC10i7FNH, because I had a Razer Core X Chroma eGPU (previously used with a MacBook Pro) on my desk that I wanted to use more frequently and I liked the idea of having a super-flexible setup where I could swap out components very easily. My setup is as follows:

  • NUC: Intel NUC10i7FNH
  • eGPU config: Razer Core X Chroma with a Radeon VII card
  • Monitor: Philips 499P9
  • OS: Windows 10 Pro (2004)

The eGPU is connected to the NUC via Thunderbolt 3 (official Razer Core X cable) and the monitor is hooked up to the eGPU via HDMI. Except from having very aggressive power saving settings, the monitor works pretty well when it's connected directly to the NUC (without eGPU attached).

The issue I'm having is that I can't see the boot process when the monitor is connected directly to the eGPU. I don't even see the Windows login screen. I have to log in "blind" and as soon as the user session is loaded, the monitor turns on and I see my Windows desktop. Sometimes if the eGPU is already plugged in when i turn on the NUC, it crashes and I have to start it again. When I connect the TB3 cable after turning on the NUC it works pretty reliably.

I tried all troubleshooting steps I could find online and I reinstalled Windows multiple times, just to check if it's an OS problem (I found it pretty weird that I couldn't see the Windows login screen). I tried multiple combinations of the TB settings in BIOS, but that didn't help either. It seems to me like the device is actively being blocked during the whole boot process, but that's just a guess.

The Intel Driver & Support Assistant shows all drivers as being up to date. I tried re-installing some drivers manually and I updated the BIOS to the latest version (AFAIK). The AMD drivers are updated as well.

SSU output is attached.

I appreciate any help I can get!

7 Replies
Highlighted
Moderator
128 Views

Hello reto_gian,

Thank you for posting on the Intel® communities.  


To better assist you I would like to gather some additional information:


  • Have you tried the eGPU in another system? Is it working as expected?
  • Have you checked for any Firmware/drivers for your eGPU? What is the current version?
  • Can you please share the settings you have tested in BIOS?
  • Is “Max Performance” enabled in BIOS? under the “Power” tab.
  • What is the current power plan in your OS?


Additionaly, by any change have you checked if this behavior occur also with different monitors?


Esteban D.

Intel Technical Support Technician   


0 Kudos
Highlighted
Novice
112 Views

Hello Esteban

Thank you for getting back to me. I'll try to answer your questions to the best of my knowledge:

  • Yes, I use it occasionally on a MacBook Pro 15" (late 2016). However, as the MacBook Pro is equipped with both an iGPU and a dGPU, the eGPU was not as straightforward to set up (I had to disable the dGPU and allocate more resources to the eGPU using the Device Manager). Using that workaround it's working quite well and I'm able to follow the entire boot process on my monitor, which is connected directly to the eGPU (basically the same setup I'm trying to achieve on my NUC).
  • Yes, I believe the driver was updated when I installed the latest Radeon Software (right after I set up Windows on my NUC). Radeon Software reports driver version 19.50.29.27-200515a-355311C-RadeonSoftwareAdrenalin2020.
  • I believe there was an option called "IGD Primary Video Port" (and "Secondary"), so I tried setting that (and later both) to Thunderbolt. There is also "Thunderbolt Security Level", but I left it on "Legacy Boot" which is the default. I also tried changing the boot order, but I can't remember which configs I tried (multiple). And a couple of other things, but I don't think it's relevant.
  • If I'm not mistaken, "Max Performance" is the default, right? I reset everything back to default settings after I couldn't find a solution to my problem.
  • The Power Plan in Windows is "Balanced" (I didn't change anything).

Unfortunately I don't have any other Monitors I can test, but the Monitor is also pretty new and I didn't have any issues in other setups (e.g. MacBook Pro) nor with the NUC connected directly to the Monitor over HDMI. I was thinking about trying DisplayPort between the eGPU and the Monitor, but I couldn't find a cable and I'm not sure if that would change anything (I'm not really knowledgeable in that area).

Another info that may be helpful: in the beginning, I was seeing two Monitors in Windows Settings, so I had to disable the iGPU in Device Monitor, because the iGPU "display" (which I couldn't see, because there was no monitor connected apparently) was always chosen automatically as the primary display.

I hope that helps!

Best regards,

Gian

0 Kudos
Highlighted
New Contributor I
100 Views

@reto_gian NUC10i7FNH no video output on boot with a monitor connected directly to the eGPU 

 

Is normal I have same kind of set up USB C has to be started by you OS before you see any thing via the E-GPU

I have My NUC plunged in via HDMI to HDMI Port one on the monitor, and the E-GPU in to HDMI Port two. This way when I turn on the Monitor the NUC will Power ON.  And If I power on the NUC via Power Button or the Keyboard Monitor will  will power on. And then I just select HDMI Two once all is powered on.

Also if you go into Display manager in windows settings you can select it to just show on your E-GPU it is normally display number 2, that way no need to disable in Device manager but I have done the same as it saves hazels every time you do a driver update.

Also your On Board GPU will not turn off till windows boots this way you can get in to Bios via the NUC Display Connection. But you will need to have NUC and E-GPU plunged in to Monitor if you want to see Post.

 

Intel® NUC Hades Canyon NUC8i7HVK
Intel Core i7-8809G 3.1GHz 4.2GHz Turbo 4 Cores 8 Processor's O/C to 4.6GHz
32GB Ram 2x 16GB DDR4 2400+ SODIMMs O/C to 2600
Razer Core X - E-GPU Fitted with a Radeon RX 5700 O/C to 2011MHz
Has been flashed with the Radeon 5700 XT Bios
512 GB M.2 SATA SSD Operating System and Apps
1TB M.2 SATA SSD Game's only Windows and Steam

Tags (1)
0 Kudos
Highlighted
Novice
86 Views

Hi AlanJT

Thank you for your reply, I was actually wondering if that would be a possible solution! I tried this in my MacBook setup once but I ran into a couple of issues (can't remember exactly which ones at the moment and looking back I'm not sure it was even related) and I was worried it could damage my gear (creating a "circular" chain sounds to me kind of like a bad idea). However, I couldn't find any evidence online that this could in fact be dangerous, so I guess it shouldn't be a problem to try this. I would still prefer to find a solution that is less hacky though, as I bought this NUC primarily because I'd seen a couple of very promising posts online that positioned it as a "plug and play" solution for eGPU setups. I would also prefer to have a solution where I wouldn't have to switch between inputs or to hotplug anything.

I really appreciate your help though, a workaround is still better than no solution!

Cheers, G.

0 Kudos
Highlighted
New Contributor I
78 Views

You can do it  like that you just do not connect you E-GPU to your monitor Just your NUC,  instead go in to All Settings / System / Display / Scroll Down to Graphics Settings and then in the Drop down box Find you games in Store App or in Desk Top Apps Add it to list, then select that App and in options for it select the GPU you want it to use.

 

The same you would have had to do for you Laptop.  Only reason I have not done mine that way is Total lack of GPU Driver support For my NUC from AMD and Intel.

0 Kudos
Highlighted
New Contributor I
70 Views

@reto_gian 

 

Hi there I just did the Latest Bios up date for my NUC Hades Canyon that was released a day or so ago, And now it is actually showing Post from the E-GPU So I can now remove the HDMI Cable from the NUC and just have the E-GPU plugged in to the monitor Via the HDMI port.

 

Minor Miracles do happen.

0 Kudos
Highlighted
Novice
38 Views

@AlanJT 

That's great to hear, I'm glad it worked for you! I just did the update, but it didn't change anything in my setup...

 

@Esteban_D_Intel any news?

0 Kudos