Intel® NUCs
Assistance in Intel® NUC products
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
12987 Discussions

NUC11BTMi9 missing drivers (Windows 10)

New Contributor I



We have just started to build a NUC11BTMi9, generally we do the below with all NUCS (NUC7 and NUC9 Extreme) with no issues:

- Install Windows from USB (created from the Microsoft Windows creation tool)

- Install the Western Digital Dashboard (for the SSD) and update firmware as required

- Install Microsoft Keyboard and Mouse driver (we use Microsoft 850 wireless keyboard / mice)

- Install Intel Driver and Support assistant


Once the above happens the Intel Driver and Support assistant generally finds all drivers required, however it appears to be very lacking with the above PC.. it missed almost all of them with only finding  the Bluetooth driver.  We had to manually download and install the latest BIOS, Wifi, graphics and many others but we are still missing 3, even then once they are all loaded the WiFi driver then stops working (when loaded alone with no others the WiFi works, so there appears to be a driver conflict somewhere)

- PCI Device

- SM Bus Controller

- Unknown device


We have tried with WIndows 10 21H1, Windows 10 21H2 and WIndows 11, why is the Driver update assistant not working with this PC?


SIDE NOTE : Windows 11 appears to have the Ethernet Driver built in, Windows 10 does not, so on build Windows 10 says "no internet", Windows 11 has internet as its being built !  Also when running Performance Test / Pass Mark tests ( Direct X11 appears to be failing, Windows says it blocked access, which appears to be a driver issue, never had this test fail on any new system (we use it to test ALL NUCs when sold), my feeling is the system is damaged, but cant be 100% sure


We have reset the BIOS (F9), we also had enabled VMD controller (BIOS > Advanced > Storage > Enable VMD controller (Enable for RAID and Optane Memory), while this is on, no SSD can be found, so need to load RAID drivers as its being built (this is standard for servers, was surprised for Windows 10 though, would think the VMD driver would be in the Windows 10/11 build, clearly its not).


Appears to be major driver issues with this system.......

The board is damaged !!


SSD = Western Digital WDS100T1B0E (used in the NUC 9 Extreme with no issues)

RAM = Kingston KF432S20IB/32 (Intel XMP certified), never used this RAM before, we normally use Kingston Value RAM (that's confirmed by Kingston for the system)


What do we need to test for this?

Many Thanks

0 Kudos
7 Replies
New Contributor I
First I don’t understand why Intel no longer lists the required chipset software on the NUC11BTMI9 / 7 download support page for the product. Over sight / deleted link ?
The chipset software creates a log of onboard hardware, without this hardware list, windows will try install a generic driver, or none at all.
Hence the yellow Bang.
This list will keep a log of the onboard hareware so windows or Intel ME management engine can identify the correct drive to install for the specific onboard hardware.
I always install this chipset software immediately after installing windows & any windows updates, before any other drivers.
Here is the download link.

INTEL’s description.
This download record installs the Intel® Chipset Device Software for Intel® NUC 11 series.
It is important to install this software first after installing a Windows* operating system, before installing any other device drivers. This action ensures that Windows recognizes all chipset components. If the operating system cannot identify all of the chipset components, you may experience the following issues:
* Yellow question marks in Device Manager
* Unknown devices in Device Manager
Once the Intel Chipset Device Software has been installed on the Intel NUC, there is no need to update to a later version.
New Contributor I

Thanks, this seem to help alot, although i still have 1 device left thats "Unknown Device", however both Ethernet and WiFi now work so this driver helped.


We also installed the Intel® NUC Software Studio Service however this didnt fix it either.


Also still have the DirectX10/11 issue, so i am wondering if the card is evern DirectX 10/11 compliant, however the internet seems to point to drivers being the issue, we loaded the one specific for this board, without them the sound doesnt work from the HDMI port.  This may need to be answered by an Intel Support guy on here

Valued Contributor I

I would say that after installing Windows, you should install the chipset inf files and the management engine driver by manually downlaod them from the Intel website.

I think the Intel Driver and Support assistant doesn't install those (or it is not good at it)


PCI Device, SM Bus Controller are related to chipset inf files, and "Unknown device" entries are most of the times also related to chipset inf.

I won't rely on that tool (nor on any others like Dell SupportAssist, HP Support Assistant, Lenovo System Update, and so) for the "fresh-first" driver installs. Other users here (SuperUsers) also agree with that. I would say that the best is to manually download the drivers from intel website installing first chipset inf and management engine. Then installing the other drivers using the particular installers .exe files, zip files, and so on...

After you install the first bundle of drivers, then you can use the tool to get notifications for coming updates and update if you want to...


The other issue maybe is a OS issue, it is saying that it is "Windows who is  blocking access", Perhaps something on the configuration, Windows Defender settings, Firewall, or OS issue.


New Contributor I

We installed the Chipset driver (as listed above) that helped alot, the Ethernet and Wifi now work together, we still have a single "Unknown Device" though and a graphics card Direct X10/11 issue (i assume the onboard graphics supports Direct X).

New Contributor I
megan3000, Right on.
Me personally,
1. Install windows
2. Install chipset software.
3. Download all required drivers from the manufacturers support page for the specific product and install them manually.
4. I do not use or rely on support assistant software.
It is time consuming doing it manually, but pays off because I rarely have driver issues
New Contributor I
If it’s the graphics, here is the link

Or look up the code for you NUC11BTMi9/ 7 here and download the appropriate driver. From this device identification list.
New Contributor I

- The video card driver you listed is already installed, without this no sound out the HDMI port.

- The Device is ACPI\VEN_INT&DEV_34C6 this is not listed on the lookup, its not the SD card reader either (just checked)



Intel® Serial IO Driver for Windows® 10 64-bit and Windows 11* for the 11th Generation Intel® NUC Products

Its the GPIO driver, downloaded and installed, cleared the driver issue....

Intel are seriously lacking with there drivers its seems....


Still not fixed the graphics issue, will open a new thread for that