Intel® NUCs
Support for Intel® NUC products
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
12540 Discussions

NUC11PAHi5 - no sound via HDMI on debian

Dolev
Beginner
1,633 Views

Hi

I'm running Debian stable (11) on NUC11PAHi5.

for some reason I don't have any sounds via the HDMI port

My kernel version is 5.10.0-11-amd64.

From research on google I've found that maybe it's an issue with the current kernel version.

May you assist me with that?

 

thank you

0 Kudos
1 Solution
AndrewG_Intel
Moderator
1,477 Views

Hello Dolev

Thank you for the information and for the Intel® SSU report.

We will review this and post back in the thread as soon as possible.


Best regards,

Andrew G.

Intel Customer Support Technician


View solution in original post

12 Replies
AndrewG_Intel
Moderator
1,607 Views

Hello @Dolev

Thank you for posting on the Intel® communities.

Please allow us to check this and we will be posting back in the thread as soon as more details are available or in case additional information is required from your environment.


Best regards,

Andrew G.

Intel Customer Support Technician


Dolev
Beginner
1,586 Views

Hi Andrew,

Yesterday evening simething very weird occur-

The NUC was on sleep mode and when I turned it on again (clicked on the power button) the sound worked perfectly.

I didn't have enough time to make any inseption for that.
But maybe it's something that belongs to the BIOS? that's the only thing I can think of.

 

thank you

oupula
Beginner
1,564 Views

sudo echo "options snd-hda-intel model=dell-headset-multi" > /etc/modprobe.d/alsa-base.conf

sudo reboot

Dolev
Beginner
1,556 Views
oupula
Beginner
1,265 Views

My NUC also is NUC11PAHi5

My System is Debian 11

 

# cat /etc/modprobe.d/alsa-base.conf
options snd-hda-intel model=dell-headset-multi

 

mate-sound.pngmate-hdmi.png

AndrewG_Intel
Moderator
1,541 Views

Hello Dolev


Just to make sure, when you say "when I turned it on again (clicked on the power button) the sound worked perfectly." Do you mean the HDMI® audio is not working fine? Or do you mean that it only worked once (in that moment?) but the issue persists?


If the problem persists, please provide us with the following information:

  1. The full report of the Intel® System Support Utility for the Linux* Operating System (please attach a file with the output instead of copying the information (plain text) directly in the thread)
  2. Please make sure and confirm that you have updated the kernel and system updates:
  3. There are some reports over community forums where Debian* was not stable and people recommend using different Linux flavors. Have you tested with different Linux distros?


Best regards,

Andrew G.

Intel Customer Support Technician


Dolev
Beginner
1,529 Views

I mean that the sound working properly when I turn on  the NUC after sleeping mode.

 

1. The file has been attached
2. Confirm. I'm using the last stable version.

3. the issue persists with Ubuntu 21.10, ZorinOS (latest version) and Manjaro.

 

 

thank you

Dolev
Beginner
1,497 Views

Now I realized that in order to fix that I must reconnect the HDMI cable - then everything works fine .

 

AndrewG_Intel
Moderator
1,478 Views

Hello Dolev

Thank you for the information and for the Intel® SSU report.

We will review this and post back in the thread as soon as possible.


Best regards,

Andrew G.

Intel Customer Support Technician


Dolev
Beginner
1,447 Views

Andrew, 
I just Install windows 11 - So the issue no longer exist. 

 

thanks for the support

 

 

AndrewG_Intel
Moderator
1,387 Views

Hello Dolev

Thank you for your response.


We are glad to know that this works fine using Windows* operating system (OS).

Based on the Product Specifications website and the Supported Operating Systems for Intel® NUC Products, Linux OS, including Debian are not validated (only Windows* 10 and 11 are listed).

In general, we don't provide drivers for Linux-based OSs and we were thinking of trying Windows or Ubuntu in order to isolate an issue to the OS Debian. Since you already tried that and using Windows the issue no longer exists, our recommendation is to seek support from the OS manufacturer for further assistance with Debian.


Having said that, and considering that the thread has been marked as "Solved" we will proceed to close this request now. If you need any additional information, please submit a new question as this thread will no longer be monitored.

It has been a pleasure to assist you.

Best regards,

Andrew G.

Intel Customer Support Technician


oupula
Beginner
906 Views

Try this 

 

sudo echo "options snd-hda-intel model=alc274-hp-mic-detect" > /etc/modprobe.d/alsa-base.conf

sudo reboot

 

 

 

Reply