Intel® NUCs
Support for Intel® NUC products
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
12734 Discussions

NUC11PAHi7 Can't use both a SATA and NVME drive


Brand new NUC11PAHi7, trying to set up and install.  Bios came as 357.0041 which seems to be the latest.

At first the NUC did not even enter the bios if I have my intended boot m.2 drive (optane 800p 58gb) installed. It just blinks the power light (about 4 seconds on, then 4 seconds off, repeat).
With it removed, I was able to enter the BIOS and change Advanced->Storage and Enable VMD controller. With this done, the NUC now boots into the BIOS and recognizes the m.2 as well as the SATA SSD.

Installing the operating system on the m.2 worked fine. However, the SATA device is not recognized at all (despite being recognized in the BIOS, and yes, the drive works in other machines).

Back into the BIOS, I see that the VMD is controlling the SATA drive. I only need it to control the m2, so figuring this is the issue, I set "Map this Root Port under VMD" to disabled.
However, there is no change after this...
Upon re-entering the BIOS, it seems that previous option has reverted to enabled. There seems to be no way to disable VMD for the SATA device?

How can I get both drives working? My option is either a m2 drive OR a SATA drive... both will not work at the same time. Which is odd, as this setup of a boot m2 OS and a SATA storage drive is basically standard practice and works fine on previous generations of NUCs and other machines, I have never seen this issue. 

Further, why will the NUC not even enter BIOS if VMD is disabled and an m2 drive is installed? Is the NUC defective? It just blinks the power light (about 4 seconds on, then 4 seconds off, repeat)

0 Kudos
7 Replies
Super User Retired Employee

I have this same unit with both M.2 SSD and SATA SSHD installed but do not see the issue you are having. There have been some reports of folks having issues with the SATA cable (which can be resolved by reseating the cable in the board's connector), but nothing regarding an issue that only manifests when both are installed. BTW, I would be testing with the BIOS Settings at their defaults. I wouldn't be playing with parameters that you do not completely understand their purpose and ramifications (one way or the other).

Hope this helps,



The issue appears agnostic to the SATA ssd, other than the SATA ssd not seeming to work with VMD.
I have since tried a cheap western digital m.2 drive and it seems there are no issues with the device with other nvme drives.

So the question is -- why does the device not even enter the BIOS splash screen when only an Intel 800p nvme drive is installed in the m.2 slot and the BIOS is at default settings? Something to do with it being considered "optane" perhaps?

It's not an issue with the drive, it continues to work fine as a boot drive in older generation hardware.


SS19, Thank you for posting in the Intel® Communities Support.


The problem could be related to compatibility between the Intel® NUC 11 Performance kit - NUC11PAHi7 and the drives, especially as you mentioned that "I have since tried a cheap western digital m.2 drive and it seems there are no issues with the device with other nvme drives.".

In the link below you will be able to see the list of compatible drives tested by Intel® for your Intel® NUC, there are other drives that are also compatible with the Intel® NUC not listed there, is just that Intel® has not tested them yet:


Since the BIOS version currently installed in your Intel® NUC is the latest one, 0041,  still, if you have issues with other drives as well there might be a hardware problem with the Intel® NUC itself, and in that case, you can always get in contact directly with the place of purchase to check their warranty options or you can get in contact directly with the Intel® support department in your area for warranty purposes:


Chat support:


For phone support, depending on your location, you will see the contact information on the links below:

EMEA contact information:

APAC contact information:

LAR contact information:

North America: Phone Number 1-916-377-7000, Monday – Friday 7:00 AM to 5:00 PM (Pacific Time).



Albert R.


Intel Customer Support Technician




Yep, it seems the issue is simply that an Intel NVME drive is just not compatible with an Intel NUC.

Valued Contributor I

Have you made sure your 800p has the latest firmware? This would be the first thing I would check using the Memory and Storage Tool:

Intel® Memory and Storage Tool (GUI)


I know the H10 Optane SSDs do work as VMD drives but the 800p was not the same type of Optane in the sense as it used the 3D X-Point memory for the SSD and not just cache storage like the H10 and H20. Since Optane has been discontinued by Intel, support will be harder to get as time goes on.

The next question would be why are you using such a small and slow SSD when you can get a 256GB NVMe SSD for $50 that is twice to three times the speed?


I had updated the firmware somewhat recently, but am not going to check again as the drive is no longer under warranty. My last experience with Intel product updates out of warranty bricked my previous NUC.  That's why I now have this one.

Indeed the 800p should be seen as a normal SSD. I have since moved the 800p to be the boot drive for a new AMD server build and it is working flawlessly there. It seems AMD has better support for Intel drives.

Why a "small and slow" SSD... well first, I already had it.
Small: because it is perfect for a boot drive. It lets you reinstall operating systems and keep a data drive clean.
Slow: It's only slow at top sequential, but it's still top of the line for random read and 4KQD1. This is again perfect for an operating system because sequential "top speed" is completely irrelevant in this context.


SS19, Thank you very much for confirming those details.

"Yep, it seems the issue is simply that an Intel NVME drive is just not compatible with an Intel NUC.", even though it does not happen that often, there are NVMe drives that are just not compatible with specific products, like in this case the Intel® NUC, but at least we know that each product is working fine and there is no hardware issue with them. Compatibility always takes a major role in computers and it is hard to tell if some parts will work with each other if they are not have been tested previously.

Any other inquiries, do not hesitate to contact us again.


Albert R.

Intel Customer Support Technician