Intel® NUCs
Assistance in Intel® NUC products
13314 Discussions

NUC11PHKi7C bricked after Express BIOS Update (Windows-Based)


Afer Windows-Based BIOS update my NUC11PHKi7C completely bricked

After attempted to update using the  .EBU.exe file downloaded from support page, sucessfull completion of update in Windows, followed the promt on the screen to restart, then computer restarted and after that I have it completely bricked. 

Now when I turn it on by the power button, the power button led, the green led, both starts to flash shortly at 7 seconds interval.

At the same time  there no HDMI / DP output - monitor shows 'NO SIGNAL' message.

Also, if USB memory stick inserted into any USB port - it attempts to read the device (USB memory stick led bllinking and NUC' red led also blinking shortly the same time)

Tried various keyboard keys - F2, F7, F10, ESC with no success.

Tried to power it on with BIOS recovery file written to USB stick (FAT32 properly formatted)

Tried to remove the battery and insert it after 15 minutes


0 Kudos
5 Replies
New Contributor I

Ive had some BIOS updates take up to 10 mins with quiet a few reboots... however you have since powered it off so this may not help you now.  Power it on and leave it for 30 mins.

0 Kudos
New Contributor I

I'd say the best option is to try the documented recovery procedure, either via the power button or, if that doesn't work, by removing the security jumper.

see   for more details.


0 Kudos

I've followed the procedure you proposed with no success.

There is no display output at all. Button menu not working. Jumper removal also has no effect.

After connecting the power jack and pressing the power button (duration of press does not matter) unit starts to blink with power button led and greed led shortly each 7th second. I've left it like this for 27 hours and this not helped.

There is no any display output signal at non of the ports, not HDMI nor mini-DP


0 Kudos
Valued Contributor I

I cannot find any reference of a 7-seconds LED power button blinking, but found one of 1 blink every 5 seconds... and there's not much to do apparently...

"This blink code could mean the Intel NUC's power-on circuit may have failed"


0 Kudos

hi,i have problem with mine  11tnki3

same problem, after a bios update that froze

does ur motherboard have extra ports for usb?

mine has, but i havent tried,  i readsomewhere on forum

that u can buy cable and connect the usb mouse+keyboard on other end,and in that way get power to them.

one other method i read is buy m2 pcie usb slots with seperate power cable from outside the nuc.

then in that way get monitor + power for keyboard mouse, i didnt try this yet.

0 Kudos