Intel® NUCs
Support for Intel® NUC products
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
11863 Discussions

NUC11PHKi7C fist impressions.

BHarr8
Valued Contributor I
353 Views

I broke down and bought it from Amazon, it took 2 days to arrive, none of that nearly October BS. Intel really needs to drop Simply Nuc as their preferred vendor.

I am just at the point where I am installing hardware and playing around with the BIOS (it came with the latest).

What I like:

Taking it apart is easier than it is with the NUC8i7HVK. The cable connecting the top to the motherboard is long enough that you do not need to detach it. Flip the metal part to the left and it can rest on a table next to the NUC without stretching the cable.

Its super easy to get at the RAM and SSDs. If you ever want to update, its a slap.


What I don't like:

RAM compatibility is somehow far worse than it is with the NUC8i7HVK (which is technically a 7th gen CPU in 8th gen pants). On my NUC8i7HVK I can run DDR4 3600 CL16. The best the NUC11PHKi7C is DDR4 3200 CL22 and all of the craptacular timings that come with being locked to JEDEC timings. There is no XMP ...... on an extreme product ..... that is the successor to an extreme product that had full XMP support. 4 generations forward to take a huge step back is a baffling design choice.

There are RAM setting in the BIOS menu ...... that do literally nothing. You can increase or decrease the multiplier and nothing happens on reboot. I tried a dozen different setting both up and down and on reboot the BIOS reports the stock speed of the RAM. I even tried RAM rated to go all the way to DDR4 3600 and no matter what I did I was locked to 2666 (which is the JEDEC speed for that kit). If RAM control does not exist, Intel should just gray it out instead of making it look like you actually have control.


Going to play around with it some more and jump right to Windows 11 although I likely will run Windows 10 officially until sometime next year.

0 Kudos
3 Replies
DeividA_Intel
Moderator
326 Views

Hello BHarr8,  

  


Thank you for posting on the Intel® communities.   



We do appreciate your post and comment about the NUC11PHKi7C, we are constantly improving and releasing drivers and BIOS updates that can improve the performance of the unit and the experience that you have with it. 


If you have any issues/problems with the unit do not hesitate to get in contact with us or open a new thread.



Please keep in mind that this thread will no longer be monitored by Intel.  


   


Regards,   


Deivid A.  

Intel Customer Support Technician  


BHarr8
Valued Contributor I
292 Views

Looking into the RAM issue a bit more it seems to be the 1.2 volt lock that eliminates all performance RAM (which require 1.35 volts to run lower timings).

I am going to be testing the fastest DDR4 3200 1.2 volt RAM I could find next week but that only drops CL22 to CL20, not exactly impressive and likely only visible to bechmarks.

Samsung makes some DDR4 3200 1.2 volt CL19 RAM but that only comes in 8GB sticks and that isn't enough for what I have in mind for this system.

I am also seeing a very strange inconsistency on Intel's driver site for this NUC. On any other system a chipset driver dated July 29th is listed but if I check with my actual NUC11PHKi7C, that specific entry is removed from the list of drivers. I assume that Intel is not supporting the driver on Windows 11 (installed on my NUC11PHKi7C) so when detected they remove the driver from the list, I can't think of another explanation. I'm still just testing things out so I downloaded it from a different system and installed it on my NUC11PHKi7C, nothing seemed out of the ordinary.

BHarr8
Valued Contributor I
286 Views

After doing a lot of research today it does look like the best possible RAM for this system is:

JEDEC 1.2v DDR4 3200 CL20 dual rank SODIMMS.

After hours of reading this thread pretty much confirmed everything I was suspecting:

https://www.reddit.com/r/GamingLaptops/comments/msii0g/comparison_of_fastest_3200mhz_jdec_rams_for/

The slightly better timings and dual rank DIMMs might be worth it if you are looking to maximize performance.

Intel really needs to remove the memory setting part of the BIOS, I played around with it more today and it does nothing no matter what you change. I suspect that Intel originally planned on this being an XMP device and when they canceled that functionality they simply forgot to edit the settings out of the menu.

Reply