Intel® NUCs
Assistance in Intel® NUC products
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
12945 Discussions

NUC11TNBi5 And LogiTech



We have several brand new  (5 pcs) NUC11TNBi5 In combination with Logitech Rally Mini Bar.

Lately we have audio problems :cracking sound when typing on keyboard or Tap.

Also when we use NUC standalone with only Logitech mini Bar as audio output with no TAP.

All firmware is updated. Bios version 64..

If we use other audio output like speaker of LG screen no problem.

Since we installed many setups with bios version 58 no problem.

Bios version 62 also fine.

We think it has to do with Bios version 64.

Also we have one new NUC where bios will not start up.

Both power and jumper restore did not work.

And it seems we can not downgrade from 64 back to 62.

Who can help us?



0 Kudos
13 Replies

Hello @CTLSolutions

Thank you for posting on the Intel® communities.


In order to review this further, could you please provide the following details?

1- Just to make sure since you referred to Intel® NUC Board model NUC11TNBi5, are you deploying systems using only Intel® NUC boards? Or are you actually using Intel® NUC Kits/Mini-PCs (e.g.: with default Intel® chassis, etc)?

2- Could you please describe in more detail the audio/sound issues? Would it be possible for you to provide a video showing the behaviors?

3- Besides the co-relation with BIOS 0064, were there any other Hardware or Software changes (e.g.: operating system, driver, or software updates?) that may relate to the point when the issue started?

4- Please elaborate more on how you connect the Intel® NUC and the Logitech* Rally Mini Bar? For instance, the type of cables and ports being used, using any special software for the Logitech device? etc.


5- From one of the NUCs affected by this behavior, please run the Intel® System Support Utility (Intel® SSU) to gather more details about the system:

  • Download the Intel® SSU and save the application on your computer
  • Open the application, check the "Everything" checkbox, and click "Scan" to see the system and device information. The Intel® SSU defaults to the "Summary View" on the output screen following the scan. Click the menu where it says "Summary" to change to "Detailed View".
  • To save your scan, click Next and click Save.
  • Once you have saved the file (.txt file), please attach it to your reply.

To upload and attach a file, use the "Drag and drop here or browse files to attach" option below the response textbox.



  1. Users being unable to downgrade the BIOS from 0064 to older versions is expected behavior. This is noted in the BIOS 0064 Release Notes: "Due to the Intel® ME firmware update in BIOS version 0064, you can’t downgrade to version 0062 or earlier."
  2. We usually handle only one issue per thread (for better issue isolation). Since we noticed that you already contacted Intel® Customer support to open an internal Web Support ticket regarding the other issue "one new NUC where bios will not start up", we recommend to you continue working through that channel regarding this other issue.
  3. Here in the thread, we will focus on the behavior with the NUC and the Logitech device. Thank you for your understanding.


Best regards,

Andrew G.

Intel Customer Support Technician





We integrate Logitech MS teams Room in hospital. We use Logitech Bundles which include. Rally ( mini) Bar, NUC and Tap.


1. The model we recieved NUC11TNK SBNUC11TNKi5000

2. I can upload video but it is to big >71mb.

To describe when i touch keyboard or Tap i hear loud cracking sound. Like an Electronic cash-desk.

Simmilar like this sound

3. No just Windows update, And Intel driver assistant to update intel drivers.

4. Connect mini bar via usb to nuc. Attach Tap via usb to nuc. Connect screen via HDMI to monitor.

Used all original Logitech cables. And changed setup to other NUC with same cables to check.

5. Not possible because the NUC are already installed in Hospital. I can find out if i have another in stock with same issue.





Hello CTLSolutions

Thank you for your response and for all these details.

Just to make sure, we received an internal message to close this request. Is this correct? Please kindly let us know if no longer assistance is required or if this was a mistake.

If you still need further assistance, but you cannot pull the Intel® SSU report from one of the affected systems, you may help us to confirm the following details:

  1. Windows* Operating System, exact version and Build number:
  2. Graphics driver version:

An Intel® SSU report from another one in stock with the same issue (as you mentioned before) would be also helpful.

Best regards,

Andrew G.

Intel Customer Support Technician



Yes, you can close case.

I found out bios 64 was not the issue.

It was a USB audio driver.

This is not show up in Intel driver assistant.

This driver needs manually added.

This solved the audio issue.

Logitech will send replacement NUC for NUC with access to bios.




Can you share the driver please?


I am also having this issue!


Hello CTLSolutions

Perfect! We are glad to know that you were able to fix this issue. Thank you for taking to time to share how you solved this problem, hopefully, it may help other users having similar issues.

As per your request, we will proceed to close this thread now. If you need any additional information, please submit a new question as this thread will no longer be monitored.

Best regards,

Andrew G.

Intel Customer Support Technician




If you install this driver i should fix Audio cracking 

NUC gen 11 > Logitech Rally ( mini) bar.





Im currently having this exact same issue on a NUC11tnKi5 aswell.

Audio seems to be glitching just as in the youtube video, and the problem seems to be happening only when connected to a Logitech conference Rally setup. (Rally was tested with another version of Intel NUCs, but works fine)

We updated all software / firmware available,  tried every configuration of cables, we found some posts about disabling DSP in BIOS but intel NUC doesnt have this option, we assume its not turned on.

Updating driver above also didnt fix it. everything was set to factory config. problem still persist.

If anyone had the same problem and was able to fix it, i would appreciate sharing any info.


Hi Alexis, 

If you're on BIOS 0064

Try the following. Enter the BIOS and go to 

  • Security Tab -> Security Features -> uncheck “Intel Platform Trust Technology”.

Exit and reboot.

For me updating/installing Display Link Drivers did NOT fix the issue. 



Hi Slaite!

Im glad to replay that for now, the problem does appear to be solved! Turning "Intel Platform Trust Technology" did it. its been 30 mins since and the cracking noise isn't back.

Just to clarify, we did a clean restart of windows, and after the first restart the problem came back, (we assume this is due to some windows update installation). AFTER that we disabled intel platform Trust Technology and it never failed since then.

Thank u very much! ill reply in a few days with the final results.


I have recently upgraded the bios to 0064 on a NUC11TNKv7. Experiencing general USB stability issues since. The problem might be related to USB hubs since devices connected through HUBs are more unstable then without. The audio device (SteelSeries Arctic Pro Wireless DAC) is disconnecting or giving distorted sound. The DAC is actually a USB HUB on it's own since it contains multiple audio devices.


I have filed a support ticket since the NUC now is completely unusable due to the BIOS upgrade.


The BIOS does not have the Intel Platform Trust Technology setting - although it does have a similar setting which is already disabled.


Does anyone have the recovery download for the 0062 bios?


You are unable to downgrade the BIOS from 0064 to older versions is expected behavior. This is noted in the BIOS 0064 Release Notes: "Due to the Intel® ME firmware update in BIOS version 0064, you can’t downgrade to version 0062 or ea..."


Hi everyone.

im sad to say the problem still persists, it just so happened to be less frequent. its turning to be a more annoying failure than expected.