Intel® NUCs
Support for Intel® NUC products
12528 Discussions

NUC12WSKi7 Thunderbolt ports are failing

Gijs1
Beginner
175 Views

I'm trying to use an Apple Studio Display with this Intel NUC 12 Pro with Windows 11.

This gave some issues initially because Windows 11 Setup does not support this. But using an HDMI to Thunderbolt converter (Club3D CAC-1333) I managed to complete the Windows 11 Setup.

Since then, I have been able to use the Apple Studio Display on Thunderbolt port 1 without issues for a short while. 5K resolution was there, as well as audio, webcam etc.

After a week or so, Thunderbolt port 1 failed on me somehow. Also a USB-C headset would not connect. I tried several things, like a fresh install of Windows 11 and even installed Windows 10.
This would not fix the issues. By then I was still able to connect the display to Thunderbolt port 2.

More recently this port failed as well. I can now only connect a display to one of the HDMI outputs.

I checked the bios and Thunderbolt has always been enabled there.

I wonder if the ports are broken or if there would be anything I could do to get them working again.

 

0 Kudos
3 Replies
n_scott_pearson
Super User Retired Employee
157 Views

Well, I would be contacting Intel Customer Support to report this possible hardware failure. At the same time, I would become suspicious of a device that eventually kills ports like this. It may be a design issue (I see other reports of issues (though mostly with compatibility) involving Apple displays), it may just be a single bad monitor or it may be exclusively a problem with the NUC, IDK.

After verifying that your warranty is still active (here: Determine if Your Product Is Still Under Warranty), you need to directly contact Intel Customer Support if the analysis points to the need for an RMA replacement process (you cannot do this through the forums). You can start here: Contact Intel Support or use this page where you can directly look up local/country phone numbers: Intel Support Phone Directory.

You can use the online forms service or email, but I actually recommend calling them directly. The above link provides local or toll-free numbers for most countries and these numbers support most local languages. You could also use the chat service (start here: Intel Customer Support Chat), but understand that this service is offered only in English and is subject to the normal (9:00-5:00 M-F) office hours in the Pacific (UTC-8) time zone.

Hope this helps,

...S

Keyaku
New Contributor I
113 Views
Similar to my experience (as Scott has definitely seen); Port 2 is working now, hopefully forever, but Port 1 is not. Once, I installed Windows 11 from a Thunderbolt device on port 1, so it definitely works (or at least worked) outside the final Windows installation.

Very flimsy, and I'm unsure if it's a complete hardware failure or a simple software one.
n_scott_pearson
Super User Retired Employee
104 Views

The only way to know is to do a complete, from-scratch reinstall of Windows 11. Sucks to have to do that.

If you decide to do it, here's the process that I use:

  1. Go here: https://www.intel.com/content/www/us/en/search.html?ws=idsa-default#q=NUC12WSKi7&sort=relevancy&f:@o... and download all of the pertinent installation packages (Hints: If you are not going to use any of the vPro features, you can ignore the NPSS and EMA packages. You can also ignore the Rapid Storage (RST) package if you are not going to use RAID).
  2. After doing a basic install of Windows 11, install the Chipset Device Software (a.k.a. INF Update) and Intel Management Engine Software/Driver package.
  3. Once you have installed these two packages (and rebooted), you can install the other driver/software packages in any order.
  4. Once all of these driver installs are done (and you've rebooted), you can go to https://www.intel.com/content/www/us/en/download-center/home.html and use the links there to install Intel Driver and Support Assistant (IDSA).

Hope this helps,

...S

Reply