Intel® NUCs
Support for Intel® NUC products
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
12739 Discussions

NUC5i5RYK powers on but not all the way


I just purchased a UPS to be able to gracefully shut down my Intel NUC5i5RYK. I shut everything down, and when I plugged it into the new UPS, it started up with the fan on full blast. 

I'm running Ubuntu 21.04.

The BIOS screen doesn't come up. The power button only works to power the device on, but not off. It sounds like the fan is working at max capacity.

Did I fry something? I'm really hoping everything is okay. So far I have tried to plug the NUC directly into the wall (and not the UPS), but during testing, since I cannot power it down with the power button, I find myself just unplugging it while it's trying to start up. I feel like this might be counterproductive and making things worse.

I tried to download the latest BIOS to a USB drive and plugged it into multiple ports, and still no avail. I have tried using HDMI and Mini DisplayPort, and same thing happens.

Is there anything else I can "reset"? Is there a way to confirm if something is actually broken here? Am I missing something obvious?

0 Kudos
1 Solution
Super User

Hi @octalsandroses 

1. You may reset BIOS by disconnecting the power adapter and the CMOS battery for about 15 minutes. The CMOS battery connector is located on board upper (the invisible) side. In order to reach the connector you need to remove the board from the NUC case. This guide will show you how to do this. 

2. I would suggest to update BIOS using BIOS Recovery with the Yellow Security Jumper Removed:

          2.1Prepare USB stick fully formatted to FAT32 with Bios  File . Format your USB with Quick Format option           unchecked. Do not format your USB in MAC (OS) or Linux machine. Use Windows.
          2.2 Disconnect the power adapter and remove the bottom panel from your NUC.
          2.3 Remove the Yellow Bios Security Jumper. (page 52 in Technical Product Specification
          2.4 Insert the USB with the file into rear USB slot. 
          2.5 Reconnect the power adapter and power ON the NUC. Wait 30 sec - 2min. The Recovery process will start automatically and                  will end after 2 -5 minutes.
          2.6 When bios recovery is completed, press and hold the Power Button to switch the power OFF, remove the power, adapter, the                  USB and replace the Security Jumper (pins 1-2) . Reinstall the bottom panel.
          2.7 Power your NUC ON.
         2.8 Enter Bios setting by pressing F2 during boot process.
         2.9 Press F9(followed by "Y"), to set Bios to default settings. Press F10 (followed by "Y"), to save the settings and exit to O.S. Let                   the NUC fully reboot.




View solution in original post

32 Replies
Actually a couple more questions:
1. How can I accept multiple posts as an answer? Both were extremely helpful!
2. What size screws attach the motherboard to the casing?
3. If the problem was the voltage output from the UPS, but the original cable still works, is it fair to assume it’s not necessary to replace it? Or is it possible that it still works but is just less reliable?
Super User Retired Employee
  1. AFAIK, you can't. Pick the one that you consider the best.
  2. One screw should be enough, but if you really want to have a second one, I can get answer from the dev team. If you are in this situation often enough, consider something like:, which should have one that works.
  3. Not sure which cable you are referring to.



@n_scott_pearson Thank you again for all of your help!

I would order a kit like that, but it feels like overkill to order 300-500 screws when I just need 1-4.

I've tried to look on the page that describes screw sizes for Intel NUCs, but I can't seem to find which screw sizes correspond to the motherboard attachment to the casing.

As far as question 3 goes, I was referring to my power adapter, but I ended up returning the replacement one since the original one appears to be working just fine so far! It's been about a week with no faulty booting!

Super User Retired Employee

I mentioned the kit because it might cost you just as much to individually purchase those 1-4 screws!

Alternatively, you could see if your town has a electronics surplus shop. Since these are common to laptops as well, the shop should offer some really cheap.


P.S. I asked the dev team (I used to be part of it before I retired) for the specs for these screws. I will relay when they respond.

Super User Retired Employee

The screws are M2.5*4L K B-ZN #1.


I was easily able to find them using search string "SCREW M2.5*4L K B-ZN #1".



Thank you so much for this @n_scott_pearson ! You have been extremely helpful. 


Unfortunately I'm back @n_scott_pearson and @LeonWaksman. I unplugged it after shutting down completely again, and now when I try to power it on, it sounds like a hair dryer and the fan is running at max RPM. The machine isn't overheated at all.

Also, every so often the power button doesn't register at all, unless I hold it down or press it a few times.

Could I have installed a faulty CMOS battery? Is there a way to tell if this is a hardware failure that is going to cause more issues down the line? Would be happy to run some sort of diagnostics if I ever get this thing running again.

Super User Retired Employee

It is certainly possible to get a bad battery, but I would say that getting a battery with wrong polarity is the more-common issue. Use a meter and check it out - but first check that wire colors and placement match the original battery.



Unfortunately have the exact same problem on the same unit as you have described, after a power failure when our RCD / Safety switch was tripped by the toaster.  I had a similar hiccup a couple of months ago after a power glitch but was able to get the unit to boot after simply taking it apart cleaning the CPU fan area and putting it back together.  But this time it doesn't want to get to post.  

Can turn it on with the power button, but cant turn off, regardless of how long you hold it down.

It just sits there pre-post with the CPU fan on flat chat (fastest).  The only way to turn off is pull the 19v plug.

It's a NUC5i5RYH.  Bought in late 2015.  8GB DDR3 1600 Ram and 256GB Samsung 850 EVO m.2.

I checked the Bios Battery, it is fine. 3.05v. 

Checked the power supply direct and under load, it has a solid 19v.

Tested the 8GB Ram in a laptop and the EVO m.2 in a PC.  Both are fine.

I did the BIOS reset (Removed the battery overnight) , rebooted, same.

Downloaded latest bios .bio file on a 4GB Fat 32 USB stick.

Removed the BIOS security jumper, rebooted, same.

Just sits there pretending to be an expensive and inefficient fan heater, pre-post. Never goes to any other menu.

I have it plugged in directly to a HDMI PC monitor via a Mini HDMI to HDMI cable that I know works


Shouldn't it give me beeps or lights if something is wrong? Does it have an internal beeper?  The internal green LED just near the power button is on solid.  No blinks.


Understand it is out of warranty and support but its only 6 years old effectively.  Any other advice would be gratefully accepted.


Ps : Actually I do notice 2 quick but dim flashes from the amber (HD) LED when I power it on.  But no other LED activity.


Cheers,  Gertsy





Hi to anyone reading this. I have an update. I'm not sure what has happened, or changed, I left the Nuc off for the weekend, with the power disconnected, and the BIOS battery connected. I fired it up today and it didn't go into "high speed fan" mode.  It went straight into BIOS update mode. I updated the BIOS to the latest V and rebooted. Now everything is working fine.  Very strange and still a bit concerning.  I have rebooted a number of times and left it disconnected from power for a few hours and it seems to be fine when reconnected.   Weird,  but I'm happy its working again.


@Gertsy - I'm sorry you've had the same problem as me, but I'm glad you got it back working! I also am back up and running but really wish I knew if there was a good tool to pinpoint what the issue actually is.

I don't understand why sometimes it works, and sometimes it reverts to being super loud.

@n_scott_pearson Now that we're both up and running again, are there any good diagnostics to run to see if there is something faulty to keep an eye on for the future?

Super User Retired Employee

Well, in addition to the Intel Processor Diagnostic Tool, you can run the diagnostics in AIDA64. As we've seen, it is important to keep the NUC clean and watching temperatures is an important indicator. I run CoreTemp and the All CPU Meter gadget on my machines. AIDA64 is also good for this as well.

As for the bizarre issues you have both seen, I guess I should add making sure that you have a charged CMOS battery. Time is an issue here; it isn't just how much time the NUC remains powered down that affects the life of the battery. I bought a bag of these battery packs (pretty cheaply) to ensure that I don't go beyond 3 years on a battery.

Hope this helps,