Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Manager
1,652 Views

NUC5i7RYH Drivers fail to install but no warning.

Hi,

I am trying to update the drivers on my system.

Running the Support Assistant

https://www.intel.com/content/www/us/en/support/intel-driver-support-assistant.html Intel® Driver & Support Assistant

It tells me that two drivers need updating.

Wireless from 19.51.8.2 to

Updated Version: 20.10.2

Release Date: November 20, 2017

Size: 94 MB

Installs the Intel® Wireless Technology-based (WiFi) driver for Windows® 10 for the Intel® NUC Kit NUC5ix3RY and DN2820FYKH.

and

LAN from 12.15.25.6712 to

Updated Version: 22.7.1

Release Date: October 27, 2017

Size: 60 MB

This download record installs the LAN driver for the Intel® NUC product with the Intel® Gigabit Ethernet Network Connection using Windows® 10.

I download.

I install.

I reboot.

I rerun the Support Assistant.

Still the same two drivers are listed as requiring updates.

0 Kudos
3 Replies
Highlighted
Super User
14 Views

Sorry to disappoint you. The Intel Driver & Support Assistant can not be trusted yet. This utility is not fully debugged. The best way to update drivers is manually. You shall start with the Chipset Driver and the Intel Management Engine Driver (if you want to update them). Reboot the computer and that install all the other drivers (sequence is not important) . Now, you need to reboot the computer only once, after the last driver is installed.

Leon

0 Kudos
Highlighted
Community Manager
14 Views

Tiz a week of disappointments.

Downloaded and tried to install manually.

They go through the motions and proudly annouce "Success!" but in the end it's a fail. No change.

I then completely removed the drivers form the system and reinstalled.

Again they go through the motions and proudly annouce "SuccessI" but in the end it's a fail.

Indeed the LAN driver took me back a version. Which I then updated through the Windows device manager app.

Oh well.

Been a bad week for Intel hardware and software around here.

0 Kudos
Highlighted
Beginner
14 Views

Hi BobTrav

Sorry, don't have a solution but seem to have exactly the same Problem.

Manual Installation (even after preceeding Deinstallation) does not change the behavior.

The Wireless 19.51.8.2 remains installed and 20.10.2 will not be installed, whatever and howoften you try to install it.

Clicking the blue "Update availlable" buttons shows Version Info for about half a second at each click.

Cold comfort, however, all seems to work still as it should.

0 Kudos