Intel® NUCs
Assistance in Intel® NUC products
Announcements
All support for Intel® NUC 7 - 13 systems is transitioning to ASUS. Read more.
13496 Discussions

NUC6CAYH Gigabit up/down limited to 10-12Mb/s !?

garuyred
Beginner
344 Views

Hi Intel,

 

I've been struggling for a few days with my NUC6CAYH and a detail I found about the Gigabit card and connection.

 

I have checked everything and it is OK (cable, drives, bios... all updated and tested). I work with Win10 Home and I've tried Linux Mint in case the operating system was the problem.

 

When I do a speed test from the NUC6CAYH, I get back that I am indeed connected to Gigabit and that I have 95-97Mb/s transfers. This is perfect and is the same as on any of my other computers.

 

The problem is when I download or upload files to the Internet. The maximum speed in any of the cases and operating systems is ALWAYS around 10-12mb/s (it is the highest peak speed). Those same files on any of my other computers immediately exceed 10-12mb/s working symmetrically at a speed between 80-90mb/s. What's going on?

 

If this NUC6CAYH has Gigabit, why is it giving such a bad transfer? Is there any limitation or bottleneck in this model? The NUC is a Celeron with 4GB DDR3 and 128GB M.2 (speed problem for this simple task I think there is not).


I honestly don't know what else to try before I discard this machine as an option for the backup work I need.

 

I have seen some documentation where the user connected the NUC6CAYH to a NAS and had this limited speed 120-150Mbps (even over Wifi) so maybe it is a limitation of the equipment and not a problem.

 

But I find it strange that a device has Gigabit and then ONLY works at 100Mbps maximum, it's totally absurd.

If someone can shed some light on this it would be great. And if someone has the same model and can do the speed and upload/download tests to see if it overcomes that limitation it would be wonderful.

 

Thanks for any help and tests you can check on your NUC6CAYH.

We are in contact.

0 Kudos
3 Replies
David_G_Intel
Moderator
321 Views

Hello @garuyred


Thank you for posting on the Intel️® communities. To investigate please share with us the Intel® System Support Utility (Intel® SSU) results 


Regards, 

David G 

Intel Customer Support Technician


0 Kudos
garuyred
Beginner
312 Views
Hi David G.:

First of all thank you very much for your quick response.

In the end I moved the NUC as close to the router as possible and connected it directly and gained a lot of speed. It is working at 60-70mb/s much more than expected.
Maybe the problem is the switch, although I do not understand why only the NUC has problems, all the other devices work connected to that switch at 90-97mb normally.

As I am in a hurry to continue with the backup, I leave the investigation finished. I really appreciate that SSU application that I will investigate later.

I finally get the NUC at the speed I needed and doing the job I wanted it for.

I will recommend the forum because there is a lot of interesting information to keep our NUCs up to date.

Thank you
0 Kudos
David_G_Intel
Moderator
305 Views

We are glad to know you found a solution, thank you for taking the time to share this fix, and hopefully, it may help other community members experiencing similar behavior. Since the thread is now solved, we will proceed to close it. 

Please keep in mind that this thread will no longer be monitored by Intel. Thank you for your understanding.  

 

Best regards, 

David G 

Intel Customer Support Technician 


0 Kudos
Reply