Community
cancel
Showing results for 
Search instead for 
Did you mean: 
TEato1
Novice
6,541 Views

NUC6CAYH Intel(r) PTT Recertification Service Using 30-40% CPU Constantly

Yes I have:

  • Waited for it to stop.
  • Reset the BIOS (this is the most bug-ridden BIOS I have ever encountered by the way, despite the high number of updates being released).
  • Reinstalled the TXE driver.
  • Reinstalled Windows (clean).

No matter what I do, the Intel(r) PTT Recertification Service is hogging between 30 and 40% of the CPU, 24/7. Sometimes it stops for less than a minute, but then it immediately resumes. I have reinstalled the driver and Windows multiple times, and it's always the same.

There's aren't many explanations for this problem; It's Intel's hardware running Intel's set of drivers on a clean Windows 10 x64 install with nothing else running. It seems like an Intel problem.

Another thread on here said that the issue resolves itself, with someone positing that the system needs to be recertified after a change. However I've had this system idling for 5 days straight and Intel(r) PTT Recertification Service is STILL hammering the CPU. Perhaps this could have something to do with the TXE driver being 2 years old?

0 Kudos
10 Replies
idata
Community Manager
3,740 Views

Hello Wattle,

 

 

Thank you for joining the Intel Communities.

 

 

In order to help you better I would like to gather more information about the configuration you have in the computer. Please attach to this thread the .txt file the Intel® System Support Utility will generate https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility

 

 

If possible provide a screenshot of the service Intel® PTT Recertification Service showing the CPU utilization.

 

 

To attach a file, you must click "Use Advanced Editor" on the upper right hand corner of the response box, then the "attach" option will appear on the bottom right hand corner of the response box.

 

 

Regards,

 

Fred D.

Intel Customer Support Technician

Under Contract to Intel Corporation

TEato1
Novice
3,740 Views

Hi Fred, I have attached the requested report, and here is a screenshot of the CPU usage:

idata
Community Manager
3,740 Views

Hello Wattle,

 

 

Thanks for the information you sent to me.

 

 

Do you use Intel® Platform Trust Technology (Intel® PTT)? If you are not using it please access the BIOS and disable it. Once disabled boot the computer into Windows* and check if issue persists or not.

 

 

Regards,

 

Fred D.

 

 

Intel Customer Support Technician

 

Under Contract to Intel Corporation
TEato1
Novice
3,740 Views

Yes I use PTT. The issue does not persist with PTT disabled in the BIOS, but PTT must be enabled for TPM to work and I need TPM for BitLocker, so that's an unacceptable solution.

idata
Community Manager
3,740 Views

Hello Wattle,

 

 

I was able to reproduce the issue in our lab with the exact same computer model. I will do further research about this. I will post information on this thread as soon as I have it.

 

 

Regards,

 

Fred D.

 

 

Intel Customer Support Technician

 

Under Contract to Intel Corporation
idata
Community Manager
3,740 Views

Wattle: I just received an update on this subject, please follow the steps below to try to fix this problem:

-In Programs and Features, uninstall Intel Trusted Execution Engine.

 

-Downloaded the latest Intel® TXE driver downloaded from: https://downloadcenter.intel.com/download/26435/.Unzip https://downloadcenter.intel.com/download/26435/.Unzip

 

-Navigate through the folder to the \Installers\TXEI\Win10\ folder.

 

-Right-click on txei.inf and choose Install.

 

-Restart the computer.

 

-Now check Task Manager. Intel PTT EK Recertification Service should no longer appear.

Please let us know if this workaround in any way affects Bitlocker.

Regards,

 

Alberto R.

Intel Customer Support Technician

 

Under Contract to Intel Corporation
TEato1
Novice
3,740 Views

I have followed your advice and uninstalled the TXE driver, then reinstalled is (that's the same driver I was already using) except using the right-click txei.inf method. This has prevented the PTT EK Recertification Service from running (presumably because it was excluded from the installation altogether), while avoiding any errors in device manager.

Bitlocker functionality appears to be unaffected.

So thanks, that seems to be an acceptable solution, though I have to ask: if it can just be excluded like that, what was the point of the PTT EK Recertification Service? Your advice seems to be tacit acknowledgement that the service is unnecessary bloat, at least in the case of this system.

Also, I would suggest that you update the TXE driver installer to avoid this issue for everyone else who installs it. Searching the internet, this issue of the PTT EK Recertification Service hogging CPUs is pretty widespread, affecting devices beyond this model of NUC.

idata
Community Manager
3,740 Views

Wattle: You are very welcome. We are looking into the issue described and in the meantime we provided that work around for this type of scenario.

 

 

Thank you very much for your feedback, I already reported to the product team for them to be aware of your comments.

 

 

Regards,

 

Alberto R.

 

 

Intel Customer Support Technician

 

Under Contract to Intel Corporation
LHill_Intel
Moderator
3,740 Views

Hi Wattle,

I have good news for you and anyone else who has seen this CPU utilization problem. If you do the following:

Then the problem should disappear.

Regards,

Lois H.

Intel

Ronny_G_Intel
Moderator
3,740 Views

Hi everyone,

I work for Intel Customer Support and I just wanted you to know that we are currently looking into this issue.

I will keep this conversation updated.

Thanks,

Ronny G

Reply