Showing results for 
Search instead for 
Did you mean: 

NUC6i5SYH Cannot update BIOS [SOLVED]

I have a NUC6i5SYH with Windows 10 Pro currently using BIOS SYSKLi35.86A version 28 and I cannot update the bios. I have tried 3 different methods on a variety of the different BIOS versions, and they all have the same problem.

1.) F7 update direct file selection (with inserting the USB before and after posting and pressing F7)

2.) USB DOS boot using IFLASH

3.) Windows installer

Also Using the UEFI the online update doesn't work because it fails to communicate with the server.

For the first two methods immediately after I proceed with the flash the computer turns off and the led light blinks orange on for 2-3 seconds, and off for 1-2 seconds repeated indefinitely. According to the blink codes, this may mean that the power on circuit has failed. If the bios flash would proceed as normal, then the computer should restart and begin bios flashing. If I force off the computer (by holding the power button for 10+ seconds) then turn it back on, the computer fails to post and it goes into recovery mode - rolling back the bios and any configurations.

The third method when I try to launch any of the executable I get the message: "current bios is an unsupported legacy bios". And nothing happens.


The reason why I am trying to update the bios because I believe it will fix my BSODs. Currently my fresh installed Windows doesn't BSOD at all until OS updates are installed. After updates are installed only safe mode doesn't BSOD. This started happening around 2 months ago - before it was working fine for two years. This BSOD is the undefined behavior type of BSOD so I get all sorts of stopcodes. Did memory tests, showed up nothing. Looking like a software problem to me.


Okay, I think I found out how to update but not sure if it is the correct method. I placed a single bios file root level on a USB drive and inserted it. Removed the BIOS security jumper inside the computer. Turn it on and pressed F7 and now it is flashing the bios.

Update 2:

Bsods still exists after updating BIOS. =(

0 Kudos
2 Replies
Super User

Hello KQuoe49

1. Next time while you are updating your Bios, please use the Bios recovery: BIOS Recovery Update Instructions for Intel® NUC . As you can see there are two methods:

- Power Button Menu

- Security Jumper removed

As you can see you have used the Security Jumper removed method (it is not required to press F7, as in this case the recovery starts and end automatically).

If you will next time update your Bios from Power Button Menu (in this method, you are not required to open your computer, follow those steps):

  • Prepare USB stick fully formatted to FAT32 (disable quick format option during format). Save the Bios file *.bio on this stick and insert it into USB slot (NUC shall be OFF).
  • Press Power Button for about 3 seconds. You should release the Power Button soon as the power led changes color from blue to amber. NUC will reboot into Power Button Menu.
  • Press F4 and the recovery shall start.
  • When the recovery finishes, pull out the power cord.
  • Replace the power cord and press Power Button to switch the computer to ON.

2. Now about the BSOD on your NUC. In the early Bios version it was bug, that the voltage regulator circuitry wasn't well protected. This was fixed two years ago in Bios ver. 0042. Since you have never updated your Bios, this failure probably has occurred (i.e. voltage regulator was permanently demaged) in your NUC. Once it happened, you can not repair it and your NUC must be replaced. So, now please check if your NUC is still covered by 3 years of Intel International Warranty: Warranty Information . If yes, ask Intel service to replace your NUC.

Hope this will help



Thanks for the reply lw1948. So far I have narrowed it down to a driver during the fresh install process. I had to disabled automatic driver installation. I was able to install all of the drivers except for the igpu driver. BSODs occur when I install any version of the Intel HD Graphics drivers. Specifically the BSOD either occurs when I restart the computer and the driver goes into effect or when the screen blips and the computer doesn't need to restart.

Most likely this could be a CPU degradation issue. This coincides with the time heavy prolonged gaming usage from about new years to when the BSODs started happening. Fortunately, the NUC is still under international warranty.