Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Manager
2,678 Views

NUC6i5SYK only 2.4GB of 4GB RAM available, 1.6GB reserved for hardware - how to increase the usable RAM?

Jump to solution

NUC6i5SYK only 2.4GB of 4GB RAM available, 1.6GB reserved for hardware. Our other systems have 3.3 GB available. OS is Win7/32, Bios-setting for reserved graphic RAM is 128MB. See the screenshots, one of a NUC with 4GB and one for comparision.

0 Kudos

Accepted Solutions
Highlighted
Moderator
115 Views

32-bit Windows has an address space of 4GB. Part of that is used by system BIOSes and graphics memory.

I would recommend that you check the amount of memory used for the graphics solution as recommended earlier, please see the following article that shows how to check on it using Windows: http://www.intel.com/content/www/us/en/support/processors/000005472.html Graphics Memory FAQ for Windows 7*, Vista*, XP*, and 2000*

This is reason why you are not seeing the total amount of physical memory available on your system, you can also go into the BIOS and set this up.

Thanks,

Ronny G

View solution in original post

26 Replies
Highlighted
Super User Retired Employee
115 Views

One thing to check is the amount of RAM that has been dedicated to the on-chip graphics solution. Go into BIOS Setup (Visual BIOS) and navigate to the Devices screen and the Video tab. Lower both the RAM dedication and the Aperture Size.

Hope this helps,

...S

0 Kudos
Highlighted
Moderator
116 Views

32-bit Windows has an address space of 4GB. Part of that is used by system BIOSes and graphics memory.

I would recommend that you check the amount of memory used for the graphics solution as recommended earlier, please see the following article that shows how to check on it using Windows: http://www.intel.com/content/www/us/en/support/processors/000005472.html Graphics Memory FAQ for Windows 7*, Vista*, XP*, and 2000*

This is reason why you are not seeing the total amount of physical memory available on your system, you can also go into the BIOS and set this up.

Thanks,

Ronny G

View solution in original post

Highlighted
Community Manager
115 Views

Thanks for your reply Scott and Ronny,

set the values to the smallest possible, no change. Bios version is the newest (51). On every other system (HP, Fujitsu, older NUC Generations...) i have 3.2-3.4 GB available.

Any other idea?

Thanks in advance

Mathis

0 Kudos
Highlighted
Community Manager
115 Views

Hello, MM2:

 

I found this article from MS that you could check and try out :)

 

https://support.microsoft.com/en-us/kb/978610 https://support.microsoft.com/en-us/kb/978610

 

Additionally, a good troubleshooting step to perform would be a BIOS recovery, with Intel boards, when you perform this procedure, it re-writes and add all the updates that have been included in previous versions of the BIOS, in the past there has been fixes related to memory, for that reason I am positive this can help with your inquiry.

 

Instructions for BIOS recovery (to be performed to the latest version): http://www.intel.com/content/www/us/en/support/boards-and-kits/000005532.html http://www.intel.com/content/www/us/en/support/boards-and-kits/000005532.html

 

Please let us know how it goes.

 

Regards,

 

Esteban C
0 Kudos
Highlighted
Community Manager
115 Views

Hi, MM2:

I just wanted to verify if you were able to get this configured as desired.

Hope I can hear from you soon

Regards,

 

Esteban C
0 Kudos
Highlighted
Community Manager
115 Views

Thank you Esteban,

tried the BIOS recovery --> no change.

The Microsoft article describes the standard behavior af Win7, it could not explain why the NUC6 has a gigabyte less than ANY other system.

Is anyon here who can test his NUC6 how much RAM is available?

best regards

Mathis

0 Kudos
Highlighted
Valued Contributor I
115 Views

better check how much is reserved for the hardware. I own a NUC6 and will check when I get home.

I remember a 32bit Acer laptop I owned with 4GB RAM, and almost 500MB was reserved for the HW. that's a lot, but your 1GB loss is strange

0 Kudos
Highlighted
Community Manager
115 Views

yes, 500-700 MB is normal, here i got 1600 MB reserved (or in use for whatever...)

0 Kudos
Highlighted
Novice
115 Views

I'm curious, why did you install 32bit Windows? Do you have an app that doesn't run in 64bit?

You may be better off with 64bit Windows since you can free up that 1.6GB and potentially run Windows with more RAM despite the larger footprint of 64bit exe's/dll's.

0 Kudos
Highlighted
Community Manager
115 Views

Hello, MM2 :

Thank you for the answer, have you changed the stick(s) of RAM between the DIMMs? I have seen some peers fixing this after doing this.

Additionally, what is the model of the RAM you have? This is usually noted in a white sticker in the module.

Regards,

 

Esteban C
0 Kudos
Highlighted
Community Manager
115 Views

Thanks K2A3,

unfortunately we still need 32bit on 70% our machines, due to older software. I've set up a test-machine with 64bit and voila, only 111MB are reserved. Think, this is a driver problem only Intel can solve. And yes, i know, that they say, that the NUCs are for 64bit only. Maybe this is why...

Attached a 64bit screenshot:

0 Kudos
Highlighted
Novice
115 Views

It is probably the other devices in the system are reserving the RAM. I suppose you could try disabling some of them to see if it makes any difference.. IR Receiver, Thunderbolt, audio, etc..

0 Kudos
Highlighted
Community Manager
115 Views

Thanks Esteban,

reseating or slot switching does not change anything. We use Kingston modules, see the attached pic. On 64bit they are fully usable.

0 Kudos
Highlighted
Community Manager
115 Views

have disabled everything except the LAN port...

0 Kudos
Highlighted
Community Manager
115 Views

MM2 :

Thank you for the information provided.

I checked this in one of the systems we have, Windows 7* 64-bit, and the Hardware reserved memory was 55 MB

Sought deeper in MS forums and found a similar scenario, people at MS recommended the following:

-Press windows key + R

 

-Type msconfig and hit enter

 

-Go to Boot > Advanced options

 

-Uncheck "Maximum memory:" if checked.

I checked that, selected 4GB as the limit (system has 8GB) rebooted the system and it had the same look as the screenshot you sent at the beginning of this thread.

I'm Positive this will help please let me know how it goes.

Regards,

 

Esteban C
0 Kudos
Highlighted
Community Manager
115 Views

Hello, MM2:

Just checking here if you were able to try the troubleshooting provided above.

Please let me know

Regards,

 

Esteban C
0 Kudos
Highlighted
Community Manager
115 Views

Hi, MM2:

Were you able to perform the troubleshooting recommended above?

Please let us know if further support is required.

Regards,

 

Esteban C
0 Kudos
Highlighted
Community Manager
115 Views

Back from vacation now. Thanks Esteban, tried that, but no change. In 64bit there is no problem, only in 32bit exists the memory hole. Tested a Gigabyte Brix with the same chipset --> same problem. Think, this is skylake-chipset-related, not only NUC.

MM2

0 Kudos
Highlighted
Community Manager
115 Views

Hello MM2,

Hope you had a great time during your vacations!

Let me get my hands on a Windows 7* 32-bit ISO to attempt to replicate this with one of our Intel® NUC Kit NUC6i5SYKs.

As soon as I get this done, will let you know my findings :)

Regards,

 

Esteban C
0 Kudos