Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
9,363 Views

NUC6i7KYK: Display Sleep, Windows Shrink & Migrate to Upper-left Corner of Display

NUC6i7KYK experiencing the symptom of when the display goes to sleep, all my windows shrink to about 1024x768 and, upon waking, are all bunched-up in the upper left corner of the screen. Here's what I've done to try to troubleshoot:

  1. Install latest Intel graphics driver from here: https://downloadcenter.intel.com/product/89187/Intel-NUC-Kit-NUC6i7KYK https://downloadcenter.intel.com/product/89187/Intel-NUC-Kit-NUC6i7KYK - done. At the time, the latest version was version 15.40.23.4444. Problem persists.
  2. Search the internet for similar problems - found this: http://www.tomshardware.com/forum/id-2459135/u28d590d-nvidia980-displayport-powersave-shrinking-wind... http://www.tomshardware.com/forum/id-2459135/u28d590d-nvidia980-displayport-powersave-shrinking-wind... - this involves editing the registry and forcing d70 (hex for 3440) and 5a0 (hex for 1440) values into PrimSurfSize.cx and PrimSurfSize.cy categories. Seemed to work until Intel driver was updated to latest version (15.40.24.4454) then problem returned.
  3. In frustration, did a complete re-install of Windows 10 Pro (including all patches and SW stack) using only latest drivers installed via Microsoft. Problem GONE, but graphics were a bit "glitchy" - forced to install Intel Graphics driver to resolve those problems.
  4. Installed latest Intel graphics driver (15.40.24.4454) and problem returned! I did notice that, post install and reboot, the Intel graphics driver pops up a calibration window that appears to set some variable to...1024X768. But, I cannot find where to change this, despite looking for several hours.
  5. Found this post on this forum (/thread/63548 https://communities.intel.com/thread/63548) where NUC5I5RYH owners experienced the exact same thing, which was cured by an update to the Intel graphics driver.

System Configuration:

  • Samsung 512GB 950 Pro (running latest firmware)
  • 2X16GB G.Skill 2800 MHz DDR4 (running @ 2400 MHz for now)
  • Windows 10 Pro, Version 1511, Build 10586.318 (fully updated and patched as of this AM)
  • Monitor LG 34UC97S (Ultrawide) attached via DP 1.2 (tried 2 different cables, both verified good on another system)
  • Graphics Driver: Intel 20.19.15.4454 (most current as of this AM)

In addition, under Advanced Display Settings -> Display Adapter Properties -> Monitor, my monitor shows up as "Generic PnP Monitor". This is interesting because, while running just Windows 10, it properly showed up here as an LG 34UC97. I just tried to re-install LG's monitor driver (which claimed success) and rebooted, but the monitor still shows up as Generic PnP Monitor. Why this is interesting is Intel's HD Graphics Control Panel reports (correctly) that the selected display is a "Digital Display LG Ultrawide". Thus, I've got conflicting information.

Please help - this is making me crazy, is a sinkhole for time, and forcing the display to remain awake is not especially power-efficient...

71 Replies
Highlighted
Novice
440 Views

Anybody? I had opened a case with Intel support (7001038267), but the advice I received directed me to installing the existing beta driver (which has now been promoted to the currently released version). Problem unresolved.

0 Kudos
Highlighted
Community Manager
440 Views

Hello nuc-nuc,

 

 

I'm sorry that it took me some time to come around to this post and to be able to test the graphics driver.

 

 

From my end I did not experience similar issue, at this point I suggest you to check with your monitor manufacturer to see if they have a newer http://www.intel.com/content/www/us/en/support/graphics-drivers/000005952.html INF file version that you can install in your system.

 

 

Also, I can suggest you the following:

 

 

Uninstall the Intel® Graphics driver; please see http://www.intel.com/content/www/us/en/support/graphics-drivers/000005598.html Uninstalling the Intel® Graphics Driver and Intel® Display HDMI/Audio Driver

 

 

Once you uninstall the Intel® driver download the Beta driver and reinstall it, you can download it here:

 

https://downloadcenter.intel.com/download/25957/Intel-Beta-Graphics-Driver-for-Windows-10-and-Window... Intel® Beta Graphics Driver for Windows® 10 and Windows 7*/8.1* [15.40]

 

 

Once the driver is installed restart your system (it will ask to restart). If you are using HDMI Install the https://downloadcenter.intel.com/download/26061/HDMI-2-0-Firmware-Update?product=89187 HDMI 2.0 Firmware Update. Please make sure you are not using any adapters, use straight connection, I mean use an HDMI from the NUC port to an HDMI to the Monitor/TV port.

 

 

Make sure you also have the latest https://downloadcenter.intel.com/download/26044/Intel-Chipset-Device-Software-for-Intel-NUC?product=... chipset driver and https://downloadcenter.intel.com/download/26051/Intel-Management-Engine-Driver-1-5M-for-Windows-10-f... Intel® Management Engine Driver

 

 

Make sure you also have the https://downloadcenter.intel.com/download/26039/BIOS-Update-KYSKLi70-86A-?product=89187 latest BIOS version for your NUC, please see http://www.intel.com/content/www/us/en/support/boards-and-kits/000005850.html F7 BIOS Update Instructions for Intel® NUC

 

 

Follow these steps to change the display resolution:

 

 

Right-click the Desktop (or press Ctrl Alt F12) and select Graphics properties.

 

If you are using Windows 8 or 8.1, you need to be in Desktop mode before you can right-click the Desktop.

 

For Windows 8 or 8.1, select Display from the options presented.

 

When the Intel® Graphics Control Panel displays, go to the Resolution section. Click the drop down and select a resolution size and refresh rate from the list that displays.

 

Click Apply. You are prompted with this question, "Do you want to keep these settings?" Once you have the resolution you want, click Ok or Yes.

 

Also, make sure with your display manufacturer that your display supports this resolution and the refresh rate used.

 

 

If the problem continues, it would be recommended checking if you have a high quality cable.

 

 

If you are attempting to connect to a TV that supports 1080p, 4K, 3D or Deep Color, you will need to use a High Speed HDMI Cable. To verify you have one of these, look along the cabling itself for the printed text which says "High Speed HDMI Cable." If it is not there, you may not be using a cable that is required to work with your display device.

 

 

 

Best wishes,

 

 

Ivan

 

0 Kudos
Highlighted
Community Manager
440 Views

Hi,

 

 

I'm just following on this thread to ask you if your issue was resolved with the information provided above or if you still need further assistance.

 

 

Thanks,

 

 

Ivan

 

0 Kudos
Highlighted
Novice
440 Views

Sorry - was on a business trip Sun - Fri last week and not monitoring this thread. On Saturday, I noticed that, when the display sleeps (still), the problem continues. Yesterday, while searching the broader Intel site for driver updates, I found driver version 15.40.25.4463 here https://downloadcenter.intel.com/product/88357/Intel-Iris-Pro-Graphics-580-for-6th-Generation-Intel-... Drivers & Software and downloaded and installed it. This AM, I found that my display was asleep so I wiggled the mouse and...all the windows were shrunken and in the upper-left corner of the display.

One thing I omitted from the earlier problem statement: when the display is sleeping, I hear the system making sounds like connecting/disconnecting a USB drive...over and over again. Typically, I turn the sound down or off, but sometimes when I step away from the system and plan on coming back, the system is making these sounds...only when the display is asleep. Can't say 100% that this is related to the above-described problem...

0 Kudos
Highlighted
Novice
440 Views

Hello Ivan,

In response to your post above, I have undertaken to make sure all of your above steps have been followed:

  • The latest LG Win 10 monitor driver file has been downloaded from here http://www.lg.com/us/support-product/lg-34UC97-S LG 34UC97-S Support: Manuals, Warranty & More | LG U.S.A - and installed
  • I have installed and tested with the following versions of the Intel graphics driver
    • Beta_15.40.23.64.4444, GFX_Win7_8.1_10_64_15.40.23.4444, GFX_Win8.1_10_64_20.15.40.24.4454_KY, and win64_154025.4463
  • Latest HDMI updated downloaded and installed (HDMI 2.0 Firmware Updater Version 0x07_0x20) - although I am using the DisplayPort to drive my display
  • Latest Chipset (Chipset_Win7_8.1_10_10.1.1.18) and ME (ME_Consumer_Win_10_11.0.6.1193) drivers downloaded and installed
  • My system is running the latest BIOS (KYSKLi70.86A.0035.EB)
  • I hate two verified functional DP cables. I have a slightly older NUC that I can swap in/out (same OS, graphics driver version, etc.) and it does not experience the same problem with this monitor

Despite the above, the problem persists. Any other ideas?

Thank you!

0 Kudos
Highlighted
Community Manager
440 Views

Open the Intel® HD Control Panel and press Ctrl-Alt-F8 to set the graphics to defaults and to see if that can help you any better.

 

 

Other than that, I will need to further investigate on this.

 

 

Regards,

 

 

Ivan

 

0 Kudos
Highlighted
Community Manager
439 Views

Could you please capture a picture of the issue if it is possible for us to further investigate on this?

0 Kudos
Highlighted
Novice
439 Views

I tried the CTRL+ALT+F8 combo and the screen flashed black, then resumed. I then set the screen sleep interval to 1 minute in Win 10, then let the system sleep. Problem persists.

I then rebooted, opened four typical apps (Chrome, Task Manager, Postbox and Crashplan), took a picture of their positions, then let the system go to sleep. The problem seems to come when the monitor goes into power save mode after the system sleeps. Here is the pre-sleep window configuration:

...and here is what it looks like after I've woken it up after sleep:

...and here are the various windows spread out (no resizing done by me):

For now, the only way to avoid this behavior is to prevent the system from sleeping (very wasteful). Thanks for any help you can provide!

0 Kudos
Highlighted
Novice
439 Views

I found several other people with similar issues in this thread:

http://www.overclock.net/t/1235582/dealing-with-displayport-hdmi-autodetect Dealing with DisplayPort/HDMI autodetect

From the thread, it appears that, when the computer puts the display to sleep, the monitor eventually powers down to save power...causing the graphics driver to start hunting between hdmi, dp, etc. for an alive monitor (hence the connect/disconnect sounds). I downloaded, tested and ran usblogview (http://www.nirsoft.net/utils/usb_log_view.html USBLogView - Records the details of any USB device that is plugged or unplugged into your system ) throughout my testing, and there was no USB connect/disconnect detected at all...until I actually disconnected and re-connected an actual USB device...so the sounds are likely being made because of the sleeping DP connection. Nvidia solved this with an update to their driver. And, # 5 in my first post above links to a thread where this problem was reported and solved on earlier NUC's with an update to the Intel display driver.

Question to Intel team: Can you please check the changes made to that other NUC graphics driver, and verify that they are still in-play for the Iris Pro 580 in our Skull Canyon NUC's? I suspect is has to do with either disabling the DP autodetect feature, or just killing the sounds that come as a result of this activity....

BTW - my work-around is to go into power profiles and tell the system to never put the display to sleep. When I'm done for the day, I just put the entire system to sleep, then wake up when I return. Since I have a very fast NVMe SSD, it comes to life almost instantly. But I would like to get things working properly.

0 Kudos
Highlighted
Community Manager
439 Views

Thanks for this additional information, please allow me to further investigate on this issue.

 

 

Regards,

 

 

Ivan

 

0 Kudos
Highlighted
Novice
439 Views

Thx. I just migrated my new NUC6i7KYK to "standby" status and promoted my 2013 NUC DC53428HYE back to "production" status until the graphics issue is sorted out. Yeah, the i5-4327U is considerably slower, I've *only* got 16 GB slow RAM vs. 32 GB faster RAM, the SSD is slower and smaller (1x1TB mSATA vs. 512 m.2 NVME and 1TB mSATA), and fewer USB 3.0 slots, but it is stable and 100% bomb-proof.

Using RDC, I can get to the NUC6i7KYK in headless mode with all power-saving features turned off, and sidestep all the issues. So - I'm still interested in resolving the graphics issue, but the irritation has been moved to the back burner.

0 Kudos
Highlighted
Moderator
439 Views

Hello nuc-nuc,

I am really sorry to hear that your NUC system is exhibiting this odd behavior.

I would recommend that you run latest BIOS 37 (it was just released) and it is available here: https://downloadcenter.intel.com/download/26087/BIOS-Update-KYSKLi70-86A-?product=89187 Download BIOS Update [KYSKLi70.86A]

If your system still exhibits the same behavior after running latest BIOS I would encourage you to contact support to get this issue resolved or the unit replaced: http://www.intel.com/content/www/us/en/support/contact-support.html# @11 Contact Support

Please make reference to ticket number: 1068624

Regards,

Ronny G

0 Kudos
Highlighted
Novice
439 Views

Hi Ronny,

Thanks for the note. I just reviewed the release notes, and it doesn't look like the BIOS 37 changes address my issue:

 Disabled USB compliance mode.

 Modified the setup items; Power Limit 1 & Power Limit 2 Power Limit 1= 35w Max = 50w Power Limit 2= 40w Max = 60w

 Fixed an issue where Thunderbolt™ wouldn't see all the connected devices, when daisy chained.

 Fixed a Thunderbolt boot issue where enabling an external graphics card would cause a yellow bang.

...but you never know. Will download, install and test - and report back with findings.

0 Kudos
Highlighted
Community Manager
439 Views

Hi,

 

 

We will appreciate if you let us know how it goes after the bios update and if the problem persists, I suggest contacting support as Ronny mentioned above to get a replacement for the unit.

 

 

 

Regards,

 

 

Ivan

 

0 Kudos
Highlighted
Novice
439 Views

Well, I've updated the BIOS to v37, and the problem persists.

But, here's an interesting thing. When I moved my NUC6i7KYK (Skull) from main to secondary status (literally on the other side of my desk), I connected it to a "lesser" monitor (a Dell U2713) and replaced it with my old NUC DC53428HYE (old NUC) - all cables remained in their original location. In this new location, Skull performed perfectly - I was able to let it sleep, etc. and no windows migrated. The old NUC works perfectly wherever it is. Upon upgrading the BIOS to v37 on Skull, it looked to work perfectly when attached to the Dell monitor, but when moved back to primary status and reconnected to the LG 34UC97S (where old NUC previously was), the problem returned!

Thus, I've been able to eliminate cables, BIOS, etc. from the equation. The problem is between the NUC6i7KYK and the LG 34UC97S monitor only. I do not believe the system needs to be returned, as it tests perfectly with the Dell monitor, but when attached to the LG Ultrawide, problems arise. Interesting to note that the old NUC works perfectly attached to either monitor. Sounds to me like the driver needs to be looked at. Should I still contact support at this point?

Thanks!

0 Kudos
Highlighted
Novice
439 Views

Hey - here's a dumb question. Could I run down to Best Buy or equivalent and purchase a Thunderbolt cable (http://www.bestbuy.com/site/apple-1-6-thunderbolt-cable-white/7944078.p?id=1218862899283&skuId=79440... Apple 1.6' Thunderbolt Cable White MD862LL/A - Best Buy and connect my LG monitor to my NUC that way? Anybody try that yet? My monitor has Thunderbolt inputs and my NUC has a Thunderbolt port... My feeling is that the problems I've been describing above may be connected with how the driver/DP handles standby and monitor power-down...

0 Kudos
Highlighted
Novice
439 Views

Here's another data point: I could not figure out which TB3 cable to get, or if an Apple TB2 cable would be compatible, so I tried another path. I grabbed an old HDMI 1.4 cable that I had in my AV cabinet, connected it and gave it a try. Except for the 3440X1440 display only reaching 50 Hz max refresh rate (vs 59 or 60 with DP), the PROBLEM IS SOLVED!!! So, clearly it is a DP / graphics driver issue. I will keep this config until a graphics driver is released that deals with this problem, then test to see if it works.

0 Kudos
Highlighted
Beginner
439 Views

I have this same issue. I have the latest drivers and BIOS. I had this with both my old NUC (d54250wyk) and my new one (NUC6i5SYK). I am using a Dell 2713 via Display-port. I am super frustrated. This is absolutely an Intel drivers issue but I have no way to show that.

0 Kudos
Highlighted
Beginner
439 Views

I am having the same issue. Have NUC set to sleep monitor after 10mins. When that happens, monitor sleeps, and then speakers make the noise like a USB device is being connected and disconnected over and over. All windows move to top left. Happens using DP or HDMI. Monitor is a BenQGW2765(1440p60hz)

Windows 10 64

8GB

128GBx2 RAID install drive

All drivers/BIOS up to date.

0 Kudos