Intel® NUCs
Support for Intel® NUC products
Announcements
Do you have improvements you would like us to make on this community site? If so, we would love to hear your feedback! Click here for an 8 question survey. Thanks!

11283 Discussions

NUC7CJYH Not Booting from USB Stick

NathanB
Beginner
1,076 Views

I can't get the NUC to boot from a USB stick.

Bios updated to .JYGLXCPS.86A.0057.2020.1020.1637 (downloaded today)

VisualBIOS setup loads and displays that version.

Bios was updated using F7 and a USB stick (the same one in the same port), so the physical port works and the NUC can pull data from it.

The boot image I'm using is OpenBSD 6.8, https://cdn.openbsd.org/pub/OpenBSD/6.8/i386/install68.img

Attempting to boot to that image on a USB stick results in it telling me that it's looking for a bootable configuration and then "A bootable device has not been detected."

I've done this with two previous NUC's (earlier NUCs, earlier OpenBSD) as recently as about a year ago.  I burned the image to a USB stick using Rufus (1.3, downloaded today).

Extra note: No USB devices show up in the boot order list whatever options I try to select: it only shows UEFI: LAN: PXE IP4.... and the IP6... version.

What I've tried:

original, new, Sandisk Ultra Fit 16GB stick, 3.1, new.  Tried with an old generic 2.0 and 2GB stick.

All of the "Boot Configuration" combinations I could come up with, including the Windows and Linux selections as well as with booting USB devices first on/off and booting network devices last on and off, booting with USB boot devices turned on, Optical on and off, network boot to UEFI PXI & iSCSI, and disabled.

Secure Boot off (tried it on before I noticed the setting)

I'm familiar with this thread: https://community.intel.com/t5/Intel-NUCs/NUC5i3RYK-Can-t-boot-from-USB-thumbdrive-legacy-OR-UEFI/td...

Any thoughts?

Thanks

-Nathan

0 Kudos
5 Replies
NathanB
Beginner
1,064 Views

Update:

This may be related to not being able to disable UEFI boot.  

ref https://www.intel.com/content/www/us/en/support/articles/000032529/intel-nuc.html and https://community.intel.com/t5/Intel-NUCs/NUC10-can-t-enable-Legacy-Boot/td-p/602288

I did turn off "Native ACPI OS PCIe Support" under Secondary Power Settings, and then tried disabling "PCIe ASPM Support" for good measure after the first didn't work.  In either case the "UEFI Boot" checkbox is still greyed out and untoggleable (even after a reboot with the new settings).

So: if that would be the solution to my problem of the boot USB not being recognized, how can I turn off the UEFI boot?

LeonWaksman
Super User
1,055 Views

Hello Nathan,

Is your NUC booting from USB created with Microsoft Media Creation Tool? Please reset your BIOS to default settings (F9) and insert this USB in rear USB slot. When you see the Intel NUC logo during power ON, click on F10 to boot into Boot Menu. Then choose the UEFI line, click Enter and see if it is booting

 

Leon

 

NathanB
Beginner
1,039 Views

I've tried a few USB burning tools: Rufus, Win32DiskImager, and ISOtoUSB.

For ports, I tried them all, except for trying to connect something to the extra 2.0 headers inside the case, and I also tried:

1) one in front and another normal FAT32 stick in back and vice versa

2) plug in only the USB boot device, not the USB keyboard when trying to boot from it (if it had worked, I'd have connected the keyboard afterward)

3) download the disk image from different mirrors and the original site

Just now, I succeeded in installing the amd64 version which is 64 bit (the i386 I was trying to install for compiler testing is 32 bit).*

So at this point I'm pretty sure that it is a UEFI boot issue and that my .USB stick, burning procedure, etc. is fine.

I still cannot get what used to be called the legacy option going (turning off the UEFI checkbox) even though the BIOS does tell me the effects if I turn it off when I hover over that option and the support thread I mentioned gives some hints.  It also admonishes against wanting to enable legacy mode, but the security based reasoning is less compelling for my case: compiler testing, not a public server. 

-Nathan

*For anyone following that path, the initial OpenBSD 6.8 release has an unrelated bug which you'd notice on reboot after the install appears to succeed.  http://linux-unix-open-source.1053819.n5.nabble.com/OpenBSD-6-8-release-boot-stuck-on-Intel-NUC-NUC7...

Ronny_G_Intel
Moderator
1,009 Views

Hi NathanB,

 

I was able to replicate the same behavior that you described and I also tested the same USB Bootable image in 3 or more different systems. The OpenBSD 6.8 USB bootable image worked as expected only on systems in which "Legacy Boot" was enabled. Please be aware that we are slowly migrating our systems from supporting "Legacy Boot" to support "UEFI Boot only".

I wasn't able to turn "Legacy Boot" on but allow me a couple of days to run this issue by the Product Team to check what options we have available, there could be a way to do this and I am just not aware of it.

Here is a picture of a different system booting of the OpenBSD 6.8 USB bootable image:

OpenBSD6.8i386.jpg

 

Regards,

Ronny G

 

Ronny_G_Intel
Moderator
994 Views

Hi NathanB,

 

We were not able to boot the i386 image on NUC7CJYH but we also tested the 64bit version and it went through the boot-up process however it hangs when the bootloader hits the acpi0 line. Unfortunately we were not able to disable it and we got stuck at this point.

We used a USB drive with OpenBSD 6.8 (using Rufus 3.13) on a NUC7CJYSAL running BIOS version 0058 and we tested this image (here) 64 bit.

Here is a screenshot with our results:

4924120AMD64.jfif

The NUC7CJYSAL has not been validated with OpenBSD 6.8 therefore we don't offer support for this integration, with that in mind I can only recommend that you reach out to the Linux community for assistance. 

In addition, with the most recent BIOS, there's no way to get it into Legacy boot. The only recommendable BIOS setting is UEFI Boot OS Selection to Linux.

 

Regards,

Ronny G

Reply