Community
cancel
Showing results for 
Search instead for 
Did you mean: 
RSzel1
Beginner
275 Views

NUC7PJYH - No Signal

I have bought four NUCs (different models). All of then work without any issues except for NUC7PJYH. It has two HDMI ports and I have been unable to get an HDMI display working connected to either of them. When the NUC is off, the display shows "Check the cable". When the NUC is on, the display shows "No signal". When I enter the menu on the display, I see HDMI-NUC in the list of sources.

 

I have not been able to do absolutely anything about this problem. When I take out the RAM, upon turning on the power LED flashes to indicate there is no RAM installed, which means, that RAM is OK. The same for HDD - I have tried with and without HDD, and even with two different HDD. In the end I had the NUC replaced by the supplier, but the new NUC exhibits exactly the same behavior.

 

Is there anything else I could try? Otherwise I will have to return the product and get my money back.

0 Kudos
4 Replies
LeonWaksman
Super User
82 Views

  1. Yes, I would try to refresh the Bios using Bios Recovery with the Yellow Security Jumper removed method:
  2. Prepare USB stick fully formatted to FAT32 with Bios file JY0053.bio https://downloadcenter.intel.com/download/29120/BIOS-Update-JYGLKCPX-86A-?product=126137. Format your USB with Quick Format option unchecked. Do not format your USB in MAC (OS) or Linux machine. Use Windows.
  3. Disconnect the power adapter and remove the bottom panel from your NUC.
  4. Remove the Yellow Bios Security Jumper. (page 48 in Technical Product Specification https://www.intel.com/content/dam/support/us/en/documents/mini-pcs/nuc-kits/NUC7xJY_TechProdSpec.pdf)
  5. Insert the USB with the JY0053.bio file into USB slot.
  6. Reconnect the power adapter and power ON the NUC. Wait 30 sec - 2min. The Recovery process will start automatically and will end after 2 -5 minutes.
  7. When bios recovery is completed, press and hold the Power Button to switch the power OFF, remove the power adapter and replace the Security Jumper (pins 1-2) . Reinstall the bottom panel.
  8. Power your NUC ON.
  9. Enter Bios setting by pressing F2 during boot process.
  10. Press F9(followed by "Y"), to set Bios to default settings. Press F10 (followed by "Y"), to save the settings and exit to O.S. Let the NUC fully reboot.

 

Leon

 

 

n_scott_pearson
Super User Retired Employee
82 Views

Let me restate Step 2: On a Windows-based PC, reformat a USB 2.0 flash disk, using the FAT32 file system, with the Quick Format option disabled (unchecked). Place file JY0053.BIO in the root folder of this flash disk. Eject it properly.

 

Best if you don't use USB 3.0 flash disk. Do not use any other file system. If FAT32 is not offered, your flash drive is too big; get another. Disabling Quick Format is an absolute must. File JY0053.BIO should be the *only* .BIO file on this flash disk.

 

Let me explain why you are doing this: The BIOS Recovery engine does not have the same level of USB flash disk compatibility as the main BIOS. Secondly, it has a fairly strict implementation of support for the FAT32 file system and can have issues with vFAT, exFAT, etc. file systems. Most bulk formatters for USB flash disks are Linux-based and Linux cannot do a full and proper FAT32 formatting (this is a fact; I am not arguing it). There is also something strange about the physical formatting done my these machines. We have found that reformatting the flash disk exactly as we have defined it ensures that the flash disk is compatible with the BIOS Recovery engine. We have also seen, however, that compatibility with some USB 3.0 flash disks is not very good and this is why I recommend not using USB 3.0 flash disks. Sorry for how long USB 2.0 flash disks can take to reformat.

 

Hope this helps and explains what we are recommending,

...S

PeterNUC
New Contributor I
82 Views

What's your display/TV? Did you try to connect your NUC to a different model?

RSzel1
Beginner
82 Views

Thanks you guys for the answers and all your effort. After having posted my question I noticed another problem - the HDD LED was permanently on, which means, that the system did not get past certain point during the POST. I took the NUC to my local dealer (from whom I had bought other NUCs I have) to have a look. He said the the device was most probably faulty. I decided to return this specimen to the e-shop as well.

 

Updating the BIOS might have worked with the first bad NUC I returned last month. Unfortunately I cannot try it to find out any more.

Reply