Community
cancel
Showing results for 
Search instead for 
Did you mean: 
wcare
Beginner
1,553 Views

NUC7PJYH wont boot off usb

Brand new fresh out of the box. I have tried to create a bootable usb drive via rufus with windows7 and windows10. It comes up "a bootable device has not been detected"

I have tried multiple usb sticks

2 OSes

disable secure boot in the bios

low level format

No matter what i do it wont pick up the usb drive as a boot drive. It does seem to boot an old vmware 5.5 usb drive i have laying here.

Nothing shows in the legacy boot box in the bios. My understanding is that they dont support it anyway with this version of NUC.

How do i get this thing to read the usb drive so i can load my os? I have been at this for 2 days. I have had pcs i can get built and loading in 15 minutes including many raspberry pi devices. This thing is a real pain so far.

0 Kudos
4 Replies
LeonWaksman
Super User
185 Views

1. Prepare Windows 10 installation USB, using Microsoft Media Creation tool: https://www.microsoft.com/en-us/software-download/windows10 Download Windows 10 . If this USB is not booting in your NUC, try it in other PC.

2. If this USB is booting in other PC but is not booting in your NUC, update Bios in your NUC, using bios recovery from Power Boot Menu:

  • Prepare USB stick fully formatted to FAT32 (disable quick format option during format). Format your USB on Windows machine (rather than Linux or MAC). Save the Bios file JY0044.bio (https://downloadcenter.intel.com/download/28106/BIOS-Update-JYGLKCPX-86A-?product=126137 Download BIOS Update [JYGLKCPX.86A] ) on this stick and insert it into USB slot (NUC shall be OFF).
  • 2 Press Power Button for about 3 seconds. You should release the Power Button soon as the power led changes color from blue to amber. Alternately, the system will emit three short beeps from the PC speaker or headphones, if connected, then stop. If you see the LED color change or you hear the beeps, release the Power Button - NUC shall reboot into Power Button Menu.
  • Press F4 and the recovery shall start (it can take up to 30 seconds for messages to appear on the screen).
  • When the recovery finishes, pull out the power cord.
  • Replace the power cord and press Power Button to switch the computer to ON.
  • Enter Bios setting by pressing F2 during boot process.
  • Press F9(followed by "Y"), to set Bios to default settings. Press F10 (followed by "Y"), to save the settings and exit to O.S. Let the NUC fully reboot.
  • If before update, you have customized bios settings, you can enter again to Bios setting to change the necessary settings.

Note:

 

If for some reason you have difficulty to boot into Power Button Menu, you may recover your Bios using Security Jumper method https://www.intel.com/content/www/us/en/support/articles/000005532/mini-pcs.html https://www.intel.com/content/www/us/en/support/articles/000005532/mini-pcs.html

Leon

wcare
Beginner
185 Views

I think that helped. I upgraded the bios to 44 and it is booting win10 now.

Once this is done and working i really want to try and reload win7 on the device. I read somewhere that win7 does support UEFI boot but you have to do somthing to allow for it.

I did use the DISMGUI to bake in the current drivers for audio but nothing i did on that old firmware would allow it to boot.

Gonna give this new firmware a shot with win7 now to see if i can get things going. I really dont want to run win10.

rgord1
Novice
185 Views

I don't want to run Windows 10 either, believe me. Not only 'Feature Updates' but just regular monthly patch Tuesday updates have in recent times not only rendered WMC for Windows 10 practically unusable full screen, but also crippled remote control of media players like PotPlayer and MPC-BE.

I think you'll find it hard to get driver support for this NUC from Intel for anything other than Windows 10. I was able to install Windows 7 on a Kabylake NUC, but without graphics driver support it was unusable as an HTPC. I guess you could use it to run routine PC tasks, but that is not what I bought NUCs for. I also loaded Linux Mint on the Kabylake, but it was virtually impossible to get it to co-exist with Windows 10, and graphics driver support for Linux is notoriously inadequate.

I was impressed with the specs of this NUC and recommended it to relatives. Probably a big mistake, given the track record of Microsoft with Windows 10.

wcare
Beginner
185 Views

yeah...i am not impressed with this thing at all. I wish i could return it. All i have done is fight to get it to do the simplest of things. Seems like it has the potential to be a great HTPC. I am thinking of going linux on it but that is not what i wanted to do with it and could have gotten by using a pi for $40 if i wanted to do that.

Windows 10 is a toilet forced updates, changes and strangeness. ITs much better than 8. I will give it that.

Oh well....live and learn. In the end i am out $400 for the kit/build i ended up with.

Reply