Community
cancel
Showing results for 
Search instead for 
Did you mean: 
AEmil
Beginner
1,991 Views

NUC7PJYH2 displays show flickering green lines and go off

I am running Fedora 29 on a NUC7PJYH2 and encounter two different graphics/display issues which seem to be pretty much hardware (NUC) related and make me thinking about returning the NUC I got a few days ago. Both issues I encounter, "flickering lines" and complete "blackouts" of displays, seem to be pretty common issues related to NUCs, independent of the exact model or generation (as far as I could see by digging through the community forum).

My setup:

  • NUC: NUC7PJYH2
  • SSD: Samsung EVO 960 256 GB
  • RAM: F4-2400C16D-16GRS
  • BIOS: Version 0045
  • OS: Fedora 29 (Kernel 4.18)
  • Displays: 2x DELL U2312HM (connected to NUC's HDMI ports via HDMI-DVI-cables, single-link-cables)

The issues I have are:

  1. Green "lines" flickering on the monitors randomly. However, both displays are affected, the monitor connected to HDMI 1 is affected more often.
  2. Random "blackouts" of a single screen or both screens. Seems that the graphics signal is lost for some time. In some cases the signal is back after a few seconds, in other cases the affected monitor(s) even go to power save mode due to missing input signal.

What I have tried so far:

  1. Since I have two identical monitors with two identical cables connected to my NUC I swapped cables, monitors resp. HDMI ports and tried all of the possible combinations which did not make any difference. However, with respect to both issues HDMI port 1 seems to be more affected. Had screen blackouts yesterday (without any green flickering lines) and green flickering lines which descended in screen blackouts today.
  2. The issues arise more often with increasing operating time, so I thought they might be temperature-related. I rebooted my NUC and had a look at the temperatures in the BIOS. No temperature was above 37 °C.
  3. Since Fedora 29 is not officially supported those issues might be related to the graphics driver and in order to narrow the issue down with regard to the graphics driver by using an officially supported OS/distro I thought about installing Ubuntu's special NUC release of Ubuntu 16.04. However, when having a look at the temperatures in the BIOS (see above) I also had green flickering lines on my monitor. As far as I know, OS-based drivers are part of the kernel and not loaded in the BIOS. Having the same green lines in the BIOS should indicate that the issue is not OS-related (and using the NUC version of Ubuntu 16.04 might result in the same issues).
  4. Even monitors without input signal and being in power save mode are recognized by the hardware as they are listed in the available devices/monitors in Fedora. So the graphics unit of the NUC seems to detect both of the monitors but not send signals to them or at least to the one which is affected by the blackout.
  5. Rebooting (and unplugging) the system/setup does not solve the problem. After a monitor had a blackout when shutting down Fedora, unplugging and rebooting only the monitor which had an input signal at the time I shut down the system is detected and showing any screen output. The monitor does not even wake up from power save mode or show the NUC or Fedora logos which a normally shown on both monitors while booting. However, even at that point, both displays are shown in Fedora's display settings.

Conclusion:

As far as I understand the whole situation based on my findings and observations, I would say that the graphics issue is not related to faulty drivers or unsupported operating systems as they not only occur when running Fedora, but also in the BIOS and during startup where no OS components should be present. So instead of being software-related (with the exception of the BIOS) this seems to be more a hardware-related issue. One might think that the cables are use are not suitable for HDMI 2.0a. I had a look at the specifications, but for my understanding this should not be an issue since my monitors only support 1920x1080 and HDMI 2.0a itself is not defined for DVI-cables. Using dual-link-cables should not even make a difference, since single-link-cables are rated for 1080p which I do not exceed. So cables might be an issue, which until now I was not able to elaborate on further.

Does anyone have any further ideas or hints on those issues or have the same problems? I am getting out of ideas and would send the NUC back to the distributor if that issue cannot be solved or at least narrowed down in the next time...

Tags (1)
0 Kudos
6 Replies
idata
Community Manager
379 Views

Hello AlbertEmil,

 

Thank you for contacting our Intel ® communities, I understand that you are facing graphic issues with your system.

 

Based on the very detailed description of your issue, there are some things that we may need to consider.

 

As you mentioned even if the OS is not supported, it becomes irrelevant as the issue is also present in the BIOS.

 

The troubleshooting performed and the details that you have provided leads us to think that yes, you might be facing a hardware issue.

 

We recommend you to do the following:

 

Make sure your SSD's firmware is up to date. You can request help from https://www.samsung.com/semiconductor/minisite/ssd/support/cs/ Samsung* in order to test the unit with https://www.samsung.com/semiconductor/minisite/ssd/download/tools/ The Magician SSD management utility

 

Also please consider that Intel® NUC Kit NUC7PJYH only supports a Max Memory Size of 8GB as specified https://ark.intel.com/products/126137/Intel-NUC-Kit-NUC7PJYH here, using more than this can cause system instability.

 

Is there a chance to test a different memory?

 

You can check our list of http://compatibleproducts.intel.com/ProductDetails?EPMID=126137 compatible memories for your unit for further guidance.

 

I hope to hear from you soon.

 

Regards,

 

Diego S.

 

Intel (R) Customer Support Technician

 

Under Contract to Intel (R) Corporation

 

idata
Community Manager
379 Views

Hello AlbertEmil,

 

We just wanted to double check if you still need further assistance.

 

Please do not hesitate on contacting us back.

 

Regards,

 

Diego S.

 

Intel (R) Customer Support Technician

 

Under Contract to Intel (R) Corporation

 

AEmil
Beginner
379 Views

Sorry, for not responding that rather long time. I had to do some further investigations and "experiments".

In the meantime

I had a look at different threads here in the NUC community and in some Linux specific forums. Many people were describing similar problems to mine with various NUC models and different Linux versions. However, the least problems seem to occur when using Manjaro Linux in general (not sure why that may be the case, there might be less user using this distro and in turn less user which could report issues or there might be less issues at all). I found https://forum.manjaro.org/t/solved-graphical-problems-with-intel-nuc7pjyh/48703 a thread on the Manjaro Forum which very similar problems to the ones I had and decided to give Manjaro a try.

After installing Manjaro I had significantly less display issues. In contrast to Fedora 29, Manjaro uses Kernel 4.19, whereas Fedora 29 (at the time I opened this thread) uses 4.18. So there might be some better/adopted drivers in the kernel supporting the integrated graphics. Just to make sure that the remaining issues (monitors switching off and going into energy save mode) are not part of any faulty hardware on my side, I decided to change the HDMI-DVI-cables from single-link- to brand-new dual-link cables. With the new cables the monitors are working as expected. I still got some glitches at the top of the monitor which is very similar to the ones https://forum.manjaro.org/t/solved-graphical-problems-with-intel-nuc7pjyh/48703 described here:

weird graphical issues in my deskbar (which I have in the top of my screen). The problem only remains there and it simply shows flickering lines of red and green

By changing the background image I was able to find out that these flickering lines or glitches are just the inverted color of Manjaro's default background image and "replace" the original color at the exact same position when they occur. Since those glitches occur when hovering over icons in the dock or panel, I assume that this is not hardware, but driver or OS related. I have chosen a rather dark, uni-colored background image without any color gradients at the very top. The mentioned glitches still occur, but they are not that visible due to the dark image. That definitely is not perfect, but makes me able to work with the NUC in an rather production-like environment.

So all my issues might have been a result of faulty cables and bad driver/OS support. As far as I can tell (did not try Windows with full driver support to be totally sure), the NUC itself does not seem to be faulty (with regards to the display issues, I have some MCE after upgrading to BIOS 0045 and the LED ring does not work). I am planning to give Fedora 29 another chance in the future, but Manjaro is fine for me at this time.

No further assistance needed - can be marked as solved.

darkf3d3
Novice
379 Views

LeonWaksman
Super User
379 Views

Hi @darkf3d3​ ,

  1. There is no need to hijack this thread. You should open one yours.
  2. What I can see that you are on bios version 0045 while the last version is version 0066. https://downloadcenter.intel.com/download/28638/BIOS-Update-BECFL357-86A-?product=126147 BTW in the bios release notes there is no version 0045. You should update your bios, using bios recovery method with the Security Jumper removed. If you know how to do this that's O.K. Here are Intel instructions https://www.intel.com/content/www/us/en/support/articles/000005532/mini-pcs.html . If you wan't more help, please open separate thread.
  3. Could be that your drivers are not updated also. All drivers you may download here https://downloadcenter.intel.com/product/126147/Intel-NUC-Kit-NUC8i5BEK
  4. I would start from reset your bios to default settings.

 

Leon

 

darkf3d3
Novice
379 Views

Reply