Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
2,463 Views

NUC7i3BN HDMI-CEC activates wrong input

Jump to solution

Since my TV has its ARC at HDMI-2, I am struggling with the problem that CEC does ALWAYS switch the TV to HDMI-1 (where nothing is connected). Can someone tell me what goes wrong? Using a DVD-Player at the same port it works! Is there some config? Or alternativly a way to disable that feature?

0 Kudos

Accepted Solutions
Highlighted
New Contributor I
18 Views

My apologies if this is a silly question, but have you tried to set the input selector in the BIOS of the NUC to HDMI-2? The setting is called "TV HDMI Port" and it's found under Devices -> Onboard devices. The default value is HDMI-1-

View solution in original post

6 Replies
Highlighted
Community Manager
18 Views

Hi, Möhre, Thank you very much for joining the Intel® NUC communities.

 

 

In order to gather further details about the HDMI-CEC feature, please verify the link below:

 

http://www.intel.com/content/www/us/en/support/boards-and-kits/intel-nuc-kits/000023500.html http://www.intel.com/content/www/us/en/support/boards-and-kits/intel-nuc-kits/000023500.html

 

 

Additionally, the issue could be related to a compatibility problem between the NUC, ARC and the TV, based on the fact that the DVD-player works fine. The option to disable the CEC feature is normally located on the TV, so the best thing to do if you cannot find it, will be to get in contact with the manufacturer of it to gather more details.

 

 

Just in case on the following link you will find the list of tested peripherals for the NUC, where you can see some monitors and TVs listed:

 

http://www.intel.com/content/www/us/en/support/boards-and-kits/intel-nuc-kits/000023164.html http://www.intel.com/content/www/us/en/support/boards-and-kits/intel-nuc-kits/000023164.html

 

 

I encourage all the peers viewing this forum, that if they have more information about this matter to post all the comments and suggestions on this thread.

 

 

Any further questions, please let me know.

 

 

Regards,

 

Alberto R

 

Highlighted
New Contributor I
19 Views

My apologies if this is a silly question, but have you tried to set the input selector in the BIOS of the NUC to HDMI-2? The setting is called "TV HDMI Port" and it's found under Devices -> Onboard devices. The default value is HDMI-1-

View solution in original post

Highlighted
Community Manager
18 Views

Thank you to nucblog.net for the suggestion provided above.

 

 

Möhre: I hope the information posted previously was useful for you.

 

 

Any questions, please let me know.

 

 

Regards,

 

Alberto R

 

0 Kudos
Highlighted
Novice
18 Views

Interesting... I didn't know I have to choose the port number manually (since the DVD-player does not even provide such an option). But thanks a lot nucblog.net & intel_corp, setting it to HDMI-2 solved the problem.

Additionally I would like to ask, if there is some option to tell also the AVR to listen to the correct input. At the moment it works randomly and the AVR sometimes switches to the TV instead of the NUC.

0 Kudos
Highlighted
Community Manager
18 Views

Möhre: You are very welcome. Excellent, it is great to hear that setting it to HDMI-2 solved the problem. Thank you once again to nucblog.net for that suggestion.

 

 

In regard to your question, I will do further research on this matter in order to try to confirm if there is a setting in the BIOS to stop the AVR from switching randomly to the TV, instead of the NUC. As soon as I get any updates, I will post all the details on this thread.

 

 

Any questions, please let me know.

 

 

Regards,

 

Alberto R
0 Kudos
Highlighted
Moderator
18 Views

Hi Möhre:

I have been doing some research and playing with different settings but honestly I wasn't able to find any setting to tell the AVR to listen to the correct input.

 

I would recommend that you check with the manufacturer of the AVR and I would encourage anyone else to share any recommendation.

Regards,

Ronny G

0 Kudos