Community
cancel
Showing results for 
Search instead for 
Did you mean: 
sesmith
Novice
181 Views

NUC7i3DNH1E Extended Display Not Working

Jump to solution

I have a NUC7i3DNH1E running Ubuntu 20.04.2 LTS.  I am trying to display dual monitors with extended display.  The monitors automatically duplicate but the system only shows one monitor in the "Settings" screen so there is no option to extend displays. 

Both monitors are HP LA2405x.  They are connected to the NUC by HDMI/DVI cables.  Attached are screen shots of the system details and setting tab showing only one display.

When I do a xrandr, I get the following:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1920 x 1200, current 1920 x 1200, maximum 1920 x 1200
default connected primary 1920x1200+0+0 0mm x 0mm
1920x1200 77.00*

Does anyone have an idea on what I need to do to make it pick up both monitors so that I can select extended display?  Let me know what else you would need to assist.  Thanks in advance.

Labels (1)
0 Kudos

Accepted Solutions
sesmith
Novice
107 Views

The issue has been resolved.  The system was running an older kernel that didn't provide the correct driver support.  Upgrading the kernel from 5.0.0.37 to 5.8.0.43 fixed the issue.  I do not know why but the "GRUB_DEFAULT" parameter was set to the 5.0.0.37 kernel not the typical default of 0.  I updated the grub file located at /etc/default/, ran update-grub, and then rebooted the system.  The system rebooted with 5.8.0.43.  

View solution in original post

8 Replies
sesmith
Novice
177 Views

I also checked Multiple Display Configuration Options for Intel® NUC Kits NUC7i7DN, NUC7i5DN, and NUC7i3DN with no luck.  The HDMI firmware link is broken and the BIOS/Graphics Driver link is for Windows only.

Maria_R_Intel
Moderator
160 Views

Hello sesmith,


Thank you for posting on the Intel* Community.


We would like to ask you for a report that may contain sensitive information, I will use the email address associated with your community profile, please respond via email.


Best regards,

Maria R.

Intel Customer Support Technician


Maria_R_Intel
Moderator
142 Views

Hello sesmith,


Thank you for the information, we received the email.


To better assist you, please complete the BIOS update process.


 

-BIOS:

 

According to the report you are using the BIOS version 0064, the latest version available on our website is the 0071. You can install this in your system even if you are using Ubuntu*


  1. Go to the following link to find version 0071 https://downloadcenter.intel.com/download/30091/BIOS-Update-DNKBLi30-.
  2. We recommend downloading the .bio version.
  3. You can find all the steps to follow on the Release Notes, in the document "read me" https://downloadmirror.intel.com/30091/eng/NUC-BIOS-Update-Readme.pdf
  4. Follow the instructions of the method "F7"


When completing this, please send us by email, a new SSU report so we will be able to proceed to check this internally.


Best regards,

Maria R.

Intel Customer Support Technician


sesmith
Novice
139 Views

Update info sent.  I look forward to your reply.

Maria_R_Intel
Moderator
132 Views

Hello sesmith,


We received the information and we are currently checking your case internally to provide you with the best assistance. Please expect an update on this thread soon.


Best regards,

Maria R.

Intel Customer Support Technician


sesmith
Novice
120 Views

It's been five days since the last update.  I am following up to see if there has been progress on the issue. 

Thanks

Steve

Ronny_G_Intel
Moderator
113 Views

Hi sesmith,

 

My apologies for the delay in getting back to you.

Let me try to replicate this issue and I will get back to you but please keep in mind that we dont provide Graphic Drivers for Linux*, the drivers are provided by the manufacturer so if this is a driver related issue I would recommend that you reach out to the Linux community.

 

Regards,

Ronny G

sesmith
Novice
108 Views

The issue has been resolved.  The system was running an older kernel that didn't provide the correct driver support.  Upgrading the kernel from 5.0.0.37 to 5.8.0.43 fixed the issue.  I do not know why but the "GRUB_DEFAULT" parameter was set to the 5.0.0.37 kernel not the typical default of 0.  I updated the grub file located at /etc/default/, ran update-grub, and then rebooted the system.  The system rebooted with 5.8.0.43.  

View solution in original post