Showing results for 
Search instead for 
Did you mean: 
New Contributor I

NUC7i5BNH 32GB memory, very slow cold boot and post error after 57 bios update


We are experiencing a problem with NUC7i5BNH running with two 16GB SO-DIMMs. After updating the bios from the original 42 to 57 the unit powers up really slow from cold state. It takes about 45s-1min to reach the Intel NUC logo page and it takes several seconds until the "F2/F7/F10" texts appear. Normally all this happens in <10 seconds pressing the power button.

A post error message "(a7) me fw downgrade request mespilock failed" is briefly displayed before the boot process is started. Warm restarts seem normal (=fast) and the memories pass Memtest normally. The unit seems to operating normally besides the very slow cold boot and the post error message. We definitely cannot deliver the unit to a customer in this condition.

We have reproduced the problem with two NUC7i5BNH units. On the second unit we did everything in a very controlled manner. The unit worked perfectly with the 42 version; all problems appeared after the update to 57. I do realise that the problem might be some incompatibility with the Corsair memories but they work individually and also pass memtest together after the slow cold boot has finished. I really hesitate to spend ~400eur just try out a second set of memories.

Things done/tried:

  • BIOS update with proper "Reset bios settings to defaults" after the update
  • Tried bios recovery with jumper and power menu methods -> no effect
  • Tried with memories individually in either slots -> worked fine without problems (fast, no post error)
  • Tried different (Kingston, Adata) smaller memories individually in the unit -> worked fine without problems (fast, no post error)

Things not tried:

  • Different 2 x 16GB modules. Unfortunately we do not have Kingston/AData 2133MHz 16GB modules available. We could get our hands on 2 x 16GB 2400MHz Adata. However the memories are really expensive to just try out. The Corsair modules themselves pass memtest and work individually in the same units. Also their specifications meet the requirements stated in the Technical Product Specification.
  • Any smaller memories in dual channel configuration. We have a chance for this on Monday. However it does not really help us to find out that 2x4 or 2x8 works.
  • Downgrading BIOS to anything earlier to 57 (see BIOS downgrade question below)


Intel NUC7i5BNH original BIOS 42 updated to 57 2 x Corsair CMSO16GX4M1A2133C15 (16GB, 2133MHz, 15-15-15-36)

No SSD installed at the moment (AData SX8000 will be installed once the memory problem is solved) BIOS release notes state that you could downgrade from 57 -> 54: "Due to a security enhancement, it will not be possible to go to any BIOS earlier than BIOS 0054."

However the BIOS update readme states the following: "If you are trying to downgrade to a previous BIOS version and its Intel® ME Firmware version is older than that currently on the motherboard, then the downgrade is NOT supported."

The ME FW in 57 is newer than in 54 ( vs Is the downgrade to 54 allowed/supported or not?


  1. What is this post error message "(a7) me fw downgrade request mespilock failed"? We have definitely not downgraded anything. Is the unit internally trying to perform some kind of revert to previous bios when the post is taking too long? Could not find any google hits on NUC with this error.
  2. Is the BIOS downgrade from 57 to any previous version allowed/supported? Since the documentation would indicate that we cannot downgrade (see above), we seem stuck with 57.
  3. Has any of the relevant BIOS settings changed between 42 to 57? These do not seem to be listed in the release notes.
  4. Are there any BIOS settings we could try to change? Eg. memory timings or the /thread/100093 "Round trip latency optimisation".
  5. Anything else we could try?

We provide Intel NUC solutions as a business and have installed several hundred units since 2013. This is the first time we experience this kind of problem. We have also provided NUC6 and NUC7 units with 32GB memory without problems but the NUC7i5BNH+Corsair 2x16GB combo is our first.

Any help is well appreciated!

Best Regards,

Henri / TeraStore

0 Kudos
8 Replies
Community Manager

Hi Marjo Suuronen,



Thank you for bringing this to my attention, let me help you on this matter.


I understand you are installing new Intel® NUC NUC7i5BNH with Corsair* 2133Mhz RAM.


To answer your questions:


1. A7 or 7A BIOS post code information is available at this link


2. The BIOS documentation indeed tell you that you cannot downgrade if you already updated to version 0057. I just tried and it does not let to do a downgrade.


2.1. I tested the recovery file 0054 without BIOS security jumper and hit F4. This time will bypass any limitation. Successfully downgraded to 0054.


3. At Intel, the only way to tell if there has been a change through BIOS versions would be with the BIOS release notes


4. Please try downgrading BIOS


5. If this still fails, please contact Intel customer support for warranty options.





Allan J.


New Contributor I

Hi Allan!

Thank you for your response.

Regarding your answers:

1. I could not find anything in the Post code tables related to the Post error message "(a7) me fw downgrade request mespilock failed" which is displayed when 2x16 Corsair memories are installed and the slow cold boot happens. There are generic google hits on this one but I could not make sense on any of the proposed reasons/fixes presented. The message seems very odd, like the Management Firmware would like to autodowngrade to previous version but is not allowed since it is older (same reason that 57 cannot be downgraded to 54?).

2-4. I successfully downgraded the BIOS from 57 -> 54 but this did not change anything. Works with single ram but slow cold boot with "(a7) me fw..." message with two.

5. I don't think warranty replacement would help since we have two units with identical behavior. I would expect this to reproduce on any unit. I would like to remind that the problem appeared after upgrading the factory installed BIOS from 42 -> 57. With 42 the unit worked without problems.

However we have good news. We received yesterday two Kingston KVR21S15D8/16 16GB rams and they worked straight away. The customer received a fully working unit just before Christmas so a happy end there

There is some very mysterious incompatibility problem with NUC7i5BNH and Corsair 16GB DDR4 SO-DIMMs when using BIOS 42+ (atleast 54 and newer). Originally we added Corsair memories in our inventory due to short supply of Kingston and AData 16GB modules. The short supply is still somewhat going on so it would be great to have the Corsair memories working 100% with NUC. They do at least seem to meet all the requirements and they used to work.

Best Regards,

Henri / TeraStore

Super User

Hi Henri,

I'm glad that you have solved this problem, however I would like to bring to your attention the following facts:

1. I didn't see the Corsair SODIMM you have purchased, however looking on this product data sheet I can read that this product has density of 16GB (i.e. it is build from one chip?). If my assumtion is correct, the following paragraphs are applicable.

2. The NUC7i5BNH Product Technical Specification. para. 1.4 defines that this computer Supports 4 Gb and 8Gb memory technology (SDRAM Density). That means that 16 GB module shall be build from 16x1024MB modules (1024MBx8=8192bit or 8Mb).

3. My advice is that next time when you order memory modules that are not listed on product compatibility list… you shall follow the specification requirements including module density.



Super User Retired Employee

Good catch Leon!

More and more 16Gb density ICs are going to be appearing. I sure hope Intel is getting support for these ICs added to the Memory Reference Code. I would also like to understand why the MRC worked in those previous BIOS releases; if there wasn't support for 16Gb density ICs, how did it ever work? Luck?


New Contributor I

Almost clicked the "Right answer" button since the ram sticks did seem indeed 16Gb density with 4 chips per side (16Gb/2GB x 8 = 16GB). But then decided to take a second closer look. As you can see from the photo below the sticker covers the chips and there seems to be 4 on each side but when looking from the end you can see a gap in center. So there are 8 chips on each side which means that they must be 8Gb density. I remember looking at the Corsair spec sheet and the NUC7i5 Product Tech Spec for SDRAM density before purchasing. I then concluded that the info, Density = 16GB (1 x 16GB), on Corsair web site must be wrong and took my chances that it must be 8Gb. It seems that the info is indeed wrong and I think the person writing did not know anything about SDRAM density but instead wrote the capacity of the memory there, 1 x 16GB. Looking at Corsair's 2 x 16GB Kit of the same memory: Corsair Memory 32GB (2x16GB) DDR4 SODIMM 2133MHz C15 Memory Kit (CMSO32GX4M2A2133C15) confirms this, it's stating "Density: 32GB (2x16GB)".

So back to square one for why this memory does not work anymore on NUC7i5BNH when used in dual channel mode. I find it really unsettling for having this kind of incompatibility issues emerging with bios upgrades. The only 16GB memory listed in the product compatibility list and available here (with two main European distributors) is the AData AD4S2400316G17. This is a 2400MHz memory and according to product tech spec not supported ("DDR4 1866/2133 MHz SDRAM SO-DIMMs"). Yeah, I know the Tech spec should perhaps just be updated but I would like to be sure that it is truly the case.

What 16GB memory can safely be used on NUC7? Safely meaning that compatibility is guaranteed to continue during NUC7 product lifetime. A single broadly available SKU would do for me.

Best regards,

Henri / TeraStore

Super User

Looking on the attached images I will say that your are right. Still it is worthy to send a question to the vendor - what is the chip density? And if there is an error in the Data Sheet?



Super User

Hello Henri,


Are you familiar with the Intel approved memory from the cmtlabs: CMTL > Search > Tested Motherboard > Results

In this list you will find few more vendors with approved 16GB memory modules. You have the following vendors: Apacier, Crucial, G.SKILL, Kingston and Micron.

Hope this helps



If the above link is blocked, copy the following link and use it without quotes: ""


Mate just letting you know I just had a VERY SIMILAR issue with the new BIOS 63. The system shipped with 61 and we always upgrade to latest before shipping. BUT.

The system was working perfectly. Immediately after upgrading to 63, the system would take up to 30 seconds to start booting. This is, as you said, unacceptable to ship to customer. I also saw that weird FV Downgrade message and something failed a few times (could not read it quick enough).

This unit has a single Team Elite 8Gb SoDIMM (DDR4 2133 code TED48G2133C15-S01). I've also tried moving it from the bottom slot to the top.

We normally always use Kingston ValueRAM which never provides an issue but for the last few builds we've used this RAM as it came as a PROMOTION from the Australian Distributor Synnex with the NUC.

This has not provided any issues in the last few builds but obviously the BIOS version of those were pre-63.

This is the first with 63 and the problem has arisen.

Now, I ran a downgrade to 62 and immediately the problem was solved. The NUC starts booting (with Intel logo) within seconds again.

Something in 63 obviously broke compatibility withe the memory (as again, was shipped with the NUC as promotion).

I suggest NOT upgrading to 63 until Intel provide a BIOS without this problem, if you use this memory.

INTEL: Please take note of this. There's an issue with 63 and the RAM provided as a promotion through your distributor. Not good enough.