Showing results for 
Search instead for 
Did you mean: 

NUC7i5BNH Windows 10 Pro install needs updating

I just bought a NUC7i5BNH and installed 16 GB RAM in it and a 1 TB 2.5" SSD. I boot off a DVD with Windows 10 Pro.

The system seems to go through the Windows 10 Pro install more or less. It copies the files to the disk (I think) since this takes about 20 minutes,

then it checks off Installing Features and checks off Installing Updates, then Finishing Up. Then the system reboots and as it boots it stops

at a light blue screen that says that it needs to get some updates to get Windows working. And then prompts me to use WIFI or network cable to get these updates.

But at this point, the wifi and ethernet Intel drivers are not installed so it cannot get any updates over the network. If I try it tries but cannot get anywhere.

If I reboot it, it keeps stopping at this screen.

Has anyone seen this before and have a way to deal with this?

I assume I cannot install the Intel drivers for the NUC until I have Windows 10 up and running fully.

I have a copy of them all but have not attempted to install them since Windows is not quite up.


0 Kudos
4 Replies
Super User Retired Employee

You want to tell it to not attempt to install updates. This can be done later -- after you install all of the driver packages included in the available Driver Bundle (this page: Downloads for Intel® NUC Kit NUC7i5BNH and then use Download Bundle button).



This wasn't really possible. The system was stopping at a screen that said "why did my PC restart?" and then it said "There's a problem that keeps us from getting your PC ready to use, but we think an update will help to get things working again". If you tried to skip attempting to get an update the system simply rebooted and stopped at the same screen.

The good news is I figured out what my problem was and this might be helpful for others. A tip off to what was wrong showed in the BIOS under the UEFI boot section. Curiously, it said there was no boot drive. The Legacy boot section said there was a boot drive on my SSD, a boot drive on the DVD disk drive the Windows 10 install disk was in, and I think a network boot choice.

Anyway, when I booted Windows 10 from the DVD drive, I remember selecting the DVD drive from which to boot but I remember not selecting the entry for the DVD drive that started with UEFI. There was a choice for the DVD drive with and without UEFI as a prefix. I think what had happened was I had selected a Legacy boot off the DVD drive which meant that the Windows 10 install set up an MBR partition table instead of a GPT partition table and so Windows 10 was not booting to completion because it wants a GPT partition table. I had tried booting from the UEFI selection in the BIOS but it seemed to simply come back to the same BIOS screen. What I needed to do was boot using the UEFI selection in the BIOS and then immediately after when the screen message "Press any key to boot from CD/DVD" appeared, press any key, before it cycled back to the BIOS screen. This led to a UEFI boot and because I'd already created 2 partitions from the previous (incorrect) Windows install, I deleted them both and then let the install occur again. This time it went to completion and all was well.

So it appears one MUST select a UEFI boot for a Windows 10 install. Windows 10 will not complete the boot after the install if a Legacy boot is used. This must mean Windows 10 needs to use a GPT partition table not an MBR partition table.

And when you select to boot from UEFI boot selection in the BIOS, make sure you also press a key on the keyboard right after this so a boot will actually start. :-)

Part of the reason it took a bit of time for me to figure this out was that my DVD drive is about 14 years old and I thought I might be dealing with a hardware incompatibility. I'd also put a 1 TB Micron/Crucial MX500 2.5 inch SSD in the NUC7i5BNH and thought I might be having a hardware compatibility with it since it is not on the list of Intel certified SSDs for this model and is quite new.

But I have the NUC7i5BNH up and running with Windows 10 fine now. Now I just have to remove all that irritating screen clutter that Microsoft felt it necessary to put into Windows 10.

What I have found interesting is that, as far as I can tell all the hardware works on this NUC using just the drivers that come with Windows 10. I downloaded the bundle with all the Intel software for this NUC from Intel but I have yet to install it. Perhaps this is because I have a copy of Windows version 1709 which was released in Oct 2017 (mine has a build date in Sep 2017) so it probably has a lot of recent Intel driver software.

Thanks for your response. Communities like this are very helpful when journeying into terra incognita. :-) I've been a bit verbose here but hopefully it might help others who encounter the same or similar issue.


Super User

Hello Keith,

It was interesting to read your post. And yes, the Windows 10 should be installed from UEFI boot.

I would like to add some comment to your post - next time when you need to install Windows 10 on NUC, much easier is to use USB media which can be prepared with Microsoft Media Creation Tool: Download Windows 10 .

The all process of installation is very clear described in the following tutorial: Windows 10 Forums . Preparing the installation media takes less that one hour (depending on your internet speed) and then the installation process about 15 minutes.



Yes, I actually considered that but because I had the Windows 10 DVD and a DVD drive handy, I went with that.

I didn't have an available clean USB flash drive to use as the boot device and was not familiar with the process

so opted to do the traditional thing. :-) I have upgraded my Mac systems using a bootable USB drive so I know

this can be done. For Windows, maybe next time. :-)