Intel® NUCs
Support for Intel® NUC products
12298 Discussions

NUC7i5BNH bios screen: no F2/Setup screen


Just upgraded from BN0081 to BN0083.

I've always had a problem getting either F2 or F10 to take.  Historically, getting into F2 has been difficult.

I can use the 3-sec power button to display the selections.  F10 displays.  F2, the screen goes blank.

I have a 1080i monitor.  I saw somewhere you need 1024x768.  I assume that is a minimum.

I can't remember if I ever got into F2/Setup after applying BN0081.  Since BN0083, I definitely fail 100% of the time to get into setup.


I have a new NUC10i5. Different physical screen, but I also have problems getting into the boot screen or the setup screen by hitting the key repeatedly during the boot process.

  On the NUC10, I did set the BIOS to always pop me into "ESC to boot / F2 to setup", but that is just while I install the OS.


Is this a general problem with these devices?

0 Kudos
5 Replies
Super User
  1. When you see the Intel NUC logo, there should be no problem to enter BIOS after hitting the F2 repeatedly (this is trough for NUC BE and NUC FN). Hitting on F10, should bring you the Boot Menu. You should use USB keyboard (either wired or wireless with USB receiver). BT keyboard is not active during boot process. The monitor used can be 1080i, but should be capable to display 1024x768.
  2. If the Secure Boot is enabled, the F2, F7, F10 menu is hidden (even if it is enabled in BIOS settings)



Super User Retired Employee

Even simpler, power off and then back on. Immediately (i.e. do not wait for the splash screen to be displayed) start pressing the F2 (or F7 or F10) key, once per second,  over and over and over, until the Visual BIOS (or BIOS Update or Boot Device Selection, respectively) screen appears.



That is pretty much what I have always tried.  Prior to a recent BIOS upgrade, I had about a 5% success rate.  Subsequent to BIOS update, 0%.  As discussed above, using a non-HDMI monitor with an HDMI to "digital" converter, in my current sample size of 1: 100%.  Infinitely better.



Just tried it again, this time with an ancient Dell monitor using a HDMI to "digital" input converter.  Good thing I have not thrown it away yet.

Immediately came up with the splash screen.  Was able to get into setup immediately.  Funny, I do not recognise the setup screen at all, but I know I did manage to update the BIOS recently.

The problem with the other monitor (ancient BenQ) seems to be that with HDMI, the NUC is always dorking around trying to wake up the TV or something.  It is not a TV, and does not take kindly to being dorked with.  Normally I just get indications on the screen that something connected then disconnected then connected , ... and totally miss the splash screen.  With the lastest BIOS I have on it, 0083.2020.0714, I have never been able to get into setup, or I would have some vestigeal memory of having seen it before. Well, actually, I can't be certain.  My memory has been bad for as long as I can remember.  It definitely looks completely foreign to me, and I have spent lots of time in BIOS setup screens over the aeons.

Interacting with it for a moment: definitely never seen this BIOS setup before.  Weird pulsating orange rectangles when you TAB between fields and a search bar.  Would have remembered that.  Anyway, the only reason I wanted to get into setup was to check on some settings while i was wrestling with the NUC10i5 I just bought.  The NUC10 also has the tendency to miss the splash screen and rarely get into setup or boot screen.  The NUC10's monitor (another DELL, UP2414Qt, an early 4K display with some quirky issues) has a display port input as well as the HDMI.  I'll try to find a suitable cable and see if it works better when connected with display port (where most of the quirks are, though).  On the NUC10 I did find some HDMI "its a TV" settings and turned them off at one point, but I suspect I may have reloaded defaults since then.

Super User Retired Employee

Don't get used to the BN NUC's Visual BIOS Setup program. If you haven't seen it yet, the implementation is radically different visually (gee, almost a pun) when you get to many of the newer NUC models (the 8th gen CB, CH, IN and PN models, the 9th gen QN and QX models and the 10th gen FC models).