Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
135 Views

NUC7i5BNH can't detect my evo 970 attached to m.2 slot

my bios settings

 

version- BNKBL357.86A.0081.20202.0114.1542 (latest version)

PCI m.2 slot is active

M.2 slot shows - Not Populated (although evo 970 is attached)

M.2 slot Vendor ID: Device_ID shows <FFFF.FFFF>

 

troubleshoot step done myself are-

I have tried booting from UEFI mode and Legacy mode but in both Windows installation can't go further pass selecting disk because m.2 is all I have installed.

I tried attached 2.5 SSD drive and it detects but that is not mine and borrowed just to test 2.5 SSD connection works.

 

 

I see that Samsung have its firmware to install but it support on linux OS so even after creating bootable drive it does not work trying to load that from BIOS.

 

any other steps I can take?

 

0 Kudos
3 Replies
Highlighted
Super User
54 Views

Download, run, and ATTACH (using the paperclip under the toolbar) the results of this utility:

https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility

 

Doc

0 Kudos
Highlighted
Beginner
54 Views

thanks for quick response.

 

looks like this is system diagnostic exe. How do I run this from BIOS?

 

0 Kudos
Highlighted
Beginner
54 Views

Here is the result. (I dont know how to run from BIOS to i put that borrowed 2.5 SSD with preinstalled Windows 10 and run this utility..- She has this from China so some words are in Chineese language but has nothing to do with my system.)

 

 

0 Kudos