Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MTont
Beginner
1,702 Views

NUC7i5BNH clone booting problem

Hi all!

I had 2 nuc (NUC7i5BNH). I installed Xubuntu 16.04 in one of them and cloned the hd into the other nuc. Everything worked well. I did the cloning thing a lot of times.

Now I bought other NUCs (NUC7i5BNH) with the same BIOS version (BNKBL537.86A.0045.2017.0417.1728).

If I put an SSD with Xubuntu from my 2 old nucs in those new NUC it doesn't boot. It says: "A bootable device has not been detected".

I tried to install ubuntu 18.04 in the new one and cloned it, but the new installation doesn't work on others NUC but the one where I installed the OS and the old 2.

Is there some kind of option in the bios that prevent from boot an SSD installed from another pc?

Help me please. I can't install ubuntu and a lot of stuff in 20+ NUC. I need to clone it...

0 Kudos
3 Replies
idata
Community Manager
89 Views

Hello Lab

 

I understand that you have issues with your Kit Intel® NUC NUC7i5BNH after cloning your hard drives

 

In this case our unit does not have any sort of hardware encryption, so we are really interested on checking what's really happening with that hard drive.

 

Our best recommendation at this moment is basically to take both NUC's with you (the one recognizing the Hard drive and the one that does not) and access the BIOS in both machines. Please make sure that all the settings are the same under the SATA device section.

 

Essentially, if both units are working under the same BIOS settings the unit must show up and boot.

 

As well, is there any chance that you can get a fresh clean installation of Xubuntu into a separate hard drive and then test it over into the non working unit just for troubleshooting purposes?

 

 

I hope to hear from you soon.

 

Best Regards,

 

Diego S.

 

MTont
Beginner
89 Views

Hello Diego,

thank you for your answer!

I tried a lot of fresh installations (ubuntu 16.04,18.04, xubuntu 16.04,18.04) everytime the same problem. I tried Windows too and it worked.

Yesterday I tried to follow this post: https://communities.intel.com/thread/112404 https://communities.intel.com/thread/112404

I tried to run boot-repair-disk (boot-repair-disk / Home / Home ) and now seems to work. I need more time but I think the problem is solved.

About the bios setup, the only things that are different are:

SECURE BOOT:

- Key Exchange Key (KEK)

- Signature Database (db)

- Blacklisted Signature Database (dbx)

In the oldest NUCs these one are not installed, in the others are installed.

Thank you! I'll let you know...

MTont
Beginner
89 Views

Yes! I can confirm that it is working.

I think the problem is in this file: boot/efi/EFI/BOOT/grubx64.efi. The boot-repair-disk regenerate this file and the NUC boot without problem but I need to do that everytime I move the SSD from a NUC to another

Reply