Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ssrfr
Novice
576 Views

NUC7i5BNK BIOS0076 upgrade breaks thunderport

Similar to this post, just upgraded NUC7i5BNK to 0076 bios and it broke the thunderport on the device. No longer is there a thunderport recognized. Previously (12+ months) have been using the usb-c/thunderport to drive my 4k monitor (via a usb-c to DVI cablematters cable). This setup has worked fine all along and thru several bios upgrades except 0076.

 

I had to revert to an HDMI connection on the back of the NUC to my dell monitors hdmi to even get a signal and start up computer. HDMI seems to be working fine.

 

I have tried to recover/restore 0072 (previous bios I was on that worked fine) but that restoration does not work: https://www.intel.com/content/dam/support/us/en/documents/mini-pcs/BIOS-Recovery-NUC.pdf

 

I have tried to 'upgrade' the thunderbolt firmware as referenced at the end of the other post by the intel rep, but that returns 'Thunderbotl service does not exist'.

 

I am at a loss, and this update as hindered the computer as HDMI output is not sufficient for colorspace/resolution/HDR.

 

Can we get a resolution or accurate way on how to downgrade the bios as none of the solution work (Intel tech's need to try and to see they DO NOT work).

0 Kudos
3 Replies
RPete12
New Contributor I
104 Views

I assume you have checked in the Bios to ensure that the Thunderbolt port is still enabled and not been disable or reset by the upgrade?

ssrfr
Novice
104 Views

Yes, both the thunderport controller are enabled and I have also toggled/cycled between auto for the Video output to actually setting the thunderport/usb-c as primary with no luck.

 

I had a moment of luck by installing the intel thunderport vs 400 software and then upgrading the firmware via the utility to 33. After the first restart it stuck and worked. But on a subsequent restart no dice again. Once I switched the cables back to the HDMI and rebooted I see that there is no longer any thunderport being shown in windows 10 device manager.

 

Tried reinstalling a minute ago and no luck either (remove and reinstall and reboot). Thunderport no longer being recognized/installing/etc. on the NUC after this bios upgrade. Still cannot get the system to downgrade to an earlier version either. Intel has really messed this one up.

Alberto_R_Intel
Moderator
104 Views

ssrfr, Thank you for posting in the Intel® Communities Support. Since the problem you are reporting is the same issue showing in a different thread, we will continue the support in there to avoid duplications on this matter, please keep verifying the following link for any updates on this topic: https://forums.intel.com/s/question/0D50P00004GppZn/nuc7i5bnk-bios0076-upgrade-breaks-thunderport?fr... Thank you very much. Regards, Alberto R. Intel Customer Support Technician Under Contract to Intel Corporation
Reply