Community
cancel
Showing results for 
Search instead for 
Did you mean: 
slizzap
Beginner
1,098 Views

NUC7i5BNK - USB 3.0 issues (device descriptor request failed)

I have a NUC7i5BNK that will not read any USB 3.0 flash drive. Thinking it was driver related, I did a full sweep of BIOS and driver updates, but had no luck. Even upgraded Windows 10 from 1709 -> 1803. I tried booting from it, but the BIOS wouldn't even see it as a bootable device, which is when I realized this was probably hardware related. Note that this same flash drive works fine on multiple other PCs (including a Windows 7 laptop using either USB 2.0 or 3.0 ports, and another Windows 10 PC using either USB 2.0 or 3.0 ports). This flash drive also works as a music storage device for my car. So the issue is definitely not with the flash drive.

 

After researching on these forums and other locations, I found a suggestion where using a non-USB 3.0 extension cord to connect the flash drive worked around the problem. Sure enough, that worked around the problem for me. Most of the posts I found were related to older NUC models. Is this a known issue?

 

NUC7i5BNK

BIOS: BNKBL357.86A

Windows 10 Pro 1803

USB drive: PNY PRO Elite USB 3.0 512 GB (P-FD512PRO-GE )

0 Kudos
2 Replies
Diego_S_Intel
Employee
89 Views

Hello slizzap, Thank you for joining our Intel ® community. I understand that you are experiencing issues with the USB ports of your Intel® NUC Kit NUC7i5BNK. As far as we know, this is not a known issue, however we really appreciate the workaround that you shared with us. In order for me to assist you better and to have a deeper insight into your system, please provide me with the .txt file that the System Support Utility will generate. To attach a file, you must click the “Attach” option on the bottom right-hand corner of the response box. Here is the link: https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows- I hope to hear from you soon. Diego S. Intel (R) Customer Support Technician Under Contract to Intel (R) Corporation
slizzap
Beginner
89 Views

This is not an isolated issue, nor is it unique to the Intel NUC line. After I posted this I had just purchased a 2nd Intel NUC for another project, which is the same make and model of my other NUC. Both have the same issue. I was also recently building another computer that has a Gigabyte motherboard with the H170 chipset. This board has the exact same problem. For all 3 computers, if I directly connect my flash drive to any USB port, the system will not recognize it. I have to connect my flash drive to a USB 2.0 extension cable for the BIOS to see it and to be able to boot from it. This is a larger problem than the NUC, so I'm not going to bother troubleshooting further.

 

Thanks.

Reply