Community
cancel
Showing results for 
Search instead for 
Did you mean: 
TWöge
Beginner
2,459 Views

NUC7i5DNKE cannot boot from EVO 960

I am using a Intel NUC7i5DNKE and the installed M.2 Samsung 960 EVO is not available as a bootable device in Uefi-Bios.

0 Kudos
9 Replies
LeonWaksman
Super User
454 Views

1. Please check that the drive is properly sitting in M2 slot and fastened wilt its screw. You can remove it and insert again.

2. In Bios settings: Advanced -> Devices->PCI->M2.Slot shall be enabled (checkbox).

I'll start from settings Bios to default settings:

  1. Enter Bios setting by pressing F2 during boot process.
  2. Press F9(followed by "Y"), to set Bios to default settings. Press F10 (followed by "Y"), to save the settings and exit to O.S. Let the NUC fully reboot.
  3. You can enter again to Bios setting to change the necessary settings.

Leon

n_scott_pearson
Super User Retired Employee
454 Views

I haven't verified this one way or the other, but there was a posting the other day that indicated that both UEFI and Legacy boot needed to be enabled for this to work (for the NVMe drive to be detected properly). Obviously, Legacy boot shouldn't need to be enabled but this user claimed that the latest BIOS has an issue that requires this setting.

Hope this helps,

...S

TWöge
Beginner
454 Views

Thanks N.Scott.Pearson - it´s weird, but this was the right thing to do. NUC-box boots now from M.2.

LeonWaksman
Super User
454 Views

Hell Tom,

It is really very weird to me too. I can't understand your and Scott's claim that Legacy boot must be enabled in order to boot from M.2 NVMe drive. I've even tested it in my NUC6i5SYH (with Samsung SM951 NVMe PCIe M.2 256GB installed drive as booting drive). So, after disabled the legacy boot, my NUC is booting without any problem (only with UEFI boot enabled). By the way - if you where acting according to may advice (i.e. setting Bios to default), it will also enabled the Legacy Boot.

I'm writing this post not because I want to argue with you, but only because I want to be sure that your founding are not misleading for other users. So, can you please, in situation that your NUC is booting, disable (just for test), legacy boot in bios and veryfy that your computer can't boot?

Thank You

Leon

n_scott_pearson
Super User Retired Employee
454 Views

Leon,

I am not saying that this is normal. There is a bug in the DN BIOS, plain and simple. A user discovered that enabling Legacy boot seems to overcome this bug. It is a workaround; nothing else.

...S

LeonWaksman
Super User
454 Views

Hello Tom,

Did you try to boot your NUC with legacy boot disabled? Can you confirm that the NUC doesn't boot?

Leon

JDoe14
Beginner
454 Views

Hello

On my side I m using a NUC7I5BNK with M.2 Samsung 960 EVO and no way to see it as bootable UEFI device. I see the M2 drive only in the legacy boot section (and works if I install grub in MBR)

Note: I m using linux gentoo, did the proper partionning (GPT + EFI boot partition FAT32 with boot and esp flags) and installed a grub EFI enabled bootloader.

/boot

└── EFI

| └── Gentoo

| └── grubx64.efi

└── vmlinuz-4.14.49

Cheers.

n_scott_pearson
Super User Retired Employee
454 Views

John77,

Your issue is not the same. Please open a separate conversation.

...S

DGrei2
Beginner
454 Views

Can confirm this is still an issue in April 2020, with the NUC8i5BEK with the Samsung Pro 960 512 GB drive . On initial install the drive showed up as NVME but not anywhere in the boot list.

 

On doing the following:

1) hit F9, then Y to reset to defaults

2) hit F10, then Y to save and reboot.

3) On reboot, enable BOTH UEFI and Legacy Boot options.

4) Again hit F10 and Y to save and reboot.

 

After the second reboot, the Evo 960 showed up in the boot list. I was then able to boot from it flawlessly. The system had to reconfigure some drives on boot but this was no issue.

 

Hope this helps!

 

 

 

Reply