Community
cancel
Showing results for 
Search instead for 
Did you mean: 
INetw1
Beginner
1,897 Views

NUC7i7BNH does not have UEFI PXE boot option

Hey, folks.

We have to deploy a large about of NUC workstations for a client which requires all of them to have BitLocker enabled. This cannot be done if the OS is not installed from (and subsequently booted) from UEFI.

When in the BIOS setup, I noted that the list of UEFI-available devices is missing LAN (PXE) as an option. It is available, and indeed works, as a Legacy boot option. I have updated the BIOS on the NUC7i7BNH tester model I have with the latest BIOS released on 05/28/2018 [BNKBL357.86A] using the F7 Recovery Flash method. Even after doing so, I'm in the same boat. I can UEFI boot a USB-attached drive, but not PXE boot. This is a problem as when we Legacy boot our WDS server to install the client's image, we cannot enable BitLocker as the OS does not boot UEFI after install.

Is there any way to get this model to UEFI PXE boot? I have attached screenshots so you can see what I see. Thanks in advance!

0 Kudos
4 Replies
INetw1
Beginner
167 Views

Ah, forgot to mention. UEFI LAN boot is also not an option when using F10 Boot Options on boot. UEFI USB booting is present, however.

idata
Community Manager
167 Views

Thank you very much for contacting the Intel Communities Team, IntegralNetworks. I will be more than happy to assist you.

 

 

By checking the screenshot attached, I can see that Legacy Boot is enabled. Please, uncheck this option, press F10 and then access the BIOS back and double check the Network Boot options.

 

 

Let us know how it goes.

 

 

 

Antony S.

 

idata
Community Manager
167 Views

Hello, IntegralNetworks.

 

 

I would like to double check if you were able to perform the troubleshooting steps that I attached to the post above and the results.

 

 

 

Antony S.
INetw1
Beginner
167 Views

Hi, Antony.

Your answer alone did not solve the issue, but it set me on the right path. The full answer is to disable Legacy Boot AND enable Secure Boot. Then the UEFI LAN options will show up. Thanks for the guidance.