Community
cancel
Showing results for 
Search instead for 
Did you mean: 
RLipp
Beginner
1,584 Views

NUC7i7BNH ethernet stopped working under Ubuntu

Hi all,

I put Ubuntu on a 7th generation Intel NUC (NUC7i7BNH). Started with 16.04 and everything was fine until last week or so. Then the wired ethernet stopped working (wireless is fine).

dmesg shows the following:

[ 5.713374] e1000e 0000:00:1f.6: enabling device (0000 -> 0002)

[ 5.713559] e1000e 0000:00:1f.6: Interrupt Throttling Rate (ints/sec) set to dynamic conservative mode

[ 6.732187] e1000e: probe of 0000:00:1f.6 failed with error -2

After lots of Googling and troubleshooting I've tried the following:

1) upgrading to 18.04

2) disabling wake on lan

3) disabling secure boot

4) downgrading bios to version where it was working

5) using intels updated e1000 drivers

None of these are working.

Anyone else have any ideas/have run into this? I'm at my wit's end trying to fix this.

Oh, lshw -c network:

*-network

description: Wireless interface

product: Wireless 8265 / 8275

vendor: Intel Corporation

physical id: 0

bus info: pci@0000:3a:00.0

logical name: wlp58s0

version: 78

serial: a0:c5:89:fc:71:64

width: 64 bits

clock: 33MHz

capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless

configuration: broadcast=yes driver=iwlwifi driverversion=4.15.0-34-generic firmware=34.0.1 ip=10.0.0.103 latency=0 link=yes multicast=yes wireless=IEEE 802.11

resources: irq:131 memory:dc200000-dc201fff

*-network UNCLAIMED

description: Ethernet controller

product: Ethernet Connection (4) I219-V

vendor: Intel Corporation

physical id: 1f.6

bus info: pci@0000:00:1f.6

version: 21

<span style="color: ...

0 Kudos
2 Replies
idata
Community Manager
263 Views

Hello rlippmann,

 

 

Thank you for joining our Intel ® Community.

 

I understand that you are experiencing issues with the Ethernet Connection (I219-V) of your Intel® NUC Kit NUC7i7BNH.

 

In this case, please consider that Intel® does not test and validate Intel® NUC on Linux*, however we know that a lot of NUC owners are using is successfully on many different Linux distros.

 

Intel ® suggests you check Linux's Ubuntu* https://www.ubuntu.com/support/community-support website and https://www.ubuntu.com/support/community-support forums for peer assistance with this installation issue.

 

The issue that you are experiencing seems to by a driver compatibility issue, since the only supported OS for your unit is Windows® 10, 64-bit*(Home and Pro editions) as you can check https://www.intel.com/content/www/us/en/support/articles/000005628/mini-pcs.html here.

 

However, you can try our https://downloadcenter.intel.com/download/22283/Ethernet-Intel-Ethernet-Adapter-Complete-Driver-Pack... Intel® Ethernet Adapter Complete Driver Pack. Not all Intel® Ethernet Adapters and Intel® Ethernet Controllers are supported under every version of Windows*, Linux*, or FreeBSD*, so we do not guarantee that these drivers will have an impact on your issue.

 

I hope this helps.

 

Regards,

 

Diego S.

 

RLipp
Beginner
263 Views

I've already posted to ubuntu forums with no response.

As I've stated in my original post, I have downloaded and installed the latest intel linux drivers and compiled them from source with the same resulting error in the log files.

I believe this is a BIOS issue as everything worked fine until I updated to the August 24th version. Now, even downgrading the BIOS doesn't fix it.

Reply