Community
cancel
Showing results for 
Search instead for 
Did you mean: 
NNovg
Beginner
1,499 Views

NUC7i7BNH refuses to hibernate after restart

Hi,

I'm not entirely sure whether the issue is NUC related or purely a Windows bug, but I only ever encountered it with the new NUC. The OS is Win 10 x64 Education with all patches installed to this date. I have a PCIe SSD, a SATA HDD and 8GB RAM installed.

The problem is the following: If the NUC boots up after a restart (regular restart button or "shutdown -r") and then I try to hibernate it, the screen goes dark for a second and then I'm immediately back to the lock screen (or to the desktop if entering the password after sleep/hibernate is disabled). If I try to hibernate it via command line ("shutdown -h"), it does the same and returns an error: "Insufficient system resources exist to complete the requested service (1450)." Sleep mode (S3, suspend to RAM) still works though. It also seems not to depend on whether the hybrid sleep mode or the quick boot mode is on in the power settings.

However, if I shutdown the NUC completely ("shutdown -s") and boot it up by pressing the power button, hibernation works again and I can boot up and hibernate indefinitely. Only if there is a restart in between, hibernation will stop working until it's shutdown and started up again via the power button.

That's very strange behavior and I don't know where to even start troubleshooting, as there is no error in the event log if the hibernation fails with the 1450 code. And since the problem consistently happens after a restart (i.e. where the NUC is not technically powered down before booting up), I suspect it might be hardware related...

Could anybody reproduce this?

0 Kudos
3 Replies
idata
Community Manager
50 Views

Hi Novgorod: Thank you very much for contacting the Intel® NUC communities. We are sorry to hear the NUC is not working properly.

 

 

In regard to your inquiry, I tried to replicate the issue using the same Intel® NUC7i7BNH, and the issue was not replicated, the NUC went to hibernation even after restart.

 

 

In order to try to fix this problem we can try a BIOS update to the latest version: 0060 using the F7 method:

 

https://www.intel.com/content/www/us/en/support/articles/000005850/mini-pcs.html https://www.intel.com/content/www/us/en/support/articles/000005850/mini-pcs.html

 

https://downloadcenter.intel.com/download/27397/BIOS-Update-BNKBL357-86A-?product=95065 https://downloadcenter.intel.com/download/27397/BIOS-Update-BNKBL357-86A-?product=95065

 

 

Also, we can try to install the latest graphics drivers, version 4849:

 

https://downloadcenter.intel.com/download/26947/NUCs-Intel-HD-Graphics-Driver-for-Windows-10-for-Int... https://downloadcenter.intel.com/download/26947/NUCs-Intel-HD-Graphics-Driver-for-Windows-10-for-Int...

 

 

We can try version 4877 as well:

 

https://downloadcenter.intel.com/download/27355/Graphics-Intel-Graphics-Driver-for-Windows-15-60-%3F... https://downloadcenter.intel.com/download/27355/Graphics-Intel-Graphics-Driver-for-Windows-15-60-?pr...

 

 

Additionally we advice to set the Windows power options on "Balanced" and what we did was to set sleep mode to "Never" and it worked just fine.

 

 

The problem could be related to the Windows image as well, if you have the option please install Windows from scratch using a different image to rule out that possibility.

 

 

Any further questions, please let me know.

 

 

Regards,

 

Alberto R

 

NNovg
Beginner
50 Views

Thanks for the reply! Sorry, I should have added these details: I was already using the latest BIOS (0060) and 4849 graphics drivers as well as all other NUC drivers currently available on the intel website. I tried the 4877 graphics driver (had to manually install it because it's generic) but it didn't make any difference. Also, the power settings were already set to "balanced" and sleep mode to "never".

I could do a bit more testing: It seemed to be restart related the first time I tested it but now I can't reproduce a way to reliably make it hibernate without the 1450 error code, even after a full shutdown and bootup. No change was made to the system since then. It does hibernate sporadically but won't do it the next time it resumes and the vast majority of the time it just doesn't hibernate (and it never did hibernate after a restart so far).

I also investigated the power options, in particular fast boot and hybrid sleep, as both of them use hibernation (suspend to disk) to some extent. If I enable fast boot, the regular shutdown doesn't work - it behaves like the broken hibernation (I guess because it tries to use hibernation but fails). If I enable hybrid sleep, the regular sleep mode (suspend to RAM, S3) doesn't work because it does S3 with hibernation in the hybrid sleep mode. All this indicates that hibernation is "broken" but I don't know why and how to troubleshoot this. The "broken" behavior is as explained in the first post: the screen turns black for some seconds and then turns back on showing the lock screen or the desktop (if entering a password on wakeup is disabled).

I'll test a fresh/minimal Win 10 installation but it'll take some work to backup and restore the current one...

idata
Community Manager
50 Views

Novgorod: You are welcome. Thank you very much for proving those results. Yes, at this point that will be the next thing to do, to re-install Windows in order to confirm if in fact the problem is related to the operating system. The other option will be to replace the NUC.

 

 

If you are interested in that procedure, please get in contact with Intel directly to confirm if the unit is eligible for replacement:

 

Chat support:

 

http://intelsupportchat.force.com/icslivechat/ics_tech_processor_ww_english_Chat http://intelsupportchat.force.com/icslivechat/ics_tech_processor_ww_english_Chat,

 

 

For phone support, depending on your location, you will see the contact information on the links below:

 

EMEA contact information: https://www.intel.com/content/www/us/en/support/contact-support/emea-contact.html https://www.intel.com/content/www/us/en/support/contact-support/emea-contact.html

 

APAC contact information: https://www.intel.com/content/www/us/en/support/contact-support/apac-contact.html https://www.intel.com/content/www/us/en/support/contact-support/apac-contact.html

 

LAR contact information: https://www.intel.la/content/www/xl/es/support/contact-support/lar-contact.html https://www.intel.la/content/www/xl/es/support/contact-support/lar-contact.html

 

North America: Phone Number 1-916-377-7000, Monday – Friday 7:00 AM to 5:00 PM (Pacific Time).

 

 

Any questions, please let me know.

 

 

Regards,

 

Alberto R