Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,097 Views

NUC7i7DN Serial Port in Linux

I have been unsuccessfully trying to use the serial port exposed on the PicoBlade header on the NUC7i7DN for several days now.

I'm trying a simple loopback test, which doesn't work. I'm on the latest BIOS (v47) and the Serial Port is enabled in the BIOS. On Linux, it seems to enumerate as /dev/ttyS0. When sending data to the port's RX pin and trying to see it in `screen`, the output is garbled and/or just random.

Any help would be appreciated!

Tags (1)
0 Kudos
2 Replies
Highlighted
Super User Retired Employee
20 Views

You do realize that this is a TTL Serial Port, right? Unlike a RS232c port, which uses -12V and +12V to differentiate 0's from 1's, a TTL serial port uses 0V and 5V for this same differentiation. If your target is a RS232c port, you are going to have problems. For more information, consult such articles as https://www.microcontrollertips.com/asynchronous-serial-communication-explained-including-ttl-uart-r... Asynchronous Serial Communication Explained (including TTL, UART, RS232), https://www.sparkfun.com/tutorials/215 RS-232 vs. TTL Serial Communication and https://electronics.stackexchange.com/questions/6889/how-does-ttl-serial-work How does TTL serial work?.

Now, you are saying that you were performing a simple loop-back test, which should not be affected by the TTL vs. RS232c signalling issue (since TX and RX are in same port). This I cannot explain. It should work. Is some sort of flow control being enabled?

...S

0 Kudos
Highlighted
Beginner
20 Views

Yes, I am aware that it is a TTL UART. I tried a loopback, and also tried connecting to an external device doing 5V TTL serial. I disabled flow control for all tests.

0 Kudos