Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Chris78
Novice
1,977 Views

NUC8I7HVK - (A7) Me FW - Downgrade - Request MeSpiLock Failed: BIOS Recovery failed

Rebooted my NUC this morning and got confronted with the (A7) Me FW - Downgrade - Request MeSpiLock Failed message. BIOS post to splashscreen takes minutes so searched the internet for a solution. Found the last resort option to do a BIOS recovery. Tried both ways (Power Button and Security Jumper). Both of them gave me the option to F4 BIOS Recovery but both reboot instantly. NUC is really slow on boot now, takes around 2 minutes before splash screen.

 

Solutions tried to recover BIOS:

 

  • Removed all devices, except for 1 memory module
  • Tried 7 USB devices (4GB, 16 GB and 32GB, fully formatted with FAT32 under Windows and SDcardformatter v5) without any luck (BIOS recovery not starting).
  • Tried to upgrade to same BIOS (worked once but didn't solve anything)
  • Tried to downgrade (not working)
  • CMOS battery unplugged for 30 minutes
  • Security Jumper removed, set to other pin combination
  • Underclocked memory to 2400Mhz and 2133Mhz (solution I found in one of the treads)

 

I'm out of options. Anyone any idea?

 

Specs:

 

NUC8I7HVK

BIOS 53

2x Samsung Pro 970 512GB

2x Corsair Vengeance DDR4 16GB, 2666MHz memory modules

0 Kudos
2 Replies
LeonWaksman
Super User
474 Views

Hello @Chris78​ 

Every think what you did is correct in this situation. One think more you may try to boot your NUC with the Security Jumper removed ( open pins 1,2,3). Within about 30 secon​ds you shoul see Configuration Menu. Try to enter bios and reset the settings to default. Dissble Secure Boot.

The other think what you may do and this is probably the solution for you, ask Intel Service for RMA to replace your NUC.

Leon

Chris78
Novice
474 Views

Hello @LWAKSMAN​ (Leon),

 

Thanks for your answer. A miracle just happen. After 4 hours of trying the Security Jumper method, the last USB stick formatted with SDformatter v5 (Overwrite format + CHS format size adjustment checked) launched the BIOS Recovery process. I also removed the USB keyboard and mouse this time so only USB stick was connected. Maybe that did the trick, I don't know.

 

Recovery was successful. I'm back to a 5 second boot time till splash screen, still on BIOS 53.

 

Christian