Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Beginner
198 Views

NUC8i3BEH not passing DTS and Dobly

Hey guys. I just bought myself a NUC to serve as a HTPC in my entertainment room. I have a 55" Samsung J series (2015) UHD TV connected to a Denon X540-BT AV receiver. The receiver is capable of processing Dolby Digital, DTS, Dolby True-HD, DTS-HD MA and DD+. It does not support Atmos or DTS:X

I have the TV hooked up to the AV receiver via HDMI ARC and then all my devices are subsequently connected to the AV receiver, which I use for switching. I cannot seem to get any of the surround sound formats to passthrough to the receiver. I tried using MPC, VLC and even Kodi. It only passes multi channel PCM signals

I read that I should update the HDMI firmware, which I did. I tried everything and I still cannot get the passthrough to work. The only thing that worked for me was DD+ from the Dolby Access app. DD+ from rips did not passthrough

I read some bad things about the HDMI outputs of the NUCs. Could this be the culprit? I want to try a USB C to HDMI converter in order to see if that works. If it does then it's definitely related to the HDMI port of the NUC

I was so excited to acquire the NUC because it's an amazing little machine but now the main purpose was for passing uncompressed audio to the receiver and I am disappointed that I can't get that to work

Please help!

Labels (1)
0 Kudos
5 Replies
Moderator
181 Views

Hello yashsookoo,


Thank you for posting on the Intel* Community.


To better assist you, please run the following tool in Windows* and attach the report generated. 

  

Intel® System Support Utility (Intel® SSU) 

 

  • Intel® SSU Download
  • Open the application and click on "Scan" to see the system and device information. By default, Intel® SSU will take you to the "Summary View". 
  • Click on the menu where it says "Summary" to change to "Detailed View". 
  • To save your scan, click on "Next", then "Save". 


Best regards,

Maria R.

Intel Customer Support Technician


Moderator
160 Views

Hello yashsookoo,


Were you able to check the previous post? 


Let me know if you need more assistance. 


Best regards, 

Maria R.  

Intel Customer Support Technician 


0 Kudos
Beginner
143 Views

Good day. Please see the SSU report attached

Please note that I managed to get DTS, DTS-HD and DD+ passthrough enabled. Some Dolby Digital files are passing through as well, but not all

0 Kudos
Beginner
125 Views

So I'd like to drop an update. I managed to get everything to work correctly after reading through a few forums

I do not know what exactly I did but it's listed as follows

  • Updated the HDMI firmware
  • Updated all drivers for the NUC
  • Set the sound settings to 5.1 output and also set the sound quality to its highest (24 kHz) in the sound settings
  • In Kodi, went into the expert settings of the sound and set the output to HDMI WASAPI
  • I then selected passthrough for all the formats

After doing all this everything started working properly as it should

Thank you and if anyone reading this needs assistance I will provide some screenshots/instructions

0 Kudos
Moderator
117 Views

Hello yashsookoo,


We are glad to know you found a solution, thank you for taking the time to share this fix, and hopefully, it may help other community members experiencing similar behavior. Since the thread is now solved, we will proceed to close it.

 

If you need any additional information, please submit a new question as this thread will no longer being monitored.

 

Best regards,

Maria R.

Intel Customer Support Technician


0 Kudos