Intel® NUCs
Assistance in Intel® NUC products
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
12983 Discussions

NUC8i5BEH USB C Port not working


Hi All

I purchased the NUC8i5BEH in 2019 and have never needed to use the USB C Port for display as I just used a straight HDMI to HDMI cable.

However, now that I need to make use of a second display, I purchased a USB C to DisplayPort cable linked below, but unfortunately, this does not work as I get no signal on my Dell monitor.

Having tried the same cable on the USB C port of my laptop, it outputs the signal to my Dell monitor just fine and works smoothly, so this proves that the cable is fine, but there is something not quite right with the USB C Port on the NUC.

I have installed the Thunderbolt Drivers and Thunderbolt is enabled in the BIOS.

The BIOS version is: BECFL357.86A.0083.2020.0730.1436, 30/07/2020
OS: Microsoft Windows 10 Pro 1903
Iris Plus Graphics 655 Driver Version:

EDIT: Just to add, I have installed the thunderbolt drivers below.
Thunderbolt™ 3 DCH Driver for Windows® 10 for Intel® NUC
Thunderbolt™ 3 Legacy Driver for Windows® 10 for Intel® NUC


Can someone please kindly advise on this issue as I would really appreciate some help with this.

Thank you

0 Kudos
1 Solution

Problem solved thanks to a reddit user!

I simply had to turn off the NUC, and then use a screwdriver to short the power connector as shown here


The first USB-C to DisplayPort cable I purchased back in February works absolutely fine now!

I will let Intel Support know.

TechGuy, interestingly, the USB-C to DisplayPort cable connected to the Dell was causing the monitor to turn on and off, but disabling DisplayPort 1.2 in the monitor's setting resolved this. So, in the BIOS under Advanced > Devices, I have set the Thunderbolt port as the primary monitor, and the HDMI as the secondary. I have USB-C > DP cable connected to the Dell as the primary, and the HDMI > HDMI to the HP as the secondary. Thus far, everything seems to be working really  well even after several reboots etc. I just hope it stays that way.

Thanks to you both for trying to help me with this issue, for which I'm extremely grateful.

View solution in original post

22 Replies
Super User Retired Employee

The USB-C implementation on the KY NUC offers the same features as is available on the BE NUCs, so if it works for one, it should work for BE. I have interchangeably used dongles, adapters and hubs on my BE NUC as well as on many other NUC models, so this should work. Let's look for issues.

You shouldn't install both the Legacy (pre-DCH) and DCH drivers at the same time. Uninstall the Legacy driver package and then reinstall the DCH drivers again.

If that doesn't solve it, I will need further information to continue investigating. Please download and run the Intel System Support Utility for Windows and have it save the report to a file. Then, using the Drag and drop here or browse files to attach dialog below the edit box for the body of your response post, upload and attach this file to the response post.



Hello, and thanks for taking the time to respond.

It's a strange one this, but after your comment about only installing the DHC drivers and not the legacy Thunderbolt drivers, I decided to do the following:

1. Restore the BIOS back to factory settings.

2. Reinstall Windows 10 Pro (latest version from their site burnt to a USB Stick)

3. Windows fully patched with all updates

4. Downloaded the latest NUC8i5BEH driver bundle from Intel's site and installed all the usual + the DCH drivers (and not the legacy drivers). Please note that the DHC zip file only contains raw .inf, .sys, .cat and .dll files. The only way I could install the drivers was to right-click the .inf files (3 of them) and select INSTALL. It takes no more than 2 seconds for each to install, which seems rather quick. Rebooted computer.

5. Ensured Thunderbolt is definitely enabled in BIOS, which it is.

Still nothing! It just doesn't work! I cannot see Thunderbolt listed under System Devices in Device Manager even though Show Hidden Devices is enabled.

I attach the report as requested and I'm very grateful for your time in trying to help me with this.

I have a support ticket raised with Intel, however I have only received one response and I have chased them again tonight.

I have a feeling the USB C port is just dead and I'm dreading having to return it back to Intel, but I don't have a choice as I really need this fixed.

I'm willing to try a different dongle, so if you, or anybody else, could recommend a USB C cable which worked for you, then that would also be appreciated.



Hi, I have the SAME computer (NUC8i5BEH) as you.  Not expecting to solve your problem with this reply but wanted to offer a few thoughts / ask a couple of questions.

1. Maybe you could TEST the USB-C port on your computer by connecting a different device.  For example, I have a USB hub that converts from USB-C to 4 x USB 3.0 Type A ports.  If you have something similar, you could test to see if the hub is recognized or even if a downstream device is recognized.

2. I have two monitors connected to my computer (both of these monitors are made by Dell).  This is how it works in my setup:

  • Dell U2419HC (Primary) Monitor
    • This monitor has HDMI, DisplayPort, and USB-C inputs.  I am using the USB-C input.
    • It is connected to the NUC via USB-C cable (USB-C connectors on both ends)
    • It receives a DisplayPort signal using "DisplayPort over USB-C" technology
    • It also has a DisplayPort output.  I am using this to daisy chain the 2nd display.
    • I have enabled a setting in the primary monitor to support Multi-Stream Transport (multiple displays)
  • Dell U2419H (Secondary) Monitor
    • This monitor has HDMI and DisplayPort inputs.  I am using the DisplayPort input.
    • It also has a DisplayPort output.  This is unused.
    • It is daisy-chained to the U2419HC monitor using a DisplayPort cable (DisplayPort connectors on both ends)

I mention the above because, in my setup, I do NOT see any Thunderbolt devices showing up in Device Manager.  Consequently, I have never needed to install the Thunderbolt drivers.

My question:  Which Dell monitor do you have?  (I'd like to look up the specs...)


Hey TechGuy,

Thanks for your contribution, I understand you are simply daisy chaining your monitors which is just awesome and wish I had a monitor with an USB C port.

Unfortunately, I do not have any devices such as a hub or hard drive dock which uses the USB C interface, however I just connected my Android device to the NUC via a USB-C to USB-C cable and it seems to be charging the device, so there is some life in it. Good suggestion.

My main monitor is the Dell U2515H which is quite old now, but it really does have a fantastic display. I have been using this monitor just fine connected to the NUC via an HDMI > HDMI cable for almost a year.

I purchased my second monitor, HP E233, a few days ago for work purposes, and it's not great, but serves it purpose.

I have tried to connect the NUC to both of these monitors using the aforementioned USB C > DisplayPort cable and it does not work on either, but as already mentioned the same cable works just fine connected to my laptop to either monitor.

I really want to try a USB C > HDMI cable, do you think that's a good idea? If so, any you can recommend from Amazon UK?



Some more comments/suggestions:

Check the DisplayPort connection on your U2515H Monitor

  • It would not hurt to recheck that you've plugged your cable to the DisplayPort IN port on the monitor and NOT to the DisplayPort OUT port (a simple mistake)

Enable DisplayPort 1.2 (DP 1.2) in your Monitor's Setup

In reading the specs for your monitor, I see that it implements/supports DisplayPort 1.1a by default but has an Enable/Disable setting for DisplayPort 1.2.

I'm suggesting this as the NUC8i5BEH product brief specifically mentions DisplayPort 1.2.  See: 

  • From the User Guide, your monitor runs in DP 1.1a mode by default
  • You can go into the setup and change it to DP 1.2 mode (Enable DP 1.2)
  • See page 27 of the referenced manual 

Other Stuff...

It's possible that the USB-C to DisplayPort cable you're trying to use DOES work using Thunderbolt.  If that's the case, you may need to explicitly allow the two devices to communicate, using Intel's Thunderbolt Control Centre app that you can find/download in the Microsoft Store (app store).

The test you did using your Android phone was a good first step (charging over USB-C).  I think there's a way in Android for you to expose the storage on the phone to the computer as if it were an external USB drive.  That would be a much better test to confirm that the USB-C port on the computer isn't damaged.

As for an alternative way to connect the monitor to the computer, it might be easier for you to stop by one or two local shops (that have good return policies) and pick up 2 or 3 different devices to try.  I would opt for a USB-C multi-port dongle versus a straight USB-C to HDMI cable.  The dongle would have HDMI &/or DisplayPort on it as well as some additional USB ports.  Note that there are good products out there and "not so good" products.  I would try to stick with the name brand vendors.  Dell itself has such a dongle.  I believe ioGear & Plugable are good names in this space.


Hello, again TechGuy,

Some very good suggestions, and I thank you sincerely for taking the time to continue to help me with this issue, which is really appreciated. I will give you the requested info below...

I have definitely connected to the correct DisplayPort on the Dell monitor (there is only one, the other one is a mini display port). Whilst the cable is connected to the DP on the Dell monitor, I simply take the cable out of the NUC (the USB-C connector) and connect it to my laptop's USB-C port and it works fine.

I already enabled DisplayPort 1.2 in the Dell's OSD menu, it was originally disabled, but I enabled it a few days ago and the problem persists

I installed the legacy Thunderbolt software which has a control panel, however it does not show any devices connected in the list.

I purchased this tonight from Amazon and it should arrive tomorrow, so I will update you once I've had a chance to test.

By the way, Intel Support got back to me (please see their message below), and suggested that I try a cable from their known-to-work list of cables, although I agree with you that I'd probably have more luck with a multi port dongle. Note that the Intel Support chap mentions to look at the cable section, however I find the adaptor section more interesting such as this one which is confirmed to be compatible


"I appreciate the information provided and I am sorry for the delay.

In this case, the cable that you are using may not be fully compatible with the unit. I recommend you to try one of the "Intel® Product Compatibility" under the "cable" option, you can check that here.

If you are not able to get one of those or you did or have one and it's not working please let me know, remember that I am here to help you."


I ordered the one from amazon before I received the message from Intel's support, but I'm keen to give it a go as someone in the review section mentioned that this cable was the only one that worked for their NUC. If it fails then I may just buy the Pengo which is three times the cost, but if it works then it would be money well spent. Also, the majority of the compatible cables/adaptors are only availabe in the US, so I'd have to pay a bit more money to import it to the UK, but the main issue is the time it will take to arrive.

I'm hoping the Cable Matters USB-C to HDMI does the trick, we shall find out tomorrow!

Thanks again, chap, you have been super helpful.


Sorry, just wanted to add that I tried to change the option for 'Use USB for" on my OnePlus 6T and Huawei P40 Pro mobile phones when connected to the NUC and charging, however those options are greyed out.

If I connect either phone to the NUC via a USB A > USB-C cable then the options become available on the phones and I get to choose what I want to do such as charge, browse files etc.

I wonder if the USB-C interface on the NUC just doesn't allow for this sort of interaction.

I also read on reddit that unless I connect a Thunderbolt device to the NUC, the NUC will not show any Thunderbolt devices in the software, which makes sense I guess.



Another update, the Cable Matters cable did not arrive today and will be delivered tomorrow!

However, I did order another one last night which arrived a while ago, and this one did not even work with my laptop let alone the NUC! So, it's going straight back. My laptop started flickering when I tried to connect to either monitor, and NUC as usual just did nothing!

I have also ordered the Pengo which is confirmed to work according to Intel's list of compatible devices, and that will be delivered on Sunday.

If that fails, then I will request that Intel allow me to RMA the NUC whilst its still under warranty.

Also, I was looking at the instructions on how to install the DCH Thunderbolt Bus Driver here, and the instructions clearly state that there should be a Base System Driver in the Other Devices category in Device Manager, and this is where you update the DCH driver obtained from here, however I cannot find anything of the sort under any category in Device Manager even with Show Hidden devices enabled! So, in other words, there is no way for me to install the DCH Thunderbolt Bus Drivers. I have pasted the installation steps below from the link above.



How to install 

  • Download this driver package and unzip it to a folder on the Intel NUC.
  • Connect a Thunderbolt device to the Thunderbolt port.
  • Uninstall the existing Thunderbolt Software. This should also uninstall the driver.

      • Open the Start menu and click Settings.


      • Select Apps & features.


      • Select Thunderbolt Software and click Uninstall.


  • Open Device Manager by pressing the Windows key + X, and then select Device Manager.
  • You should see an error on a Base System Driver in the Other Devices category.
  • Double-click the Base System Driver and go to the Driver tab.
  • Click the Update Driver button.
  • Browse to and select the folder where you unzipped the driver package.
  • Click Next to install the driver.

Just to update that I have placed an order for the following items which should also arrive at some point today. I shall provide the results once I've had a chance to test them.


Plugable USB C to HDMI 2.0 Adapter

QGeeM USB C to DisplayPort Adapter

uni USB C to HDMI Adapter


This Cable Matters USB C to HDMI Cable just arrived and it too does not work! Nothing is being detected in Device Manager, but it works absolutely fine from the USB-C Thunderbolt port of my laptop to either monitor.

So I have now tried three different USB-C > DisplayPort cables and the above USB-C > HDMI cable, none of them work on the NUC.


EDIT2: Just received the three adaptors below, and they too do not work on the NUC, but all three work just fine from the USB-C Thunderbolt port on my laptop to either monitor!

Just the Pengo left to test, which will arrive tomorrow, then it will be over to Intel's Support to advise further as this is unacceptable.

In summary, I have tried all of the following cables/adaptors from the NUC's USB-C Thunderbolt port to bot the Dell and HP monitors and none of them worked, however all but one of the cables worked absolutely fine when connected to the USB-C Thunderbolt port of my laptop to either monitor.

Cables tested:
uni USB C to DisplayPort Cable
CHOETECH USB C to DisplayPort Cable
Cable Matters USB C to HDMI Cable

Adaptors tested:
Plugable USB C to HDMI 2.0 Adapter
QGeeM USB C to DisplayPort Adapter
uni USB C to HDMI Adapter


Problem solved thanks to a reddit user!

I simply had to turn off the NUC, and then use a screwdriver to short the power connector as shown here


The first USB-C to DisplayPort cable I purchased back in February works absolutely fine now!

I will let Intel Support know.

TechGuy, interestingly, the USB-C to DisplayPort cable connected to the Dell was causing the monitor to turn on and off, but disabling DisplayPort 1.2 in the monitor's setting resolved this. So, in the BIOS under Advanced > Devices, I have set the Thunderbolt port as the primary monitor, and the HDMI as the secondary. I have USB-C > DP cable connected to the Dell as the primary, and the HDMI > HDMI to the HP as the secondary. Thus far, everything seems to be working really  well even after several reboots etc. I just hope it stays that way.

Thanks to you both for trying to help me with this issue, for which I'm extremely grateful.

Super User

When using anything to cause a short, keep in mind your warranty.



Hi AlHill

Thanks for taking the time to comment, I understand where you are coming from, and it's very good advice, although if I'm being completely honest, I was in some ways hoping the bleeding thing would just die so I could buy something else with two simple HDMI/DP ports and none of this Thunderbolt nonsense. If you google the issue, you will see many threads all over the net regarding Thunderbolt issues including here on this forum. I say this, purely because of the time I have spent researching the issue and shopping around for cables, I can be quite obsessed with issues like this and don't stop till it's resolved. 

Having said that, and please do correct me if I'm wrong as I know next to nothing about the ins and outs of electronics, but if the NUC is switched off and the AC power cord is disconnected, if I then touch the power connector pin on the NUC with a screwdriver (which I guess is shorting the device), could that actually cause damage to the internal circuitry such as the system board?



I've got this same issue with my NUC8i5BEH.  I can run a Thunderbolt device (Presonus Quantum 2626) with a direct cable from the NUC's USB-C port with no issues. However, when I tried to chain in a USB-C hub with the idea that I could run a second monitor and the Quantum 2626 from the hub, the Quantum 2626 gets power but it doesn't work and no devices appear in the Thunderbolt Manager App for me to approve (I haven't tried adding a second monitor yet).  Should a USB-C hub appear as a device that needs authorizing?  

Super User Retired Employee
There is a significant difference between a device - like this dock - that as "Thunderbolt-Ready" versus one that truly supports Thunderbolt. In this case, what is happening is the dock is attaching as a simple USB device, bypassing the Thunderbolt controller completely, and thus no downstream (i.e., below the dock) Thunderbolt support will be available. [Aside: Monitor support via USB-C DisplayPort Alt. Mode will still be available, however.]
If your desire is to connect a downstream Thunderbolt device, you must have a true Thunderbolt dock, not one that is "Ready" (or whatever they choose to call it). At the same time, you also need a dock that is designed to pass on the Thunderbolt capability; just because it has a USB-C connector does not mean it will support a true Thunderbolt device.
Hope this helps,

Thanks Scott.  I just sent that hub back to Amazon.  I'm annoyed at Intel because, by having only 1 TB and 1 HDMI port on the NUC8i5BEH, I'm stuck with a single monitor UNLESS I pay almost what the NUC cost ($250 - $300) for a true Thunderbolt Dock.

Is there no other way to achieve what I'm trying to do with the NUC8i5BEH?


Super User Retired Employee

There are a couple of 'slightly' cheaper Thunderbolt devices that will support the capability you are asking for, though they only support a single downstream monitor. Here is the one I purchased for testing (US$99):

Hope this helps,


P.S. I also purchased this Thunderbolt drive bay for adding an M.2 NVMe SSD (US$90): Sadly, my wife says that I have now blown my budget for test equipment for the next couple of years...

Super User Retired Employee

I just thought of something else: You can use adapters like this: (HDMI) or this: (DisplayPort) to connect two monitors. Since these adapters are Thunderbolt compatible, they can be used below a Thunderbolt dock that doesn't offer this (dual-monitor) capability itself.



The Quantum 2626 Tech Specs are here.  They are not particularly helpful as all they say is that the USB-C port/Computer it is plugged into must support Thunderbolt.

Given that the NUC has it's own power supply, I don't need a docking station that supplies power but it seems all docking stations (by their definition) include power supplies which makes them expensive.  So what I think I need is a USB-C docking station that provides for a second monitor but which passes the full USB-C/Thunderbolt signal through - still struggling to find something at or under $100 that meets my needs.

Intel, if you're reading this, PLEASE add a second HDMI port to the NUC, it's a show-stopper for many people.  An alternative (for me at least) would be a second USB-C/TB port so I could run a simple USB-C to monitor adapter/cable from one and the Quantum 2626 from the other.


Another thought that occurs to me is that I can use a USB 3.0 to HDMI adapter for my second monitor.  My main monitor is a 28" 4k one but the second one would not be able to hit 4k (at least I haven't found one yet that does).  It's a compromise but it would leave the USB-C port free for the Quantum 2626.