Intel® NUCs
Support for Intel® NUC products
12506 Discussions

NUC8i5BEH does not support 5140x1440 resolution on Ubuntu 20.04


I recently purchased a Samsung CRG9 and hooked it to my NUC8i5BEH, with a usb c -> HDMI didn't work;
I tried with a HDMI -> HDMI connection and it worked after a few tries.

After about an hour the monitor went to sleep and on wake the resolution had switched to 3840x1080 the option 5120x1440 had disappeared from the menu, even though 3840x2160 was still listed as an option (which is higher than 5120x1440);

If I use the PBP function it also works but it seems that it's not able to work with that 5120 value since from the spec the maximum supported resolution is 4096 x 2160 @ 60 Hz, 24bpp (which again, is higher 5120x1440).

I don't know if it's a bug or something, I am at a loss, I really like the monitor and I'd rather keep it, since it works intermittently looks like something that might be resolved

0 Kudos
1 Reply

Hello Ferrari_Techie,


Thank you for posting on the Intel* Community.


I need to inform you that Intel has not tested and validated this Intel NUC model with any Linux distribution; however, we have plenty of positive reports from customers that are using the unit successfully on many different Linux distros.


You can check the Intel Compatibility Tool for the NUC model in case you are interested.


This seems to be a compatibility issue or lack of graphics drivers on your system, most Linux-based* distributions include Intel® Graphics Drivers. These drivers are provided and maintained by the Linux* distribution vendors. Contact your operating system vendor (OSV) and use their distribution for driver access and support.

If you need any additional information, please submit a new question as this thread will no longer be monitored.


Best regards,

Maria R.

Intel Customer Support Technician