Community
cancel
Showing results for 
Search instead for 
Did you mean: 
EMarc6
Beginner
335 Views

NUC8i7BEH - BIOS 86A.0077 (2019.11.27.1452) However the option to display Boot function keys F2 F3 F10 F12 are enabled in BIOS advanced boot display options, None of the Function keys appear on the boot screen (only the Intel NUC message).

​Keys are accessible but I would like text appears as it does correctly on my NUC4 e.g.

0 Kudos
9 Replies
AlHill
Super User
85 Views

Some say that this is "by design", others say it is a BIOS problem.

However, you may be able to see the keys by turning OFF secure boot.

 

Doc

 

EMarc6
Beginner
85 Views

​Thanks Doc. I don't think its by design because it works on my NUCs  NUC4 and NUC6, however I haven't checked there if the secure boot is OFF or not.

 

Eric.

 

 

AlHill
Super User
85 Views

Turn secure boot off. Then try.

 

"by design" does not include your other nucs. Only the nuc in question. Remember, they all run a different bios.

 

Doc

 

EMarc6
Beginner
85 Views

I've turned off the secure boot and, as you expected, the Function Keys text did appear!

Thanks Doc.

 

AlHill
Super User
85 Views

Good. There is a debate among some of us about this. As I said, some say it is by design, some say bios error. Back years ago, this would have been called "a bug-like feature".

 

You have to decide about secure boot, now that you know what the issue is. Personally, I would keep secure boot on, and hope for a future bios update.

 

Doc

 

LeonWaksman
Super User
85 Views

Intel says it is design future. I say it is bad design. However, you should know that even when the Secure Boot is enabled and the functional keys menu is invisible, still the keys are accepted.

 

Leon

 

EMarc6
Beginner
85 Views

AlHill
Super User
85 Views

"Intel says it is design future. I say it is bad design."

 

And, the debate continues into 2020<G>

 

Doc

EMarc6
Beginner
85 Views

We'll see in future BIOS updates. The point is when text is displayed, we know when it's the right time for pushing the F-key (it's not too early either too late).

Reply