Intel® NUCs
Assistance in Intel® NUC products
All support for Intel® NUC 7 - 13 systems is transitioning to ASUS. Read more.
13490 Discussions

NUC8i7BEH won't boot, and no hdmi signal


Hi my NUC8i7BEH was working great for over a year, and then yesterday it stopped.


Now, when I start it up, the led on the Nuc turns blue for about 30 seconds, and then turns off for about 5 seconds (the blue LED goes dim for a moment before turning off), and then the LED turns back on again for another 30 seconds.  This cycle repeats indefinitely.  And there is no HDMI signal.  


I tried removing the SSD and it made no difference, and still no HDMI signal.


I tried removing the ram, and when that happens the LED just blinks three times, and still no HDMI signal.


I considered whether there was a BIOS update that did not go well (I did not initiate one, but I don't kno whether one was initiated automatically).  


I followed the Intel guide for resetting the BIOS and, attempted to reset it by changing the jumper, and, separate, by removing and replacing the battery.  These had no effect.


If anyone can help, that would be great. 


Thank you!



0 Kudos
4 Replies
Super User

Hi @TS284 

1. "I followed the Intel guide for resetting the BIOS and, attempted to reset it by changing the jumper"  By saying this you mean that you have performed BIOS Recovery or just reset the yellow jumper from pins
1-2 to 2-3?

2. Can you see some video output (Configuration Menu), if you power ON you NUC without the Yellow Security Jumper (all three pins open)? Remove all devices from the USB ports and wait up to 1 minute, after depressing on Power Switch.

3. Can you test your NUC with other monitor (or TV set)?



0 Kudos

Hi @LeonWaksman thank you for the response.


I followed the steps here: , which involve switching the jumper, and, separately, removing the battery


I tried starting it without the jumper and no devices connected, and still no video output


I also just tested it on the TV set (with a known working HDMI cable) and still no video outbput


I didn't do the USB flash bios steps because the Nuc is my only computer and I can't make a flash drive with it.


Thanks again

0 Kudos
Super User

Hi @TS284 

1. If you don't see the Configuration Menu after power ON with the jumper removed, I'm not sure if the BIOS Recovery will work. Any way, you can prepare a USB stick with the BIOS file using someone else computer (friend or neighbor). If you will have such USB you may try to power ON your NUC with this USB inserted in rear USB port while the Yellow Security Jumper is removed. Wait 1- 2 minutes and see if the BIOS Recovery starts.

2. Since your NUC shows sign of life, please try to power ON with only one SO DIMM at time (first in the upper and then in the lower slot).

3. You may also try (if you have suitable video cable) the rear USB C (Thunderbird) video output.



0 Kudos

Hello @TS284

Thank you for posting on the Intel® communities.

We found that you have an internal open case describing the same issue and the same hardware/software environment as the one in this thread. Since Intel® Customer Support is already assisting you through the internal case, to avoid duplication of effort we will continue the support through the internal case. We will close this inquiry from our side but we will keep the thread open in case the community wants to share more suggestions.

If you need any additional information from Intel, please submit a new question as this thread will no longer being monitored. Thank you for your understanding.

Best regards,

Andrew G.

Intel Customer Support Technician

0 Kudos