Community
cancel
Showing results for 
Search instead for 
Did you mean: 
PHamm2
Beginner
709 Views

NUC8i7HKV disables all USB ports after latest firmware flash - cannot boot!

I just updated my NUC with the latest bios. Rebooted into Windows, all seemed good. Then rebooted into EFI using the advanced startup option in windows. At this point, the bios setup loaded, but my USB mouse and Keyboard do not work. There is no power to the USB ports, the mouse and keyboard lights don't even come on. I tried all the USB ports, front and back. Since I couldn't change anything in the BIOS, I power cycled it so that it would boot into Windows. However, now I get a prompt that says "The previous boot attempt failed. Would you like to restore fastboot on the next boot? (Y/N)". Since the keyboard has no power, I cannot answer this prompt. The prompt does not time out. So basically my NUC is bricked from upgrading to the latest firmware. Please help!

0 Kudos
7 Replies
n_scott_pearson
Super User Retired Employee
229 Views

Unplug A/C power for 5 minutes and then check again. If this doesn't work, disconnect A/C power again and unplug the CR2032 battery connected to the board for 15 minutes.

 

Do you have Fast Boot enabled? My advice: *NEVER* enable Fast Boot. It accomplished nothing and causes all sorts of other issues.

 

...S

PHamm2
Beginner
229 Views

Scott,

Pulling the power did the trick to get past this Fast Boot screen. After restoring power, I no longer get that prompt. I have since disabled Fast Boot.

 

However, my USB ports still have no power when in the EFI Bios. I cannot make any changes to the BIOS or hit any keys pre-Windows startup.

Any ideas on how to fix this?

-Paul

LeonWaksman
Super User
229 Views

@PHamm2​ 

  1. In case that disconnecting the CMOS battery will not help, since your NUC is open, remove the yellow Security Jumper and power ON your NUC. You NUC should boot into Configuration Menu (see the attached image). If the Fast Boot was enabled you will see in this menu an item [F3] Disable Fast Boot. So, press F3.
  2. If the [F3] is not displayed (i.e. Fast Boot is not enabled), please update again your Bios, however this time with the Security Jumper Removed:
  3. Prepare USB stick fully formatted to FAT32 with Bios file HN0057.bio https://downloadcenter.intel.com/download/28829/BIOS-Update-HNKBLi70-86A-?product=126143 . Format your USB with Quick Format option unchecked. Do not format your USB in MAC (OS) or Linux machine. Use Windows.
  4. Remove the yellow security jumper (see Product Technical Spec, para. 2.2.3.4, page 46 )  https://www.intel.com/content/dam/support/us/en/documents/mini-pcs/nuc-kits/NUC8i7HVK_TechProdSpec.p...
  5. Insert the USB with the HN0057.bio file.
  6. Reconnect the power adapter and power ON the NUC. Wait 30 sec - 2min. The Recovery process will start automatically and will end after 2 -5 minutes.
  7. When bios recovery is completed, switch the power OFF, remove the power adapter and replace the Security Jumper (pins 1-2) . Reinstall the LED panel and the upper cover.
  8. Power your NUC ON.
  9. Enter Bios setting by pressing F2 during boot process.
  10. Press F9(followed by "Y"), to set Bios to default settings. Press F10 (followed by "Y"), to save the settings and exit to O.S. Let the NUC fully reboot.
  11. If before update, you have customized bios settings, you can enter again to Bios setting to change the necessary settings. 

 

Hope this helps

Leon

 

PHamm2
Beginner
229 Views

Leon,

Pulling the power fixed the fastboot issue. However, when I boot, my USB ports have no power. So I cannot use the keyboard or mouse pre-windows or in the EFI bios. Worked fine before flashing to the latest bios. Any ideas on how to make my USB ports work in the bios so I can use my mouse/keyboard. As it is now, I can boot into the bios, but cannot do anything.

Thanks!

-Paul

LeonWaksman
Super User
229 Views

Hi Paul,

Do exactly what I've advised in my previous post, paragraphs 2 - 11. Those are instructions for Bios recovery with the Yellow Security Jumper removed. This procedure starts and ends without need for user intervention. Since you have wrote that the USB are not working while you enter Bios, this should still work. Please insert the USB with the bios file into yellow colored USB port.

 

Hope this will work

Leon

 

PHamm2
Beginner
229 Views

Lwaksman,

I did as you suggested and reflashed my NUC without the jumper. This was a success. However, I still had the same problem. Booted into Windows, all good, choose advance options to reboot into the BIOS. Again, no power to any of the USB ports at boot time. Keyboard and mouse did not work. While still in the bios screen, I held the power button down for 3 seconds, and the system flashed, resolution changed (lowered), and suddenly the ports came on. I was then able to access the bios and make the changes I needed, but this method is terrible and I have not attempted to repeat it. Leaving well enough alone, this is ugly!

-Paul

LeonWaksman
Super User
229 Views

Hi Paul,

I'm glad that at least your NUC works.

 

Regards

Leon

 

Reply