Intel® NUCs
Support for Intel® NUC products
Announcements
Do you have improvements you would like us to make on this community site? If so, we would love to hear your feedback! Click here for an 8 question survey. Thanks!

11290 Discussions

NUC8i7HVK - A bootable device has not been detected

fahdriyami
Beginner
1,126 Views

Hello,

I am having trouble installing Windows 10 (20H2) on my Hades Canyon NUC. Whenever I try, Windows setup completes, then it goes to the Getting Devices Ready screen, and when that completes the NUC restarts and displays an error that a bootable device has not been detected.

Hardware:

  • NUC8i7HVK
  • Samsung 950 Pro NVMe
  • 16GB RAM

 

BIOS Settings:

  • BIOS version: HNKBLi70.86A.0064.2020.1028.1438
  • UEFI Boot: Enabled
  • Fast Boot: Disabled
  • Secure Boot: Enabled

 

Windows USB Stick (Created with Rufus):

  • Windows 10 (20H2 ISO)
  • Partition Scheme: GPT
  • Target System: UEFI (non CSM)
  • File System: FAT32

 

Install Process:

  1. Insert USB Installation Media in front yellow USB port.
  2. Power on and Press F10 and Select UEFI: Jetflash 8GB (my USB stick).
  3. Goes to Windows Setup.
  4. Use Shift-F10 and Diskpart to format drive to GPT.
  5. Continue with Installation.
  6. Installation completes.
  7. Reboots.
  8. Windows moves to Getting Devices Ready screen. Reaches 100%. Reboots.
  9. NUC boots back into Windows Setup.
  10. I unplug the USB stick, and close Windows Setup. NUC reboots.
  11. Error: A bootable device has not been found.
  12. I go back into the BIOS, and it has no issue detecting the NVMe, as under UEFI boot priority it shows the following:
    1. UEFI: Samsung SSD 950: Part 2: OS Bootloader
    2. UEFI: Samsung SSD 950: Part 3: OS Bootloader
    3. UEFI: Windows Boot Manager: Part 0: OS Bootloader
    4. UEFI: Windows Boot Manager: Part 0: OS Bootloader

I'm not sure what I'm doing wrong. Any help appreciated and please let me know if more info is needed.

Thanks,

Fahad

 

0 Kudos
9 Replies
LeonWaksman
Super User
1,119 Views

Hi Fahad,

You did almost every thing good, except the para.4 in your installation process (i.e. Use Shift-F10 and Diskpart to format drive to GPT). 

1. I suggest you to reinstall Windows using the following method:
2. Please prepare your installation media (you need 8GB – 32GB USB stick), using Microsoft Media Creation Tool. This will install version 2004.
3. Your bios should be set to default settings. Enter bios (press F2 during boot) and then press F9 (Y) to set defaults and F10 (Y) to save settings and exit.
4. With the installation media inserted into rear USB slot, power ON your NUC and repeatably press F10 to get Boot Menu.
5. In this menu, choose UEFI option of you Installation media.
6. Follow this tutorial to continue with installation.
7. In para. 9 you may enter Product Key from the Microsoft Distribution you bought or click on the I don't have a product key and Windows will be reactivated automatically, since it was activated on this computer.
8. Skip on para. 14 and continue in para. 15. Important, do not format drive where you want to install Windows, rather delete all existing partitions from this drive, till you see one unallocated space.
9. Press Next and continue with the installation.

Leon

fahdriyami
Beginner
1,109 Views

Thanks Leon,

I just tried this, following every step. Main differences this time was using the rear USB port and creating the installation media using the Windows Media Creation Tool. BIOS was reset to defaults as well.

Unfortunately the results are the same. I still end up with the error message.

LeonWaksman
Super User
1,093 Views

Hi Fahad,

1. In your first message you mentioned that after the installation fails in BIOS under UEFI Boot priority you can see the following lines:

  1. UEFI: Samsung SSD 950: Part 2: OS Bootloader
  2. UEFI: Samsung SSD 950: Part 3: OS Bootloader
  3. UEFI: Windows Boot Manager: Part 0: OS Bootloader
  4. UEFI: Windows Boot Manager: Part 0: OS Bootloader

Please boot into Boot Menu (BOOT Menu may be reached after clicking few times on F10 when you see the Intel NUC logo after power ON). In the Boot Menu move cursor to the "UEFI: Windows Boot Manager: Part 0: OS Bootloader" line and click on Enter.

2. Was the SSD the only one SSD installed in your NUC?

3. Is this new SSD or was it previously used for some other O.S. (Linux)?

Leon

 

fahdriyami
Beginner
1,066 Views

Unlike in the BIOS, in the F10 Boot Menu, only two entries show:

  1. UEFI: Samsung SSD 950: Part 2: OS Bootloader
  2. UEFI: Samsung SSD 950: Part 3: OS Bootloader

Clicking on any of them makes the screen go black for a second, and then its just back in the boot menu.

Only one SSD is installed in the system. I tried re-seating the SSD and moving it from Slot 1 to Slot 2, nothing changes.

This SSD was previously used for Windows and MacOS. Out of curiosity, I just tried installing Ubuntu on it, and it worked flawlessly. Then tried Windows again, but I still get the bootable device error.

fahdriyami
Beginner
1,059 Views

So something strange happened.

I decided to reinstall MacOS on the NUC, and when I prepared the USB drive (which uses OpenCore), and went into F10 to select it, it booted to the Windows OOBE and I am now in Windows.

This only works when the flash drive is plugged into one of the rear ports. If I remove the drive and restart, I get the bootable device not found error.

I'm not sure how to fix this.

LeonWaksman
Super User
1,048 Views

Hi Fahad,

That what I was suspecting: there is no problem with your NUC, it is rather problem with your SSD. The SSD has some old entries form macOS and/or Linux which where not cleaned during Windows installation.  I'm not an expert for Linux and I'm not familiar with macOS neither. I suggest that before you start to install Windows again,  wipe your SSD using following steps:

  1. Boot from your Windows 10 installation USB.
  2.  Select your language preferences and click/tap on Next.
  3.  Click/tap on Repair your computer at the bottom.
  4.  Click/tap on Troubleshoot.
  5.  Click/tap on Advanced options.
  6. Click on Command Prompt
  7. Run Diskpart
  8. Run List disk
  9. Run sel disk n (where n is the number of your system drive)
  10. Run clean all , your drive will be wiped.

 

Leon

 

 

fahdriyami
Beginner
1,035 Views

Hi Leon,

I've been trying to wrap my head around what is happening but things just keep getting stranger.

Here's what I did. I removed the SSD from the NUC, so now there is no storage device in it.

I then prepared a brand new Flash drive using the Windows Media Creation tool.

I plug in the flash drive into the NUC and go to the boot menu using F10. What do I see? One entry that says OpenCore. If I remove the flash drive, there is no entry. How did OpenCore get on this flash drive? I have no idea.

Now, if I also plug in the old flash drive (Ubuntu installation on it) alongside the new one, I now see two entries in the F10 menu:

  1. OpenCore
  2. UEFI: USB: Sandisk: Part 0: OS Bootloader

The only way, I can boot anything, is if I have two flash drives plugged in.

I suspect OpenCore is stored in the NVRAM, and I've been trying to clear it unsuccessfully. I tried unplugging the power plug and the motherboard battery in the NUC and leaving it without power overnight, but it doesnt seem to have worked.

I have no clue as to where OpenCore is lingering and why if I plug any single USB into the NUC, it shows as OpenCore in the F10 and BIOS entries.

I tried the diskpart clean all command on the USB flashdrives, same result, and this doesnt explain why OpenCore appears for a brand new flash drive.

I'm so confused.

LeonWaksman
Super User
1,029 Views

The Windows Installation USB, was created on Mac or Windows computer?

Leon

 

fahdriyami
Beginner
1,021 Views

It was created using Windows Media Creation Tool in Windows 10 20H2.

I've given up on installing Windows on this NUC. No matter what I try, OpenCore seems to have taken over. I went back to MacOS.

I did so by creating two USB flash drives for MacOS and plugged them both in. The NUC recognized only one of them. The second was merely to get the NUC to boot the other as per my previous experiment.

It worked. Managed to boot into OpenCore and use its built-in tool to clear the NVRAM. Unfortunately that didnt resolve the boot issues with Windows.

So I decided to give up on Windows and proceed with the MacOS install. It completed successfully, and I don't need to have a USB plugged in to boot. Thankfully no more bootable device missing errors either.

Thanks for taking the time to help me troubleshoot, Leon, I really appreciate it.

Reply