Community
cancel
Showing results for 
Search instead for 
Did you mean: 
WZz
Beginner
4,639 Views

NUC8i7HVK - Can I use the new radeon driver 18.6.1?

Hi, I just find there's a new vega m driver version 18.6.1, https://downloadcenter.intel.com/download/27881/Graphics-Radeon-RX-Vega-M-Graphics https://downloadcenter.intel.com/download/27881/Graphics-Radeon-RX-Vega-M-Graphics

is it the same as 64_24.20.11001.1028 ?

I just got my nuc, which one should I install? thanks

0 Kudos
28 Replies
MLevi
Valued Contributor I
342 Views

Walnuzh,

Scrolling down towards the bottom of the page is list of compatibility.

That's our baby.

This update works for me and represents driver version # 24.20.11020.2, Radeon version 17.7

Thanks for posting!

Mike

KBlak4
Beginner
342 Views

Doesn't work Mike,

It actually destroyed the running version - Intel driver check also stated incorrect driver. (but nothing new it tells me often I have incorrect drivers and when I install their recommended updates same result same driver) go figure.

Top and bottom wouldn't work until I reinstated from the NUC 8i7 Section.

The Real problem with most of what I'm seeing posting here which annoys me is the HDCP 2.2 handshake, that just doesn't work.

The real kicker was finding that a whole trail from Microsoft stating as such and they expect it to become a bigger issue as more people move towards 4K UHD (dated 2015)

There are a number of forums all with issues relating to the fact the machine just doesn't do what it's described to do when it comes to connectivity, not just Nuc

Microsoft fixed this for Xbox one S because of the Blu - ray player they added into it. funnily enough so did Sony with the PS Pro

I don't know why the collective group AMD, Intel, Microsoft aren't getting off their arse to fix it as they know what needs to be done.

Intel seem to think it's my job to fault find despite providing all the proof.

As for Microsoft they took the capability away in Windows 10 as they saw a DVD Blu-ray unnecessary, however they are willing to allow you to pay for the privilege of using the DVD player.

Intel you introduced the world to HDCP DRM about time you helped with the program instead of dreaming up what to do with 8K

MLevi
Valued Contributor I
342 Views

In the response from Toons, I want to point out the generalization he has used, as in "it doesn't work".

The finer point is it doesn't work for him and this DOES NOT MEAN that you will have issues.

It worked for me perfectly, and I suspect it will for others.

The steps for installation that I used:

1. Uninstall the existing Radeon driver

2. Uninstall the existing Intel driver

3. Install the latest Intel driver

4. Install the latest Radeon driver

RWash1
Beginner
342 Views

Mike,

Are you sure you don't have secure boot disabled on your system?

I tried using the new 18.6.1 driver on my HVK and when I installed it I saw that the yellow bang in Device Manager points to an error 56 relating to incorrectly signed drivers. I admit that I tried with mine with drivers in place rather than cleaning all current drivers out before installing. When I disabled secure boot in the bios though the new 18.6.1 drivers worked fine.

KBlak4
Beginner
342 Views

Cacnoff,

I clean installed just AMD = screwed - if this is truely the latest then why the errors and why isn't showing through complete structure, and why does it tell me it's wrong?

So I did it again and clean installed both because the Intel HD was newer than the one on the NUC page (once again why aren't the latest updates in one place, so I Clean installed both, Intel held, AMD still no joy as to the contrary of what Mike had just stated I actually tried it twice once using express and through custom which choosing that option, you can allow AMD to do a clean install. so deciding it's another dead end of contradictory evidence I went back to the way they I had it originally and I'll wait for intel to start getting their act together

When your being told to update things that are already there, info pages lead to another topic altogether you have to question who is actually looking this over and signing off on it. I wouldn't be signing off the updates without the right info in them, and revoking Publish access to the knowledge base till it's been fact checked and tested where required.

They also need to spend some more time on here and see what is going on with their systems and customers instead of relying on others and pleading ignorance as to matters they could help fix. Something I pointed out that was wrong they replicated first attempt in the lab and that was 3 weeks ago after starting to loose patience I saw it was actually a reported topic on here from 3 weeks prior. with no response.

We are only a number yes, when they turn from ones to zero's someone needs to start taking control.

RWash1
Beginner
342 Views

I think the NUC sub-forum has some of the most responsive support engineers out of anywhere on the intel communities forums.

Its also important to remember that while Downloadcenter is a single website it services most of the different groups of intel which all operate semi-autonomously from one another. NUC, ssd, wired networking, wireless networking, graphics, cpu, and so on. Those are all different groups at intel that all have different release schedules and goals.

As for why the graphics driver posted doesn't also have a shared posting for NUC, its possible that it is still being run through some extra validation, but who knows. Even AMD directly from their site list it as a BETA driver whatever that means. https://www2.ati.com/drivers/beta/win10-64bit-radeon-software-adrenalin-edition-18.6.1-june13.exe

And while some people are more helpful than others, and have good advice...unless you see a "on behalf of intel" response its an end-user trying to help.

MLevi
Valued Contributor I
342 Views

Critical thinking is important when considering anyone's post on forums, even Intel people.

The point is if you look on the download page, posted by the originator of this thread, the driver has been verified on the NUC8i7HVK configuration.

 

Does Intel sell another device with the exact same core and graphics combination that the arrow is pointing to?

In the absence of any other FACTS, this is the updated driver for the NUC8i7HVK, in my personal, and most humble opinion.

My configuration is a Standard, Out-of-The-Box NUC8i7HVK. The only thing I've done to modify is replace the thermal grease between the head plate and die.

Other than that, standard bios, standard drivers, nothing "unique" that would cause this unit to accept the driver.

I can't say that for the units that other's have tried this driver on.

Check out the download page ...

Important note: I also think that the updated Radeon driver is correct because it lags the Intel HD Graphics 630 by two weeks or so ... which makes sense to me because Intel just released the 630 driver recently. The Radeon driver had to be developed and tested against the Intel HD630 driver ... so with no evidence or FACTs to the contrary, my opinion is not changed that this is the correct and updated Radeon driver that works with version 24.20.100.6094 Intel HD 630 driver for the Intel NUC8i7HVK.

Finally - Intel appears to update the HD Graphics 630 drivers first and then test the Radeon RX Vega M GH drivers that get release a few weeks later, or so it appears.

Device ManagerIntel Driver 24.20.100.6094 Radeon Driver 24.20.11020.2 
MLevi
Valued Contributor I
342 Views

Hi Cacoff,

No bios changes since it arrived. It's literally configured (BIOS) as it came.

I don't use secure boot at all, or I don't think I do ... never had to set it or unset it.

How do this NUCs come configured? On or Off on the secure boot?

Mike

RWash1
Beginner
342 Views

Secure boot is enabled by default on the Hades Canyon Bios. At least it is when you set defaults in bios with F2.

"The point is if you look on the download page, posted by the originator of this thread, the driver has been verified on the NUC8i7HVK configuration.

Does Intel sell another device with the exact same core and graphics combination that the arrow is pointing to?"

Intel sells the 8809G to anyone that wants to build a system with that as the base, the fact that currently the only 8809G platform available is the NUC8i7HVK is coincidence alone.

Nothing in the driver posting or release notes points to NUC8i7HVK at all in fact, its only a reference to the i7-8809G alone.

Driver Version: 18.6.1

Release Version: Production Version

Release Date: June 13, 2018

Operating System(s):

Microsoft Windows* 10-64 - Anniversary Update

Microsoft Windows* 10-64 - Creators Update

Microsoft Windows* 10-64 - Fall Creators Update

Platforms:

8th Gen Intel(R) Core(TM) processor family (codename Kaby Lake G)

CONTENTS

I. Product Support

II. Installation Information

III. Disclaimer

I. Product Support

Supports Radeon™ RX Vega M Graphics on:

8th Gen Intel(R) Core(TM) processor family (codename Kaby Lake G)

II. Installation Information

This document makes references to products developed by Intel. There are some restrictions on how these products may be used, and what information may be disclosed to others. Please read the Disclaimer section and contact your Intel field representative if you would like more information.

III. Disclaimer

Intel is making no claims of usability, efficacy or warranty. The INTEL SOFTWARE LICENSE AGREEMENT contained herein completely defines the license and use of this software.

This document contains information on products in the design phase of development. The information here is subject to change without notice. Do not finalize a design with this information.

*Other names and brands may be claimed as the property of others.

I'll have to try mine with the newer igpu driver and 18.6.1 combination to see if there is some weird dependency between them.

MLevi
Valued Contributor I
342 Views

Hey Toons,

The sequence for updating the Radeon driver is posted here.

Essentially it means uninstalling in order, the old Radeon Driver and whatever Intel HD 630 Driver you have.

Then acquire the latest Intel driver, install that , and only then, install the new Radeon Driver.

/message/547829# 547829 5. /message/547829# 547829 Re: NUC8i7HVK Radeon driver problem

HannaJenJun 5, 2018 2:13 PM (/message/547433# 547433 in response to Zauze)

This message was posted on behalf of Intel Corporation

Hello Zauze

 

 

Thank you for your response.

 

We will need you to totally disconnect your machine from the internet, and then uninstall all the graphic drivers from you machine until the basic display driver is exposed.

In order to do it, please go ahead and click on the "Uninstalling the Intel Graphics Driver via the Device Manager Method" option on the following link:

 

https://www.intel.com/content/www/us/en/support/articles/000005598/graphics-drivers.html%3F_ga%3D2.1... https://www.intel.com/content/www/us/en/support/articles/000005598/graphics-drivers.html?_ga=2.12338...

 

Please note that you may need to reboot 2 or maybe 3 times your machine after uninstalling the drivers, so you can make sure that you got rid of them.

 

After that, please go ahead and perform a manual installation of the latest Radeon* Graphics Driver for Intel® NUC Kit NUC8i7HNK,, here's the direct download:

 

(original posted link): https://downloadcenter.intel.com/download/27723/NUCs-Radeon-Graphics-Driver-for-Intel-NUC-Kit-NUC8i7... https://downloadcenter.intel.com/download/27723/NUCs-Radeon-Graphics-Driver-for-Intel-NUC-Kit-NUC8i7...

(New Driver link): https://downloadcenter.intel.com/download/27877/NUCs-Radeon-Graphics-Driver-for-Intel-NUC-Kit-NUC8i7... Download Radeon* Graphics Driver for Intel® NUC Kit NUC8i7HNK, NUC8i7HVK

 

Please go ahead and try to update the drivers through a manual installation.

 

You will find all the steps here:

 

https://www.youtube.com/watch%3Fv%3DS1KzoQDjMMY https://www.youtube.com/watch?v=S1KzoQDjMMY

 

The content on the above site is not controlled by Intel. This information is offered for your convenience and should not be viewed as an endorsement by Intel for the merchants or services offered there.

 

 

I hope this helps.

 

 

Best regards.

 

Diego S.
MLevi
Valued Contributor I
342 Views

I know, it doesn't explicitly say NUC8i7HVK, but ... this happened the last time they updated the Radeon and the Intel drivers for this NUC and it took a few weeks for the driver to hit the "vanilla drivers download page" on Intel Support.

I do think that you're on the right track uninstalling all graphics drivers then reinstall Intel latest (for this NUC) and then the Radeon.

I'm not following the logic that 8809G's are sold to anyone and that this means it's only a coincidence that the our NUCs use these?

What is the difference between the 8809G's sold "to anyone", and 8809G's in the NUC8i7HVK?

Why is it "just coincidence" that our NUCs use the same CPU/GPU combination and why would Intel create drivers for other markets of 8809G buyer's that are not NUC8i7HVK?

RBoer1
Novice
342 Views

So we have these two drivers:

https://downloadcenter.intel.com/download/27881/Radeon-RX-Vega-M-Graphics?product=130409 Download Radeon™ RX Vega M Graphics (from 6/13/2018)

https://downloadcenter.intel.com/download/27877/NUCs-Radeon-Graphics-Driver-for-Intel-NUC-Kit-NUC8i7... Download Radeon* Graphics Driver for Intel® NUC Kit NUC8i7HNK, NUC8i7HVK (from 6/6/2018)

The first one doesn't work - after installing, the sound-volume control reports an error and there is no "Radeon RX Vega M Settings" icon. It has this state, Irrelevant of whether I uninstalled all drivers first - or tried a "clean" install (from within the ATI installer).

After having installed the one from 6/13, when trying to install the one from 6/6 it won't work ( installer reports missing files ), you need to manually uninstall the "AMD" driver from "Uninstall software". If do that, then the one from 6/6 it will install, you will get the Vega M Settings back and also sound-volume control will get back to normal. It will then look like this in the display settings screen (at least it has a more recent vulkan runtime, 1.1.70) - device manager reports driver version "24.20.11001.1028" and driver date "04/04/2018"

compared to the initial drivers I used when installing the NUC (GFX_Radeon_Win10_64_23.20.792.2048) which looks like this (vulkan 1.0.54):

So no clue what's up with the 6/16 drivers... I can see in MikeLevine's device-manager they have a way newer driver date... but they don't seem to work...

MLevi
Valued Contributor I
342 Views

Discovered a newer update to the Intel Graphics Driver for our NUCs.

Like the Radeon Driver, it's so new that it hasn't yet made the NUC8i7HVK Support/Download Page.

Again, installs perfectly in my configuration and works like a charm. Your experience may differ.

Important to follow the sequence of uninstalling all video drivers then installing Intel driver first, then the Radeon driver... see the post from the other day.

---

only if you already have the Radeon driver version showed below AND it is working>

Disable both display adapters using the Device Manager

Update the Intel driver *

Enable the Intel adapter first then enable the Radeon adapter

* you may be prompted to restart, I waited until after enabling the Radeon adapter.

---

https://downloadcenter.intel.com/product/98909/Intel-HD-Graphics-630 Downloads for Intel® HD Graphics 630

The link below is for the same version referred to in my post in this thread for the Radeon Driver for our NUCs

https://downloadcenter.intel.com/download/27881/Graphics-Radeon-RX-Vega-M-Graphics Download Radeon™ RX Vega M Graphics

WZz
Beginner
342 Views

@ MikeLevine

 

Thanks Mike, I followed your instructions, installed the newest intel HD driver first, reboot the nuc, installed the Radeon 18.6.1 driver, it works without any issue by far.

One thing to mention is I installed the drivers on a clean windows 10, I never installed any graphic drivers on it before.

The Radeon 18.6.1 comes with the radeon setting software too. It works like a charm. thanks again :-)

RBoer1
Novice
342 Views

Tried the link by MikeLevine and it seems Intel is on to something - I'll try it as soon as they put it back.

Available DownloadsWindows 10, 64-bit*

Language: English

Size: 0 MB

MD5: d41d8cd98f00b204e9800998ecf8427e

https://downloadmirror.intel.com/27881/eng/We%20will%20replace%20soon.txt We will replace soon.txt

IMPORTANT:

We detected an installation error within this version 18.6.1 of the Radeon™ RX Vega M graphics driver and are working to correct this quickly and repost as soon as possible. Please check back in 48 hours.

KBlak4
Beginner
342 Views

Yeah, depending on what you are running it crashes, I was able to complete the process as per details from Mike then out of the blue all yellow bang appeared and it liked it no more.

The intel UHD driver held but the .exe file from the radeon link is not digitally signed so it eventually gets rejected by your machine depending what OS and settings you are running.

The only thing you can do from there more or less is go back.to the previous working version unless you remove all software protection and have faith in everything being standalone it did seem to have another knock on effect too.

It's odd that they would publish an unsigned driver no matter which system you were installing it on.

As I although I agreed with Mike's logic and thought the same, I could never get it to hold even on a fresh install.

MLevi
Valued Contributor I
342 Views

Sorry to hear and it's strange that using the same process, same drivers results in such significant differences.

It seems that there might be configuration, OS, and hardware differences impacting OUR results.

Physcial

32GB Memory

500GB M.2. Slot 1 (Boot) [Drive c:\]

120GB m.2. Slot 2 (storage) [Drive m:\)

TB3 connections

Connected to DELL U3818DW via TB 3 connection

UA Arrow Audio Interface via TB 3 connection

OS

Windows 10 Pro 64 for Workstations

Fast-Ring Insider Preview

Current evaluation copy: Build 17692.rs_prerelease.180609-1317

BIOS Settings

Standard, it remains in the default state it was shipped in.

Special Configuration Notes:

  • The Pagefile and Swap file were relocated to the M:\ drive. I don't use it for anything else.
  • M:\
  • C:\

I use a 2x3TB, RAID 1 (Mirror) NAS System that is linked to my OneDrive so that I have physical and Cloud backups.

When both of the NAS drives failed last week I was glad to have the cloud (1.9GB of music, video, and Illustrator designs).

Advanced configuration Settings

MLevi
Valued Contributor I
342 Views

Confirmed, looks like they need to fix the Radeon driver installation.

KBlak4
Beginner
342 Views

Mike the 2 obvious differences I can see rather than using 2 SSD I have the wifi adaptor in the top end of the board and the second slot just has a 1TB Samsung 970 SSD

I also haven't went to RS5 beta yet which did look like it has some useful things in it.

KBlak4
Beginner
102 Views

Installed repaired version this morning it seems content now

Reply